gnu: gcc@11: Patch libpthread on GNU/Hurd.
* gnu/packages/gcc.scm (gcc-11)[arguments]: Add 'patch-hurd-libpthread' phase. * gnu/packages/patches/gcc-11-libstdc++-hurd-libpthread.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Co-authored-by: Ludovic Courtès <ludo@gnu.org>master
parent
bbb849f11f
commit
6cdd444a56
|
@ -1181,6 +1181,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/gcc-9-strmov-store-file-names.patch \
|
%D%/packages/patches/gcc-9-strmov-store-file-names.patch \
|
||||||
%D%/packages/patches/gcc-12-strmov-store-file-names.patch \
|
%D%/packages/patches/gcc-12-strmov-store-file-names.patch \
|
||||||
%D%/packages/patches/gcc-10-cross-environment-variables.patch \
|
%D%/packages/patches/gcc-10-cross-environment-variables.patch \
|
||||||
|
%D%/packages/patches/gcc-11-libstdc++-hurd-libpthread.patch \
|
||||||
%D%/packages/patches/gcc-12-cross-environment-variables.patch \
|
%D%/packages/patches/gcc-12-cross-environment-variables.patch \
|
||||||
%D%/packages/patches/gcc-10-tree-sra-union-handling.patch \
|
%D%/packages/patches/gcc-10-tree-sra-union-handling.patch \
|
||||||
%D%/packages/patches/gcolor3-update-libportal-usage.patch \
|
%D%/packages/patches/gcolor3-update-libportal-usage.patch \
|
||||||
|
|
|
@ -706,7 +706,18 @@ It also includes runtime support libraries for these languages.")
|
||||||
"gcc-10-tree-sra-union-handling.patch"))
|
"gcc-10-tree-sra-union-handling.patch"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet gcc-canadian-cross-objdump-snippet)))
|
(snippet gcc-canadian-cross-objdump-snippet)))
|
||||||
|
(arguments
|
||||||
|
(substitute-keyword-arguments (package-arguments gcc-8)
|
||||||
|
((#:phases phases #~%standard-phases)
|
||||||
|
(if (target-hurd?)
|
||||||
|
#~(modify-phases #$phases
|
||||||
|
(add-after 'unpack 'patch-hurd-libpthread
|
||||||
|
(lambda _
|
||||||
|
(define patch
|
||||||
|
#$(local-file
|
||||||
|
(search-patch "gcc-11-libstdc++-hurd-libpthread.patch")))
|
||||||
|
(invoke "patch" "--force" "-p1" "-i" patch))))
|
||||||
|
phases))))
|
||||||
(properties
|
(properties
|
||||||
`((compiler-cpu-architectures
|
`((compiler-cpu-architectures
|
||||||
("aarch64" ,@%gcc-11-aarch64-micro-architectures)
|
("aarch64" ,@%gcc-11-aarch64-micro-architectures)
|
||||||
|
|
|
@ -0,0 +1,62 @@
|
||||||
|
From f0065f207cf19cd960b33d961472c6d69514336f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Samuel Thibault <samuel.thibault@gnu.org>
|
||||||
|
Date: Fri, 7 Oct 2022 22:45:06 +0200
|
||||||
|
Subject: [PATCH] libstdc++: Mark pieces of gnu-linux/os_support.h
|
||||||
|
linux-specific
|
||||||
|
|
||||||
|
This is notably needed because in glibc 2.34, the move of pthread functions
|
||||||
|
into libc.so happened for Linux only, not GNU/Hurd.
|
||||||
|
|
||||||
|
The pthread_self() function can also always be used fine as it is on
|
||||||
|
GNU/Hurd.
|
||||||
|
|
||||||
|
libstdc++-v3/ChangeLog:
|
||||||
|
|
||||||
|
* config/os/gnu-linux/os_defines.h [!__linux__]
|
||||||
|
(_GLIBCXX_NATIVE_THREAD_ID, _GLIBCXX_GTHREAD_USE_WEAK): Do not define.
|
||||||
|
|
||||||
|
Reviewed-by: Jonathan Wakely <jwakely@redhat.com>
|
||||||
|
---
|
||||||
|
libstdc++-v3/config/os/gnu-linux/os_defines.h | 22 +++++++++++--------
|
||||||
|
1 file changed, 13 insertions(+), 9 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/libstdc++-v3/config/os/gnu-linux/os_defines.h b/libstdc++-v3/config/os/gnu-linux/os_defines.h
|
||||||
|
index 3064f8d908ac2..87317031fcd71 100644
|
||||||
|
--- a/libstdc++-v3/config/os/gnu-linux/os_defines.h
|
||||||
|
+++ b/libstdc++-v3/config/os/gnu-linux/os_defines.h
|
||||||
|
@@ -60,22 +60,26 @@
|
||||||
|
# define _GLIBCXX_HAVE_FLOAT128_MATH 1
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if __GLIBC_PREREQ(2, 27)
|
||||||
|
+#ifdef __linux__
|
||||||
|
+// The following libpthread properties only apply to Linux, not GNU/Hurd.
|
||||||
|
+
|
||||||
|
+# if __GLIBC_PREREQ(2, 27)
|
||||||
|
// Since glibc 2.27 pthread_self() is usable without linking to libpthread.
|
||||||
|
-# define _GLIBCXX_NATIVE_THREAD_ID pthread_self()
|
||||||
|
-#else
|
||||||
|
+# define _GLIBCXX_NATIVE_THREAD_ID pthread_self()
|
||||||
|
+# else
|
||||||
|
// Before then it was in libc.so.6 but not libc.a, and always returns 0,
|
||||||
|
// which breaks the invariant this_thread::get_id() != thread::id{}.
|
||||||
|
// So only use it if we know the libpthread version is available.
|
||||||
|
// Otherwise use (__gthread_t)1 as the ID of the main (and only) thread.
|
||||||
|
-# define _GLIBCXX_NATIVE_THREAD_ID \
|
||||||
|
- (__gthread_active_p() ? __gthread_self() : (__gthread_t)1)
|
||||||
|
-#endif
|
||||||
|
+# define _GLIBCXX_NATIVE_THREAD_ID \
|
||||||
|
+ (__gthread_active_p() ? __gthread_self() : (__gthread_t)1)
|
||||||
|
+# endif
|
||||||
|
|
||||||
|
-#if __GLIBC_PREREQ(2, 34)
|
||||||
|
+# if __GLIBC_PREREQ(2, 34)
|
||||||
|
// Since glibc 2.34 all pthreads functions are usable without linking to
|
||||||
|
// libpthread.
|
||||||
|
-# define _GLIBCXX_GTHREAD_USE_WEAK 0
|
||||||
|
-#endif
|
||||||
|
+# define _GLIBCXX_GTHREAD_USE_WEAK 0
|
||||||
|
+# endif
|
||||||
|
+#endif // __linux__
|
||||||
|
|
||||||
|
#endif
|
Reference in New Issue