me
/
guix
Archived
1
0
Fork 0

gnu: sbcl-geco: Update to 2.1.1.

* gnu/packages/lisp-xyz.scm (sbcl-geco): Update to 2.1.1.
  [source]: Fetch from Github.
  [home-page]: Update to author's page.
* gnu/packages/patches/sbcl-geco-fix-organism-class.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Guillaume Le Vaillant 2020-12-11 18:08:00 +01:00
parent 4a084c7a7b
commit 6e301c3a53
No known key found for this signature in database
GPG Key ID: 6BE8208ADF21FE3F
3 changed files with 8 additions and 21 deletions

View File

@ -1596,7 +1596,6 @@ dist_patch_DATA = \
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
%D%/packages/patches/rxvt-unicode-escape-sequences.patch \
%D%/packages/patches/sbcl-clml-fix-types.patch \
%D%/packages/patches/sbcl-geco-fix-organism-class.patch \
%D%/packages/patches/scalapack-blacs-mpi-deprecations.patch \
%D%/packages/patches/scheme48-tests.patch \
%D%/packages/patches/scotch-build-parallelism.patch \

View File

@ -11234,17 +11234,18 @@ XML to Lisp structures or s-expressions and back.")
(define-public sbcl-geco
(package
(name "sbcl-geco")
(version "2.01a")
(version "2.1.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://common-lisp.net/project/geco/download/"
"geco-" version ".tar.gz"))
(method git-fetch)
(uri (git-reference
(url "https://github.com/gpwwjr/GECO")
(commit (string-append "v" version))))
(file-name (git-file-name "geco" version))
(sha256
(base32 "0kk0bzr1019cfmf2b1jl1rk9shv3gx5z1znifxllg9mb98yqsgw0"))
(patches (search-patches "sbcl-geco-fix-organism-class.patch"))))
(base32 "1rc8a4mk40hjx5qy980hjylv6xxqdbq38hg8c4w30y93abfd519s"))))
(build-system asdf-build-system/sbcl)
(home-page "https://common-lisp.net/project/geco/")
(home-page "http://hiwaay.net/~gpw/geco/geco.html")
(synopsis "Genetic algorithm toolkit for Common Lisp")
(description
"GECO (Genetic Evolution through Combination of Objects) is an extensible,

View File

@ -1,13 +0,0 @@
Fix the ORGANISM class so that SBCL >= 2.0.9 can compile it without error.
--- a/classes.lisp 2020-10-28 12:11:10.725659464 +0100
+++ b/classes.lisp 2020-10-31 17:34:36.822752447 +0100
@@ -148,7 +148,7 @@
:accessor score
:initarg :score
:initform 'nil
- :type number)
+ :type (or number null))
(NORMALIZED-SCORE
:accessor normalized-score
:initarg :normalized-score