From 6e4b1b450cf3b8ab431b5923d411bb3de85ecada Mon Sep 17 00:00:00 2001
From: cage <cage-dev@twistfold.it>
Date: Tue, 12 Mar 2024 20:42:21 +0100
Subject: [PATCH] gnu: cl-croatoan: Update to 0.2-1.282145f.

* gnu/packages/lisp-xyz.scm (sbcl-croatoan): Update to 0.2-1.282145f.

Change-Id: I8a7e93e9f0dabfa42e35845e610dd5bd2b63cec9
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
---
 gnu/packages/lisp-xyz.scm | 62 ++++++++++++++++++++-------------------
 1 file changed, 32 insertions(+), 30 deletions(-)

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ea13b467dd..ec9bf3a9ca 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19108,37 +19108,39 @@ protocol for Mastodon.")
   (sbcl-package->cl-source-package sbcl-tooter))
 
 (define-public sbcl-croatoan
-  (package
-    (name "sbcl-croatoan")
-    (version "0.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/McParen/croatoan")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name "cl-croatoan" version))
-       (sha256
-        (base32 "0x2rlckyn8kn5mqy0fib8piggz694g3naarz2dvha1hsy4jhb1wg"))))
-    (build-system asdf-build-system/sbcl)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-paths
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "ncurses/ncurses.lisp"
-               (("libncursesw.so")
-                (search-input-file inputs "/lib/libncursesw.so"))))))))
-    (inputs
-     (list ncurses
-           sbcl-cffi
-           sbcl-trivial-gray-streams
-           sbcl-bordeaux-threads))
-    (synopsis "Common Lisp bindings for the ncurses terminal library")
-    (description "Croatoan provides high-level Common Lisp CLOS bindings for
+  (let ((commit "282145ff9e9005fddc4241bc6827b3ab09c5bd25")
+        (revision "1"))
+    (package
+      (name "sbcl-croatoan")
+      (version (git-version "2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/McParen/croatoan")
+               (commit commit)))
+         (file-name (git-file-name "cl-croatoan" version))
+         (sha256
+          (base32 "021h2f2yj4j9gynr3k7qi36x94jm5b95p3vaddbaih96wyzgbmq5"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'fix-paths
+             (lambda* (#:key inputs #:allow-other-keys)
+               (substitute* "ncurses/ncurses.lisp"
+                 (("libncursesw.so")
+                  (search-input-file inputs "/lib/libncursesw.so"))))))))
+      (inputs
+       (list ncurses
+             sbcl-cffi
+             sbcl-trivial-gray-streams
+             sbcl-bordeaux-threads))
+      (synopsis "Common Lisp bindings for the ncurses terminal library")
+      (description "Croatoan provides high-level Common Lisp CLOS bindings for
 the ncurses terminal library.")
-    (home-page "https://github.com/McParen/croatoan")
-    (license license:expat)))
+      (home-page "https://github.com/McParen/croatoan")
+      (license license:expat))))
 
 (define-public ecl-croatoan
   (sbcl-package->ecl-package sbcl-croatoan))