gnu: cmake: Update patch to work with new system.
* gnu/packages/patches/cmake-fix-tests.patch: Update to work with -p1. * gnu/packages/cmake.scm (cmake): Drop patch flag -p0.master
parent
487da56570
commit
6eac909b45
|
@ -41,7 +41,6 @@
|
|||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:test-target "test"
|
||||
#:patch-flags '("-p0")
|
||||
#:phases (alist-replace
|
||||
'configure
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- Tests/CMakeLists.txt 2013-03-20 22:57:13.000000000 +0100
|
||||
+++ Tests/CMakeLists.txt 2013-03-20 22:58:02.000000000 +0100
|
||||
--- a/Tests/CMakeLists.txt 2013-03-20 22:57:13.000000000 +0100
|
||||
+++ b/Tests/CMakeLists.txt 2013-03-20 22:58:02.000000000 +0100
|
||||
@@ -1706,16 +1706,17 @@
|
||||
PASS_REGULAR_EXPRESSION "Could not find executable"
|
||||
FAIL_REGULAR_EXPRESSION "SegFault")
|
||||
|
@ -28,8 +28,8 @@
|
|||
|
||||
configure_file(
|
||||
"${CMake_SOURCE_DIR}/Tests/CTestTestConfigFileInBuildDir/test1.cmake.in"
|
||||
--- Utilities/cmcurl/CMakeLists.txt 2013-03-20 22:57:13.000000000 +0100
|
||||
+++ Utilities/cmcurl/CMakeLists.txt 2013-03-20 23:08:41.000000000 +0100
|
||||
--- a/Utilities/cmcurl/CMakeLists.txt 2013-03-20 22:57:13.000000000 +0100
|
||||
+++ b/Utilities/cmcurl/CMakeLists.txt 2013-03-20 23:08:41.000000000 +0100
|
||||
@@ -729,8 +729,9 @@
|
||||
ADD_EXECUTABLE(LIBCURL Testing/curltest.c)
|
||||
TARGET_LINK_LIBRARIES(LIBCURL cmcurl ${CMAKE_DL_LIBS})
|
||||
|
|
Reference in New Issue