me
/
guix
Archived
1
0
Fork 0

gnu: guile@3.0.8: Add patch to address continuation memory leak.

* gnu/packages/patches/guile-continuation-stack-leak.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/guile.scm (guile-3.0-latest)[source]: Use it.
master
Ludovic Courtès 2022-11-06 12:32:58 +01:00
parent 905443abb7
commit 7138ba34fa
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 30 additions and 1 deletions

View File

@ -1274,6 +1274,7 @@ dist_patch_DATA = \
%D%/packages/patches/guile-linux-syscalls.patch \ %D%/packages/patches/guile-linux-syscalls.patch \
%D%/packages/patches/guile-3.0-linux-syscalls.patch \ %D%/packages/patches/guile-3.0-linux-syscalls.patch \
%D%/packages/patches/guile-ac-d-bus-fix-tests.patch \ %D%/packages/patches/guile-ac-d-bus-fix-tests.patch \
%D%/packages/patches/guile-continuation-stack-leak.patch \
%D%/packages/patches/guile-cross-compilation.patch \ %D%/packages/patches/guile-cross-compilation.patch \
%D%/packages/patches/guile-fibers-destroy-peer-schedulers.patch \ %D%/packages/patches/guile-fibers-destroy-peer-schedulers.patch \
%D%/packages/patches/guile-fibers-epoll-instance-is-dead.patch \ %D%/packages/patches/guile-fibers-epoll-instance-is-dead.patch \

View File

@ -399,7 +399,8 @@ without requiring the source code to be rewritten.")
(sha256 (sha256
(base32 (base32
"04wagg0zr0sib0w9ly5jm91jplgfigzfgmy8fjdlx07jaq50d9ys")) "04wagg0zr0sib0w9ly5jm91jplgfigzfgmy8fjdlx07jaq50d9ys"))
(patches (search-patches "guile-cross-compilation.patch")))) (patches (search-patches "guile-cross-compilation.patch"
"guile-continuation-stack-leak.patch"))))
(arguments (arguments
(substitute-keyword-arguments (package-arguments guile-3.0) (substitute-keyword-arguments (package-arguments guile-3.0)
;; Guile 3.0.8 is bit-reproducible when built in parallel, thanks to ;; Guile 3.0.8 is bit-reproducible when built in parallel, thanks to

View File

@ -0,0 +1,27 @@
This patch fixes a memory leak when capturing and resuming delimited
continuations intensively, as is the case with the Shepherd 0.9+:
https://issues.guix.gnu.org/59021
diff --git a/libguile/vm.c b/libguile/vm.c
index 6fd5c554f..516bae773 100644
--- a/libguile/vm.c
+++ b/libguile/vm.c
@@ -165,11 +165,13 @@ capture_stack (union scm_vm_stack_element *stack_top,
scm_t_dynstack *dynstack, uint32_t flags)
{
struct scm_vm_cont *p;
+ size_t stack_size;
- p = scm_gc_malloc (sizeof (*p), "capture_vm_cont");
- p->stack_size = stack_top - sp;
- p->stack_bottom = scm_gc_malloc (p->stack_size * sizeof (*p->stack_bottom),
- "capture_vm_cont");
+ stack_size = stack_top - sp;
+ p = scm_gc_malloc (sizeof (*p) + stack_size * sizeof (*p->stack_bottom),
+ "capture_vm_cont");
+ p->stack_size = stack_size;
+ p->stack_bottom = (void *) ((char *) p + sizeof (*p));
p->vra = vra;
p->mra = mra;
p->fp_offset = stack_top - fp;