From 71a438dcba391022fbbc41a1703f3172bae9c63c Mon Sep 17 00:00:00 2001
From: Sergey Trofimov <sarg@sarg.org.ru>
Date: Mon, 1 May 2023 18:18:42 +0200
Subject: [PATCH] gnu: git-crypt: Fix build issues on OpenSSL 3.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/version-control.scm (git-crypt)[arguments]: In 'build'
phase, set 'CXXFLAGS'.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/version-control.scm | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4fbf3b4d05..4bdf63cc63 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -937,6 +937,10 @@ write native speed custom Git applications in any language with bindings.")
              #t))
          (replace 'build
            (lambda _
+             ;; Add flag to work around OpenSSL 3 incompatibility.
+             ;; See <https://github.com/AGWA/git-crypt/issues/232>.
+             (setenv "CXXFLAGS" "-DOPENSSL_API_COMPAT=0x30000000L")
+
              (invoke "make" "ENABLE_MAN=yes")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)