gnu: python-flask-restful: Update to 0.3.9.
* gnu/packages/python-web.scm (python-flask-restful): Update to 0.3.9. [source]: Remove patch. [build-system]: Use pyproject-build-system. [arguments]: Disable "test_redirect" test; remove 'fix-imports phase. [native-inputs]: Replace python-nose with python-pytest. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/python-flask-restful-werkzeug-compat.patch: Remove file.
parent
461dff2651
commit
71dc990f22
|
@ -1728,7 +1728,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-docopt-pytest6-compat.patch \
|
||||
%D%/packages/patches/python-execnet-read-only-fix.patch \
|
||||
%D%/packages/patches/python-fixtures-remove-monkeypatch-test.patch \
|
||||
%D%/packages/patches/python-flask-restful-werkzeug-compat.patch \
|
||||
%D%/packages/patches/python-ipython-documentation-chars.patch \
|
||||
%D%/packages/patches/python-ipython-documentation-repro.patch \
|
||||
%D%/packages/patches/python-keras-integration-test.patch \
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
We need one patch on top of 0.3.8 for compatibility with Werkzeug 1.0.
|
||||
|
||||
Taken from upstream:
|
||||
https://github.com/flask-restful/flask-restful/commit/73376a488907af3042b52678ac4c23f8a8911e5b
|
||||
|
||||
diff --git a/tests/test_api.py b/tests/test_api.py
|
||||
index f7f8e661..6795d362 100644
|
||||
--- a/tests/test_api.py
|
||||
+++ b/tests/test_api.py
|
||||
@@ -445,7 +445,9 @@ def test_handle_non_api_error(self):
|
||||
|
||||
resp = app.get("/foo")
|
||||
self.assertEquals(resp.status_code, 404)
|
||||
- self.assertEquals('text/html', resp.headers['Content-Type'])
|
||||
+ # in newer versions of werkzeug this is `text/html; charset=utf8`
|
||||
+ content_type, _, _ = resp.headers['Content-Type'].partition(';')
|
||||
+ self.assertEquals('text/html', content_type)
|
||||
|
||||
def test_non_api_error_404_catchall(self):
|
||||
app = Flask(__name__)
|
||||
diff --git a/tests/test_reqparse.py b/tests/test_reqparse.py
|
||||
index 2f1fbedf..9776f17c 100644
|
||||
--- a/tests/test_reqparse.py
|
||||
+++ b/tests/test_reqparse.py
|
||||
@@ -2,9 +2,9 @@
|
||||
import unittest
|
||||
from mock import Mock, patch
|
||||
from flask import Flask
|
||||
-from werkzeug import exceptions, MultiDict
|
||||
+from werkzeug import exceptions
|
||||
from werkzeug.wrappers import Request
|
||||
-from werkzeug.datastructures import FileStorage
|
||||
+from werkzeug.datastructures import FileStorage, MultiDict
|
||||
from flask_restful.reqparse import Argument, RequestParser, Namespace
|
||||
import six
|
||||
import decimal
|
|
@ -3924,35 +3924,28 @@ apps.")
|
|||
(define-public python-flask-restful
|
||||
(package
|
||||
(name "python-flask-restful")
|
||||
(version "0.3.8")
|
||||
(version "0.3.9")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "Flask-RESTful" version))
|
||||
(patches (search-patches "python-flask-restful-werkzeug-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"05b9lzx5yc3wgml2bcq50lq35h66m8zpj6dc9advcb5z3acsbaay"))))
|
||||
(build-system python-build-system)
|
||||
"0gm5dz088v3d2k1dkcp9b3nnqpkk0fp2jly870hijj2xhc5nbv6c"))))
|
||||
(build-system pyproject-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'fix-imports
|
||||
(lambda _
|
||||
(substitute* "flask_restful/__init__.py"
|
||||
(("flask\\.helpers") "flask.scaffold")))))))
|
||||
;; This test fails because '/' is not 'http://localhost/'.
|
||||
(list #:test-flags '(list "-k" "not test_redirect")))
|
||||
(propagated-inputs
|
||||
(list python-aniso8601 python-flask python-pytz))
|
||||
(list python-aniso8601 python-flask python-pytz))
|
||||
(native-inputs
|
||||
(list ;; Optional dependency of Flask. Tests need it.
|
||||
python-blinker python-mock ; For tests
|
||||
python-nose)) ;for tests
|
||||
(home-page
|
||||
"https://www.github.com/flask-restful/flask-restful/")
|
||||
(synopsis
|
||||
"Flask module for creating REST APIs")
|
||||
(list python-blinker
|
||||
python-mock
|
||||
python-pytest))
|
||||
(home-page "https://www.github.com/flask-restful/flask-restful/")
|
||||
(synopsis "Flask module for creating REST APIs")
|
||||
(description
|
||||
"This package contains a Flask module for creating REST APIs.")
|
||||
"This package contains a Flask module for creating REST APIs.")
|
||||
(license license:bsd-3)))
|
||||
|
||||
(define-public python-flask-basicauth
|
||||
|
|
Reference in New Issue