me
/
guix
Archived
1
0
Fork 0

gnu: genimage: Update to 14-1.11bb044.

Update to commit 11bb04455 to integrate fixes related to new genext2fs and
e2fsprogs versions.

* gnu/packages/genimage.scm (genimage): Update to 14-1.11bb044.
[arguments]{fix-failing-tests}: Update it.
* gnu/packages/patches/genimage-mke2fs-test.patch: Update it.
master
Mathieu Othacehe 2021-11-21 11:22:45 +00:00
parent e74bcbc64f
commit 72501a555e
No known key found for this signature in database
GPG Key ID: 8354763531769CA6
2 changed files with 98 additions and 96 deletions

View File

@ -41,18 +41,20 @@
#:use-module (gnu packages virtualization))
(define-public genimage
(let ((commit "11bb04455eaf5434f0723c91a2224918ebd0a196")
(revision "1"))
(package
(name "genimage")
(version "14")
(version (git-version "14" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/pengutronix/genimage")
(commit (string-append "v" version))))
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
"1l45djpbaffhyw0allq3mgzwrdilk05iyj0nvp8l3s47vnp5bnbs"))
"1dq3lk0awk12v2aidry35gvrci5a3nr6rzcq0j9hyyf0w1z1rn0l"))
(patches
(search-patches "genimage-mke2fs-test.patch"))))
(build-system gnu-build-system)
@ -90,11 +92,11 @@
(lambda _
;; We don't have /etc/passwd so uid 0 is not known as "root".
;; Thus patch it out.
(substitute* '("test/ext2test.dump"
"test/ext3test.dump"
"test/ext4test.dump"
"test/ext2test-percent.dump"
"test/mke2fs.dump")
(substitute* '("test/ext2test.0.dump"
"test/ext3test.0.dump"
"test/ext4test.0.dump"
"test/ext2test-percent.0.dump"
"test/mke2fs.0.dump")
(("root") "unknown"))))
(add-before 'check 'setenv-check
(lambda _
@ -133,4 +135,4 @@
(description "@command{genimage} creates Flash images according to a
specification file.")
(home-page "https://github.com/pengutronix/genimage")
(license license:gpl2)))
(license license:gpl2))))

View File

@ -1,8 +1,8 @@
diff --git a/test/mke2fs.dump b/test/mke2fs.dump
index 8e63662..0c25798 100644
--- a/test/mke2fs.dump
+++ b/test/mke2fs.dump
@@ -11,7 +11,7 @@ Filesystem OS type: Linux
--- a/test/mke2fs.0.dump
+++ b/test/mke2fs.0.dump
@@ -11,7 +11,7 @@
Inode count: 8192
Block count: 32768
Reserved block count: 1638
@ -11,7 +11,7 @@ index 8e63662..0c25798 100644
Free inodes: 8141
First block: 1
Block size: 1024
@@ -29,7 +29,7 @@ Mount count: 0
@@ -29,7 +29,7 @@
Maximum mount count: -1
Last checked: Sat Jan 1 00:00:00 2000
Check interval: 0 (<none>)
@ -20,7 +20,7 @@ index 8e63662..0c25798 100644
Reserved blocks uid: 0 (user root)
Reserved blocks gid: 0 (group root)
First inode: 11
@@ -49,13 +49,13 @@ Journal sequence: 0x00000001
@@ -51,13 +51,13 @@
Journal start: 0