gnu: quassel: Update to 0.12.5.
* gnu/packages/irc.scm (quassel): Update to 0.12.5. [source]: Remove patch. * gnu/packages/patches/quassel-fix-tls-check.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
1c51b7b4bc
commit
72dae07296
|
@ -1063,7 +1063,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/qtbase-use-TZDIR.patch \
|
%D%/packages/patches/qtbase-use-TZDIR.patch \
|
||||||
%D%/packages/patches/qtscript-disable-tests.patch \
|
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||||
%D%/packages/patches/quagga-reproducible-build.patch \
|
%D%/packages/patches/quagga-reproducible-build.patch \
|
||||||
%D%/packages/patches/quassel-fix-tls-check.patch \
|
|
||||||
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
||||||
%D%/packages/patches/rapicorn-isnan.patch \
|
%D%/packages/patches/rapicorn-isnan.patch \
|
||||||
%D%/packages/patches/raptor2-heap-overflow.patch \
|
%D%/packages/patches/raptor2-heap-overflow.patch \
|
||||||
|
|
|
@ -65,18 +65,17 @@
|
||||||
(define-public quassel
|
(define-public quassel
|
||||||
(package
|
(package
|
||||||
(name "quassel")
|
(name "quassel")
|
||||||
(version "0.12.4")
|
(version "0.12.5")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://quassel-irc.org/pub/quassel-"
|
(uri (string-append "http://quassel-irc.org/pub/quassel-"
|
||||||
version ".tar.bz2"))
|
version ".tar.bz2"))
|
||||||
(patches (search-patches "quassel-fix-tls-check.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0ka456fb8ha3w7g74xlzfg6w4azxjjxgrhl4aqpbwg3lnd6fbr4k"))
|
"1qkl3sb4ijx4k17m0c42j2p5bc4jymypwhmplm942rbrzm6mg50q"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
;; We don't want to install the bundles scripts
|
;; We don't want to install the bundled scripts.
|
||||||
(snippet
|
(snippet
|
||||||
'(begin
|
'(begin
|
||||||
(delete-file-recursively "data/scripts")
|
(delete-file-recursively "data/scripts")
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
This allows quasselclient to connect to SSL-enabled quasselcore instances.
|
|
||||||
|
|
||||||
The check in qglobal.h requires -fPIC (not -fPIE as it is now). When this check
|
|
||||||
fails SSL / TLS is disabled.
|
|
||||||
|
|
||||||
This patch comes from the upstream source repository [0] and can be
|
|
||||||
removed when the next version is packaged.
|
|
||||||
|
|
||||||
[0] https://github.com/quassel/quassel/commit/4768c9e99f99b581d4e32e797db91d0182391696
|
|
||||||
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -428,6 +428,11 @@ endif()
|
|
||||||
cmake_push_check_state(RESET)
|
|
||||||
set(CMAKE_REQUIRED_INCLUDES ${QT_INCLUDES} ${Qt5Core_INCLUDE_DIRS})
|
|
||||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
|
|
||||||
+
|
|
||||||
+if (USE_QT5 AND Qt5_POSITION_INDEPENDENT_CODE)
|
|
||||||
+ set(CMAKE_REQUIRED_FLAGS "-fPIC -DQT_NO_VERSION_TAGGING")
|
|
||||||
+endif()
|
|
||||||
+
|
|
||||||
check_cxx_source_compiles("
|
|
||||||
#include \"qglobal.h\"
|
|
||||||
#if defined QT_NO_SSL
|
|
||||||
|
|
Reference in New Issue