gnu: openssh: Update to 9.4p1.
* gnu/packages/ssh.scm (openssh): Update to 9.4p1. [source]: Remove upstreamed Hurd patch. * gnu/packages/patches/openssh-hurd.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
8b40e1ea15
commit
72e2bbebf5
|
@ -1684,7 +1684,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/openjdk-15-xcursor-no-dynamic.patch \
|
%D%/packages/patches/openjdk-15-xcursor-no-dynamic.patch \
|
||||||
%D%/packages/patches/openmpi-mtl-priorities.patch \
|
%D%/packages/patches/openmpi-mtl-priorities.patch \
|
||||||
%D%/packages/patches/openmw-assume-nonconst-SIGSTKSZ.patch \
|
%D%/packages/patches/openmw-assume-nonconst-SIGSTKSZ.patch \
|
||||||
%D%/packages/patches/openssh-hurd.patch \
|
|
||||||
%D%/packages/patches/openssh-trust-guix-store-directory.patch \
|
%D%/packages/patches/openssh-trust-guix-store-directory.patch \
|
||||||
%D%/packages/patches/openresolv-restartcmd-guix.patch \
|
%D%/packages/patches/openresolv-restartcmd-guix.patch \
|
||||||
%D%/packages/patches/openrgb-unbundle-hueplusplus.patch \
|
%D%/packages/patches/openrgb-unbundle-hueplusplus.patch \
|
||||||
|
|
|
@ -1,30 +0,0 @@
|
||||||
Author: Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
|
|
||||||
Not upstreamed.
|
|
||||||
|
|
||||||
From 1ddae040d67e9a4ebcc3e1b95af1bff12c0f086b Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
|
|
||||||
Date: Tue, 7 Apr 2020 17:41:05 +0200
|
|
||||||
Subject: [PATCH] Build fix for the Hurd.
|
|
||||||
|
|
||||||
* gss-serv.c (ssh_gssapi_acquire_cred): Use HOST_NAME_MAX instead of
|
|
||||||
MAXHOSTNAMELEN.
|
|
||||||
---
|
|
||||||
gss-serv.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/gss-serv.c b/gss-serv.c
|
|
||||||
index 1d47870e7..22081c6f1 100644
|
|
||||||
--- a/gss-serv.c
|
|
||||||
+++ b/gss-serv.c
|
|
||||||
@@ -107,7 +107,7 @@ ssh_gssapi_acquire_cred(Gssctxt *ctx)
|
|
||||||
gss_create_empty_oid_set(&status, &oidset);
|
|
||||||
gss_add_oid_set_member(&status, ctx->oid, &oidset);
|
|
||||||
|
|
||||||
- if (gethostname(lname, MAXHOSTNAMELEN)) {
|
|
||||||
+ if (gethostname(lname, HOST_NAME_MAX)) {
|
|
||||||
gss_release_oid_set(&status, &oidset);
|
|
||||||
return (-1);
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.26.0
|
|
||||||
|
|
|
@ -198,16 +198,15 @@ a server that supports the SSH-2 protocol.")
|
||||||
(define-public openssh
|
(define-public openssh
|
||||||
(package
|
(package
|
||||||
(name "openssh")
|
(name "openssh")
|
||||||
(version "9.3p2")
|
(version "9.4p1")
|
||||||
(source (origin
|
(source
|
||||||
(method url-fetch)
|
(origin
|
||||||
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
|
(method url-fetch)
|
||||||
"openssh-" version ".tar.gz"))
|
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
|
||||||
(patches (search-patches "openssh-hurd.patch"
|
"openssh-" version ".tar.gz"))
|
||||||
"openssh-trust-guix-store-directory.patch"))
|
(patches (search-patches "openssh-trust-guix-store-directory.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32 "11bahrik5qi337m954g5479f63cxnxdch076ng7668fvi28gs21n"))))
|
||||||
"1s3nqv57r3l7avsdkzwd575dvxra8h19xpqczl0z3cvcgwabw3i0"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
(list
|
(list
|
||||||
|
|
Reference in New Issue