gnu: enlightenment: Update to 0.25.0.
* gnu/packages/enlightenment.scm (enlightenment): Update to 0.25.0. [arguments]: Remove unneeded configure-flags. Don't remove phase which isn't part of the build system. Remove trailing #t from phases. [inputs]: Add libexif. * gnu/packages/patches/enlightenment-fix-setuid-path.patch: Refresh patch.master
parent
49cf2a40d2
commit
73ff9d6e0e
|
@ -296,7 +296,7 @@ Libraries with some extra bells and whistles.")
|
||||||
(define-public enlightenment
|
(define-public enlightenment
|
||||||
(package
|
(package
|
||||||
(name "enlightenment")
|
(name "enlightenment")
|
||||||
(version "0.24.2")
|
(version "0.25.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri
|
(uri
|
||||||
|
@ -304,21 +304,16 @@ Libraries with some extra bells and whistles.")
|
||||||
"enlightenment/enlightenment-" version ".tar.xz"))
|
"enlightenment/enlightenment-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1wfz0rwwsx7c1mkswn4hc9xw1i6bsdirhxiycf7ha2vcipqy465y"))
|
"01nzyvjy06043m01fdb1309xx3wxxg0s3hj9g9di7jjsxp774vkx"))
|
||||||
(patches (search-patches "enlightenment-fix-setuid-path.patch"))))
|
(patches (search-patches "enlightenment-fix-setuid-path.patch"))))
|
||||||
(build-system meson-build-system)
|
(build-system meson-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags
|
`(#:configure-flags
|
||||||
(let ((efl (assoc-ref %build-inputs "efl")))
|
(list "-Dsystemd=false"
|
||||||
(list "-Dsystemd=false"
|
"-Dpackagekit=false"
|
||||||
"-Dpackagekit=false"
|
"-Dwl=true")
|
||||||
"-Dwl=true"
|
|
||||||
(string-append "-Dedje-cc=" efl "/bin/edje_cc")
|
|
||||||
(string-append "-Deldbus-codegen=" efl "/bin/eldbus-codegen")
|
|
||||||
(string-append "-Deet=" efl "/bin/eet")))
|
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
(delete 'bootstrap) ; We don't want to run the autogen script.
|
|
||||||
(add-before 'configure 'set-system-actions
|
(add-before 'configure 'set-system-actions
|
||||||
(lambda* (#:key inputs #:allow-other-keys)
|
(lambda* (#:key inputs #:allow-other-keys)
|
||||||
(setenv "HOME" "/tmp")
|
(setenv "HOME" "/tmp")
|
||||||
|
@ -356,8 +351,7 @@ Libraries with some extra bells and whistles.")
|
||||||
(("/bin/umount") "/run/setuid-programs/umount")
|
(("/bin/umount") "/run/setuid-programs/umount")
|
||||||
(("/usr/bin/eject") "/run/current-system/profile/bin/eject"))
|
(("/usr/bin/eject") "/run/current-system/profile/bin/eject"))
|
||||||
(substitute* "src/bin/system/e_system_power.c"
|
(substitute* "src/bin/system/e_system_power.c"
|
||||||
(("systemctl") "loginctl"))
|
(("systemctl") "loginctl"))))))))
|
||||||
#t))))))
|
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("gettext" ,gettext-minimal)
|
`(("gettext" ,gettext-minimal)
|
||||||
("pkg-config" ,pkg-config)))
|
("pkg-config" ,pkg-config)))
|
||||||
|
@ -368,10 +362,11 @@ Libraries with some extra bells and whistles.")
|
||||||
("dbus" ,dbus)
|
("dbus" ,dbus)
|
||||||
("freetype" ,freetype)
|
("freetype" ,freetype)
|
||||||
("libdrm" ,libdrm)
|
("libdrm" ,libdrm)
|
||||||
|
("libexif" ,libexif)
|
||||||
("libxcb" ,libxcb)
|
("libxcb" ,libxcb)
|
||||||
("libxext" ,libxext)
|
("libxext" ,libxext)
|
||||||
("linux-pam" ,linux-pam)
|
("linux-pam" ,linux-pam)
|
||||||
("puleseaudio" ,pulseaudio)
|
("pulseaudio" ,pulseaudio)
|
||||||
("setxkbmap" ,setxkbmap)
|
("setxkbmap" ,setxkbmap)
|
||||||
("xcb-util-keysyms" ,xcb-util-keysyms)
|
("xcb-util-keysyms" ,xcb-util-keysyms)
|
||||||
("xkeyboard-config" ,xkeyboard-config)
|
("xkeyboard-config" ,xkeyboard-config)
|
||||||
|
|
|
@ -1,9 +1,11 @@
|
||||||
|
This diff was generated against enlightenment-0.25.0, targeting all the occurances of 'suid_exes'.
|
||||||
|
|
||||||
diff --git a/src/bin/e_auth.c b/src/bin/e_auth.c
|
diff --git a/src/bin/e_auth.c b/src/bin/e_auth.c
|
||||||
index 8b0aa6641..3dff0ad84 100644
|
index 6d07a0ac3..31e0e728f 100644
|
||||||
--- a/src/bin/e_auth.c
|
--- a/src/bin/e_auth.c
|
||||||
+++ b/src/bin/e_auth.c
|
+++ b/src/bin/e_auth.c
|
||||||
@@ -12,8 +12,7 @@ e_auth_begin(char *passwd)
|
@@ -38,8 +38,7 @@ e_auth_begin(char *passwd)
|
||||||
if (pwlen == 0) goto out;
|
pwlen = strlen(passwd);
|
||||||
|
|
||||||
snprintf(buf, sizeof(buf),
|
snprintf(buf, sizeof(buf),
|
||||||
- "%s/enlightenment/utils/enlightenment_ckpasswd pw",
|
- "%s/enlightenment/utils/enlightenment_ckpasswd pw",
|
||||||
|
@ -11,9 +13,9 @@ index 8b0aa6641..3dff0ad84 100644
|
||||||
+ "/run/setuid-programs/enlightenment_ckpasswd pw");
|
+ "/run/setuid-programs/enlightenment_ckpasswd pw");
|
||||||
exe = ecore_exe_pipe_run(buf, ECORE_EXE_PIPE_WRITE, NULL);
|
exe = ecore_exe_pipe_run(buf, ECORE_EXE_PIPE_WRITE, NULL);
|
||||||
if (!exe) goto out;
|
if (!exe) goto out;
|
||||||
if (ecore_exe_send(exe, passwd, pwlen) != EINA_TRUE) goto out;
|
snprintf(buf, sizeof(buf), "pw %s", passwd);
|
||||||
@@ -47,8 +46,7 @@ e_auth_polkit_begin(char *passwd, const char *cookie, unsigned int uid)
|
@@ -75,8 +74,7 @@ e_auth_polkit_begin(char *passwd, const char *cookie, unsigned int uid)
|
||||||
if (pwlen == 0) goto out;
|
pwlen = strlen(passwd);
|
||||||
|
|
||||||
snprintf(buf, sizeof(buf),
|
snprintf(buf, sizeof(buf),
|
||||||
- "%s/enlightenment/utils/enlightenment_ckpasswd pk",
|
- "%s/enlightenment/utils/enlightenment_ckpasswd pk",
|
||||||
|
@ -54,23 +56,24 @@ index 9b10b3117..74e6b72ad 100644
|
||||||
}
|
}
|
||||||
v->guard = ecore_timer_loop_add(E_FM_MOUNT_TIMEOUT, (Ecore_Task_Cb)_e_fm_main_eeze_vol_mount_timeout, v);
|
v->guard = ecore_timer_loop_add(E_FM_MOUNT_TIMEOUT, (Ecore_Task_Cb)_e_fm_main_eeze_vol_mount_timeout, v);
|
||||||
diff --git a/src/bin/e_start_main.c b/src/bin/e_start_main.c
|
diff --git a/src/bin/e_start_main.c b/src/bin/e_start_main.c
|
||||||
index b2c439455..cb16c7bd4 100644
|
index 722063339..2da2d5a23 100644
|
||||||
--- a/src/bin/e_start_main.c
|
--- a/src/bin/e_start_main.c
|
||||||
+++ b/src/bin/e_start_main.c
|
+++ b/src/bin/e_start_main.c
|
||||||
@@ -710,7 +710,7 @@ main(int argc, char **argv)
|
@@ -596,8 +596,7 @@ main(int argc, char **argv)
|
||||||
"E_ALERT_FONT_DIR=%s/data/fonts", eina_prefix_data_get(pfx));
|
eina_prefix_data_get(pfx));
|
||||||
putenv(buf2);
|
putenv(buf2);
|
||||||
snprintf(buf3, sizeof(buf3),
|
myasprintf(&buf3,
|
||||||
- "E_ALERT_SYSTEM_BIN=%s/enlightenment/utils/enlightenment_system", eina_prefix_lib_get(pfx));
|
- "E_ALERT_SYSTEM_BIN=%s/enlightenment/utils/enlightenment_system",
|
||||||
+ "E_ALERT_SYSTEM_BIN=/run/setuid-programs/enlightenment_system");
|
- eina_prefix_lib_get(pfx));
|
||||||
|
+ "E_ALERT_SYSTEM_BIN=/run/setuid-programs/enlightenment_system");
|
||||||
putenv(buf3);
|
putenv(buf3);
|
||||||
|
|
||||||
if ((valgrind_mode || valgrind_tool) &&
|
home = getenv("HOME");
|
||||||
diff --git a/src/bin/e_system.c b/src/bin/e_system.c
|
diff --git a/src/bin/e_system.c b/src/bin/e_system.c
|
||||||
index 1e7aabb64..dc0173219 100644
|
index bfd43e7e2..45d78b7ed 100644
|
||||||
--- a/src/bin/e_system.c
|
--- a/src/bin/e_system.c
|
||||||
+++ b/src/bin/e_system.c
|
+++ b/src/bin/e_system.c
|
||||||
@@ -132,7 +132,7 @@ _system_spawn(void)
|
@@ -133,7 +133,7 @@ _system_spawn(void)
|
||||||
else _respawn_count = 0;
|
else _respawn_count = 0;
|
||||||
if (_respawn_count > 5) return;
|
if (_respawn_count > 5) return;
|
||||||
snprintf(buf, sizeof(buf),
|
snprintf(buf, sizeof(buf),
|
||||||
|
|
Reference in New Issue