From 7627ac7ba950c272262bcbf0bb7757b583ff02f0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Wiktor=20=C5=BBelazny?= <wzelazny@vurv.cz>
Date: Thu, 1 Sep 2022 11:38:04 +0200
Subject: [PATCH] gnu: Add texlive-latex-lastpage.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/tex.scm (texlive-latex-lastpage): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/tex.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 56308c4cf9..2236f9faf2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11591,3 +11591,21 @@ within ‘words’ that contain non-alphabetic characters (e.g., that include
 underscores), and hyphenation of text typeset in monospaced (e.g., cmtt)
 fonts.")
     (license license:lppl1.3c+)))
+
+(define-public texlive-latex-lastpage
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-lastpage"
+              (list "doc/latex/lastpage/"
+                    "tex/latex/lastpage/")
+              (base32 "0q6x743b8fkw9r82lrxy49f9xsg81bffynwvpnvpnp3h4mkafvdb")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lastpage")
+    (synopsis "Reference last page for Page N of M type footers")
+    (description
+     "This package enables referencing the number of pages in a LaTeX document
+through the introduction of a new label which can be referenced like
+@code{\\pageref{LastPage}} to give a reference to the last page of a document.
+It is particularly useful in the page footer that says: Page N of M.")
+    (license license:lppl1.3c+)))