gnu: higan: Update to 110.
* gnu/packages/emulators.scm (higan): Update to 110. [source]: Switch to new repository. [inputs]: Add libxrandr, replace sdl with sdl2. [home-page]: Use new URL. [license]: Switch license. * gnu/packages/patches/higan-remove-march-native-flag.patch: Delete file. * gnu/local.mk: Reflect patch removal.master
parent
be54cbe690
commit
76cc11a0ed
|
@ -1031,7 +1031,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/hdf-eos5-remove-gctp.patch \
|
%D%/packages/patches/hdf-eos5-remove-gctp.patch \
|
||||||
%D%/packages/patches/hdf-eos5-fix-szip.patch \
|
%D%/packages/patches/hdf-eos5-fix-szip.patch \
|
||||||
%D%/packages/patches/hdf-eos5-fortrantests.patch \
|
%D%/packages/patches/hdf-eos5-fortrantests.patch \
|
||||||
%D%/packages/patches/higan-remove-march-native-flag.patch \
|
|
||||||
%D%/packages/patches/hubbub-sort-entities.patch \
|
%D%/packages/patches/hubbub-sort-entities.patch \
|
||||||
%D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \
|
%D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \
|
||||||
%D%/packages/patches/hplip-remove-imageprocessor.patch \
|
%D%/packages/patches/hplip-remove-imageprocessor.patch \
|
||||||
|
|
|
@ -311,28 +311,19 @@ and a game metadata scraper.")
|
||||||
(home-page "https://emulationstation.org")
|
(home-page "https://emulationstation.org")
|
||||||
(license license:expat))))
|
(license license:expat))))
|
||||||
|
|
||||||
;; Note: higan v107 has been released, but as explained by the dialog that
|
|
||||||
;; appears after starting the new version, it's an experimental release. The
|
|
||||||
;; author recommends v106 for general use.
|
|
||||||
;;
|
|
||||||
;; When updating to v107 (or probably beyond), sdl will have to be replaced
|
|
||||||
;; with sdl2, and libxrandr will need to be added to inputs. The patch
|
|
||||||
;; `higan-remove-march-native-flag.patch' will not be necessary, since the flag
|
|
||||||
;; is now being added only for `platform=local', which is not the default.
|
|
||||||
(define-public higan
|
(define-public higan
|
||||||
(package
|
(package
|
||||||
(name "higan")
|
(name "higan")
|
||||||
(version "106")
|
(version "110")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
(uri (git-reference
|
(uri (git-reference
|
||||||
(url "https://github.com/byuu/higan/")
|
(url "https://github.com/higan-emu/higan.git")
|
||||||
(commit (string-append "v" version))))
|
(commit (string-append "v" version))))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1mxivf8124vz4hl0b0xa1yqv0z9m3i12v9psmbpqkprrbq0wbgn1"))
|
(base32 "11rvm53c3p2f6zk8xbyv2j51xp8zmqnch7zravhj3fk590qrjrr2"))))
|
||||||
(patches (search-patches "higan-remove-march-native-flag.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)))
|
`(("pkg-config" ,pkg-config)))
|
||||||
|
@ -342,11 +333,12 @@ and a game metadata scraper.")
|
||||||
("eudev" ,eudev)
|
("eudev" ,eudev)
|
||||||
("gtk+" ,gtk+-2)
|
("gtk+" ,gtk+-2)
|
||||||
("gtksourceview-2" ,gtksourceview-2)
|
("gtksourceview-2" ,gtksourceview-2)
|
||||||
|
("libxrandr" ,libxrandr)
|
||||||
("libxv" ,libxv)
|
("libxv" ,libxv)
|
||||||
("mesa" ,mesa)
|
("mesa" ,mesa)
|
||||||
("openal" ,openal)
|
("openal" ,openal)
|
||||||
("pulseaudio" ,pulseaudio)
|
("pulseaudio" ,pulseaudio)
|
||||||
("sdl" ,sdl)))
|
("sdl2" ,sdl2)))
|
||||||
(arguments
|
(arguments
|
||||||
'(#:phases
|
'(#:phases
|
||||||
(let ((build-phase (assoc-ref %standard-phases 'build))
|
(let ((build-phase (assoc-ref %standard-phases 'build))
|
||||||
|
@ -405,7 +397,7 @@ and a game metadata scraper.")
|
||||||
(string-append "prefix=" (assoc-ref %outputs "out")))
|
(string-append "prefix=" (assoc-ref %outputs "out")))
|
||||||
;; There is no test suite.
|
;; There is no test suite.
|
||||||
#:tests? #f))
|
#:tests? #f))
|
||||||
(home-page "https://byuu.org/higan")
|
(home-page "https://github.com/higan-emu/higan/")
|
||||||
(synopsis "Nintendo multi-system emulator")
|
(synopsis "Nintendo multi-system emulator")
|
||||||
(description
|
(description
|
||||||
"higan (formerly bsnes) is an emulator for multiple Nintendo video game
|
"higan (formerly bsnes) is an emulator for multiple Nintendo video game
|
||||||
|
@ -413,10 +405,7 @@ consoles, including the Nintendo Entertainment System (NES/Famicom), Super
|
||||||
Nintendo Entertainment System (SNES/Super Famicom), Game Boy, Game Boy
|
Nintendo Entertainment System (SNES/Super Famicom), Game Boy, Game Boy
|
||||||
Color (GBC), and Game Boy Advance (GBA). It also supports the subsystems
|
Color (GBC), and Game Boy Advance (GBA). It also supports the subsystems
|
||||||
Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
|
Super Game Boy, BS-X Satellaview, and Sufami Turbo.")
|
||||||
;; As noted in these files among more:
|
(license license:gpl3+)))
|
||||||
;; - icarus/icarus.cpp
|
|
||||||
;; - higan/emulator/emulator.hpp
|
|
||||||
(license license:gpl3)))
|
|
||||||
|
|
||||||
(define-public mgba
|
(define-public mgba
|
||||||
(package
|
(package
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
Remove -march=native from build flags.
|
|
||||||
|
|
||||||
--- a/higan/GNUmakefile
|
|
||||||
+++ b/higan/GNUmakefile
|
|
||||||
@@ -26,7 +26,6 @@
|
|
||||||
flags += -fopenmp
|
|
||||||
link += -fopenmp
|
|
||||||
ifeq ($(binary),application)
|
|
||||||
- flags += -march=native
|
|
||||||
link += -Wl,-export-dynamic
|
|
||||||
link += -lX11 -lXext
|
|
||||||
else ifeq ($(binary),library)
|
|
Reference in New Issue