gnu: emacs-ess: Fix build failure.
* gnu/packages/patches/emacs-ess-fix-obsolete-function-alias.patch: New file. * gnu/packages/statistics.scm (emacs-ess)[source]<patches>: Add it here... * gnu/local.mk (dist_patch_DATA): ... and here.
This commit is contained in:
parent
e0e30c9202
commit
77a41cb98c
3 changed files with 27 additions and 1 deletions
|
@ -1028,6 +1028,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/elm-compiler-fix-map-key.patch \
|
%D%/packages/patches/elm-compiler-fix-map-key.patch \
|
||||||
%D%/packages/patches/elogind-revert-polkit-detection.patch \
|
%D%/packages/patches/elogind-revert-polkit-detection.patch \
|
||||||
%D%/packages/patches/emacs-exec-path.patch \
|
%D%/packages/patches/emacs-exec-path.patch \
|
||||||
|
%D%/packages/patches/emacs-ess-fix-obsolete-function-alias.patch \
|
||||||
%D%/packages/patches/emacs-git-email-missing-parens.patch \
|
%D%/packages/patches/emacs-git-email-missing-parens.patch \
|
||||||
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
|
||||||
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
||||||
|
|
|
@ -0,0 +1,23 @@
|
||||||
|
From 9cc5520e1998d03f5dec0fbb1fe71b7cdec38b65 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Alex Branham <alex.branham@gmail.com>
|
||||||
|
Date: Wed, 6 Jan 2021 06:41:20 -0500
|
||||||
|
Subject: [PATCH] Add required when to obsolete function alias
|
||||||
|
|
||||||
|
Closes #1085
|
||||||
|
---
|
||||||
|
lisp/ess-r-package.el | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/lisp/ess-r-package.el b/lisp/ess-r-package.el
|
||||||
|
index 260959955..397ce14e6 100644
|
||||||
|
--- a/lisp/ess-r-package.el
|
||||||
|
+++ b/lisp/ess-r-package.el
|
||||||
|
@@ -577,7 +577,7 @@ package mode. Use this function if state of the buffer such as
|
||||||
|
(error "As of ESS 16.04, `ess-developer' is deprecated. Use `ess-r-set-evaluation-env' instead"))
|
||||||
|
|
||||||
|
(defalias 'ess-toggle-developer 'ess-developer)
|
||||||
|
-(define-obsolete-function-alias 'ess-r-devtools-check-package-buildwin 'ess-r-devtools-check-with-winbuilder)
|
||||||
|
+(define-obsolete-function-alias 'ess-r-devtools-check-package-buildwin 'ess-r-devtools-check-with-winbuilder "18.04")
|
||||||
|
(define-obsolete-function-alias 'ess-r-devtools-ask 'ess-r-devtools-execute-command "18.04")
|
||||||
|
|
||||||
|
(make-obsolete-variable 'ess-developer "Please use `ess-developer-select-package' and `ess-r-set-evaluation-env' instead." "16.04")
|
|
@ -6347,7 +6347,9 @@ Java package that provides routines for various statistical distributions.")
|
||||||
"$(MAKE) -C lisp install; $(MAKE) -C doc install")
|
"$(MAKE) -C lisp install; $(MAKE) -C doc install")
|
||||||
(("\\$\\(INSTALL) -R \\./\\* \\$\\(ESSDESTDIR)/")
|
(("\\$\\(INSTALL) -R \\./\\* \\$\\(ESSDESTDIR)/")
|
||||||
"$(MAKE) -C etc install"))
|
"$(MAKE) -C etc install"))
|
||||||
#t))))
|
#t))
|
||||||
|
(patches
|
||||||
|
(search-patches "emacs-ess-fix-obsolete-function-alias.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
(let ((base-directory "/share/emacs/site-lisp"))
|
(let ((base-directory "/share/emacs/site-lisp"))
|
||||||
|
|
Reference in a new issue