gnu: openresolv: Update to 3.13.2.
* gnu/packages/dns.scm (openresolv): Update to 3.13.2. * gnu/packages/patches/openresolv-restartcmd-guix.patch: Adjust. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>master
parent
7f194852a4
commit
7971da9e30
|
@ -1228,35 +1228,41 @@ and TCP-capable recursive DNS server for finding domains on the internet.")
|
||||||
(define-public openresolv
|
(define-public openresolv
|
||||||
(package
|
(package
|
||||||
(name "openresolv")
|
(name "openresolv")
|
||||||
(version "3.12.0")
|
(version "3.13.2")
|
||||||
(source (origin
|
(source
|
||||||
(method url-fetch)
|
(origin
|
||||||
(uri (string-append "https://roy.marples.name/downloads/openresolv/"
|
(method git-fetch)
|
||||||
"openresolv-" version ".tar.xz"))
|
(uri (git-reference
|
||||||
(sha256
|
(url "https://github.com/NetworkConfiguration/openresolv")
|
||||||
(base32
|
(commit (string-append "v" version))))
|
||||||
"15qvp5va2yrqpz0ba54clvn8cbc66v4sl7k3bi9ji8jpx040bcs2"))
|
(file-name (git-file-name name version))
|
||||||
(patches
|
(sha256
|
||||||
(search-patches "openresolv-restartcmd-guix.patch"))))
|
(base32
|
||||||
|
"03m8n0j0kxxm5kpl66gz4lxr1qqgrp8zlkaq9j8fz27fih0g75xf"))
|
||||||
|
(patches
|
||||||
|
(search-patches "openresolv-restartcmd-guix.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:tests? #f ; No test suite
|
(list #:tests? #f ; No test suite
|
||||||
#:configure-flags
|
|
||||||
(list (string-append "--sysconfdir=/etc"))
|
#:configure-flags
|
||||||
#:make-flags
|
#~(list (string-append "--prefix=" #$output:out)
|
||||||
(list (string-append "SYSCONFDIR=/" (assoc-ref %outputs "out") "/etc"))
|
"--sysconfdir=/etc"
|
||||||
#:phases
|
"--rundir=/run")
|
||||||
(modify-phases %standard-phases
|
|
||||||
(add-after 'install 'wrap-program
|
#:phases
|
||||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
#~(modify-phases %standard-phases
|
||||||
(let ((out (assoc-ref outputs "out"))
|
(replace 'install
|
||||||
(coreutils (assoc-ref inputs "coreutils-minimal")))
|
(lambda* (#:key make-flags #:allow-other-keys)
|
||||||
(substitute* (string-append out "/sbin/resolvconf")
|
(apply invoke "make" "install"
|
||||||
(("RESOLVCONF=\"\\$0\"")
|
(string-append "SYSCONFDIR=" #$output "/etc")
|
||||||
(format #f "\
|
make-flags)))
|
||||||
RESOLVCONF=\"$0\"
|
(add-after 'install 'wrap-program
|
||||||
PATH=~a/bin:$PATH"
|
(lambda* (#:key inputs #:allow-other-keys)
|
||||||
coreutils)))))))))
|
(substitute* (string-append #$output "/sbin/resolvconf")
|
||||||
|
(("RESOLVCONF=\"\\$0\"")
|
||||||
|
(format #f "RESOLVCONF=\"$0\"\nPATH=~a/bin:$PATH"
|
||||||
|
(assoc-ref inputs "coreutils-minimal")))))))))
|
||||||
(inputs
|
(inputs
|
||||||
(list coreutils-minimal))
|
(list coreutils-minimal))
|
||||||
(home-page "https://roy.marples.name/projects/openresolv/")
|
(home-page "https://roy.marples.name/projects/openresolv/")
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 7f0ce36828ec1e130bee857b8236ca091e4d8a2c Mon Sep 17 00:00:00 2001
|
From 439266671bbd790b3cb339c157c87db382e85c96 Mon Sep 17 00:00:00 2001
|
||||||
From: Brice Waegeneire <brice@waegenei.re>
|
From: Brice Waegeneire <brice@waegenei.re>
|
||||||
Date: Sat, 9 May 2020 15:52:06 +0200
|
Date: Sat, 9 May 2020 15:52:06 +0200
|
||||||
Subject: [PATCH] Add RESTARTCMD for Guix System.
|
Subject: [PATCH] Add RESTARTCMD for Guix System.
|
||||||
|
@ -12,13 +12,13 @@ to do it on Guix System by using shepherd.
|
||||||
1 file changed, 7 insertions(+)
|
1 file changed, 7 insertions(+)
|
||||||
|
|
||||||
diff --git a/resolvconf.in b/resolvconf.in
|
diff --git a/resolvconf.in b/resolvconf.in
|
||||||
index 3cad04d..5ef5294 100644
|
index aa77ffe..921882e 100644
|
||||||
--- a/resolvconf.in
|
--- a/resolvconf.in
|
||||||
+++ b/resolvconf.in
|
+++ b/resolvconf.in
|
||||||
@@ -369,6 +369,13 @@ detect_init()
|
@@ -375,6 +375,13 @@ detect_init()
|
||||||
then
|
|
||||||
/etc/rc.d/$1 restart
|
|
||||||
fi'
|
fi'
|
||||||
|
elif [ -d /etc/dinit.d ] && command -v dinitctl >/dev/null 2>&1; then
|
||||||
|
RESTARTCMD='dinitctl --quiet restart --ignore-unstarted $1'
|
||||||
+ elif [ -e /gnu/store ] && [ -e /run/current-system/profile ]; then
|
+ elif [ -e /gnu/store ] && [ -e /run/current-system/profile ]; then
|
||||||
+ # Guix System
|
+ # Guix System
|
||||||
+ RESTARTCMD='
|
+ RESTARTCMD='
|
||||||
|
@ -30,5 +30,5 @@ index 3cad04d..5ef5294 100644
|
||||||
for x in /etc/init.d/rc.d /etc/rc.d /etc/init.d; do
|
for x in /etc/init.d/rc.d /etc/rc.d /etc/init.d; do
|
||||||
[ -d $x ] || continue
|
[ -d $x ] || continue
|
||||||
--
|
--
|
||||||
2.26.0
|
2.41.0
|
||||||
|
|
||||||
|
|
Reference in New Issue