gnu: nss: Update to 3.66.
* gnu/packages/nss.scm (nss): Update to 3.66. Reindent.
[arguments]: Remove #:parallel-build?.
* gnu/packages/patches/nss-getcwd-nonnull.patch: Adjust for directory change.
* gnu/packages/patches/nss-3.56-pkgconfig.patch,
gnu/packages/patches/nss-increase-test-timeout.patch: Revert to
6223566971
.
* gnu/packages/certs.scm (nss-certs)[arguments]: Adjust for directory change.
master
parent
d25873fa9d
commit
79878c64b4
|
@ -92,7 +92,7 @@ that was originally contributed to Debian.")
|
||||||
(add-after 'unpack 'install
|
(add-after 'unpack 'install
|
||||||
(lambda _
|
(lambda _
|
||||||
(let ((certsdir (string-append %output "/etc/ssl/certs/")))
|
(let ((certsdir (string-append %output "/etc/ssl/certs/")))
|
||||||
(with-directory-excursion "lib/ckfw/builtins/"
|
(with-directory-excursion "nss/lib/ckfw/builtins/"
|
||||||
(unless (file-exists? "blacklist.txt")
|
(unless (file-exists? "blacklist.txt")
|
||||||
(call-with-output-file "blacklist.txt" (const #t)))
|
(call-with-output-file "blacklist.txt" (const #t)))
|
||||||
;; Extract selected single certificates from blob.
|
;; Extract selected single certificates from blob.
|
||||||
|
|
|
@ -3,7 +3,7 @@
|
||||||
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
|
||||||
;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
|
;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
|
||||||
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||||
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
|
;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
|
||||||
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
|
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
|
||||||
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||||
;;;
|
;;;
|
||||||
|
@ -25,8 +25,6 @@
|
||||||
(define-module (gnu packages nss)
|
(define-module (gnu packages nss)
|
||||||
#:use-module (guix packages)
|
#:use-module (guix packages)
|
||||||
#:use-module (guix download)
|
#:use-module (guix download)
|
||||||
#:use-module (guix git-download)
|
|
||||||
#:use-module (guix hg-download)
|
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
#:use-module ((guix licenses) #:prefix license:)
|
#:use-module ((guix licenses) #:prefix license:)
|
||||||
#:use-module (gnu packages)
|
#:use-module (gnu packages)
|
||||||
|
@ -76,124 +74,118 @@ in the Mozilla clients.")
|
||||||
;;; Note: When updating, also test the build of the nss-certs package, which
|
;;; Note: When updating, also test the build of the nss-certs package, which
|
||||||
;;; uses the same source as nss.
|
;;; uses the same source as nss.
|
||||||
(define-public nss
|
(define-public nss
|
||||||
;; Use the latest commit to get this fix:
|
(package
|
||||||
;; https://bugzilla.mozilla.org/show_bug.cgi?id=1686134, which caused test
|
(name "nss")
|
||||||
;; failures. A simple patch cannot be used, as git binary diffs is not
|
(version "3.66")
|
||||||
;; supported.
|
(source (origin
|
||||||
(let ((revision "1")
|
(method url-fetch)
|
||||||
(changeset "92dcda94c1d4688edad2c094d505cd253757c0d4"))
|
(uri (let ((version-with-underscores
|
||||||
(package
|
(string-join (string-split version #\.) "_")))
|
||||||
(name "nss")
|
(string-append
|
||||||
(version (git-version "3.61" revision changeset))
|
"https://ftp.mozilla.org/pub/mozilla.org/security/nss/"
|
||||||
(source (origin
|
"releases/NSS_" version-with-underscores "_RTM/src/"
|
||||||
(method hg-fetch)
|
"nss-" version ".tar.gz")))
|
||||||
(uri (hg-reference
|
(sha256
|
||||||
(url "https://hg.mozilla.org/projects/nss")
|
(base32
|
||||||
(changeset changeset)))
|
"1jfdnh5l4k57r2vb07s06hqi7m2qzk0d9x25lsdsrw3cflx9x9w9"))
|
||||||
(sha256
|
;; Create nss.pc and nss-config.
|
||||||
(base32
|
(patches (search-patches "nss-3.56-pkgconfig.patch"
|
||||||
"0j3hnsfw1855x150zgdyf3d6wapiph80rmbvc34ykpp3j347q5hb"))
|
"nss-getcwd-nonnull.patch"
|
||||||
(file-name (git-file-name name version))
|
"nss-increase-test-timeout.patch"))
|
||||||
;; Create nss.pc and nss-config.
|
(modules '((guix build utils)))
|
||||||
(patches (search-patches "nss-3.56-pkgconfig.patch"
|
(snippet
|
||||||
"nss-getcwd-nonnull.patch"
|
'(begin
|
||||||
"nss-increase-test-timeout.patch"))
|
;; Delete the bundled copy of these libraries.
|
||||||
(modules '((guix build utils)))
|
(delete-file-recursively "nss/lib/zlib")
|
||||||
(snippet
|
(delete-file-recursively "nss/lib/sqlite")))))
|
||||||
'(begin
|
(build-system gnu-build-system)
|
||||||
;; Delete the bundled copy of these libraries.
|
(outputs '("out" "bin"))
|
||||||
(delete-file-recursively "lib/zlib")
|
(arguments
|
||||||
(delete-file-recursively "lib/sqlite")))))
|
`(#:make-flags
|
||||||
(build-system gnu-build-system)
|
(let* ((out (assoc-ref %outputs "out"))
|
||||||
(outputs '("out" "bin"))
|
(nspr (string-append (assoc-ref %build-inputs "nspr")))
|
||||||
(arguments
|
(rpath (string-append "-Wl,-rpath=" out "/lib/nss")))
|
||||||
;; Parallel builds are not supported (see:
|
(list "-C" "nss" (string-append "PREFIX=" out)
|
||||||
;; https://bugzilla.mozilla.org/show_bug.cgi?id=1640328).
|
"NSDISTMODE=copy"
|
||||||
`(#:parallel-build? #f
|
"NSS_USE_SYSTEM_SQLITE=1"
|
||||||
#:tests? #t ;requires at least one hour to run
|
(string-append "NSPR_INCLUDE_DIR=" nspr "/include/nspr")
|
||||||
#:make-flags
|
;; Add $out/lib/nss to RPATH.
|
||||||
(let* ((out (assoc-ref %outputs "out"))
|
(string-append "RPATH=" rpath)
|
||||||
(nspr (string-append (assoc-ref %build-inputs "nspr")))
|
(string-append "LDFLAGS=" rpath)))
|
||||||
(rpath (string-append "-Wl,-rpath=" out "/lib/nss")))
|
#:modules ((guix build gnu-build-system)
|
||||||
(list (string-append "PREFIX=" out)
|
(guix build utils)
|
||||||
"NSDISTMODE=copy"
|
(ice-9 ftw)
|
||||||
"NSS_USE_SYSTEM_SQLITE=1"
|
(ice-9 match)
|
||||||
(string-append "NSPR_INCLUDE_DIR=" nspr "/include/nspr")
|
(srfi srfi-26))
|
||||||
;; Add $out/lib/nss to RPATH.
|
#:phases
|
||||||
(string-append "RPATH=" rpath)
|
(modify-phases %standard-phases
|
||||||
(string-append "LDFLAGS=" rpath)))
|
(replace 'configure
|
||||||
#:modules ((guix build gnu-build-system)
|
(lambda _
|
||||||
(guix build utils)
|
(setenv "CC" "gcc")
|
||||||
(ice-9 ftw)
|
;; Tells NSS to build for the 64-bit ABI if we are 64-bit system.
|
||||||
(ice-9 match)
|
,@(match (%current-system)
|
||||||
(srfi srfi-26))
|
((or "x86_64-linux" "aarch64-linux")
|
||||||
#:phases
|
`((setenv "USE_64" "1")))
|
||||||
(modify-phases %standard-phases
|
(_
|
||||||
(replace 'configure
|
'()))))
|
||||||
(lambda _
|
(replace 'check
|
||||||
(setenv "CC" "gcc")
|
(lambda* (#:key tests? #:allow-other-keys)
|
||||||
;; Tells NSS to build for the 64-bit ABI if we are 64-bit system.
|
(if tests?
|
||||||
,@(match (%current-system)
|
(begin
|
||||||
((or "x86_64-linux" "aarch64-linux")
|
;; Use 127.0.0.1 instead of $HOST.$DOMSUF as HOSTADDR for
|
||||||
`((setenv "USE_64" "1")))
|
;; testing. The latter requires a working DNS or /etc/hosts.
|
||||||
(_
|
(setenv "DOMSUF" "localdomain")
|
||||||
'()))))
|
(setenv "USE_IP" "TRUE")
|
||||||
(replace 'check
|
(setenv "IP_ADDRESS" "127.0.0.1")
|
||||||
(lambda* (#:key tests? #:allow-other-keys)
|
|
||||||
(when tests?
|
|
||||||
;; Use 127.0.0.1 instead of $HOST.$DOMSUF as HOSTADDR for testing.
|
|
||||||
;; The later requires a working DNS or /etc/hosts.
|
|
||||||
(setenv "DOMSUF" "localdomain")
|
|
||||||
(setenv "USE_IP" "TRUE")
|
|
||||||
(setenv "IP_ADDRESS" "127.0.0.1")
|
|
||||||
|
|
||||||
;; The "PayPalEE.cert" certificate expires every six months,
|
;; The "PayPalEE.cert" certificate expires every six months,
|
||||||
;; leading to test failures:
|
;; leading to test failures:
|
||||||
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
|
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
|
||||||
;; work around that, set the time to roughly the release date.
|
;; work around that, set the time to roughly the release date.
|
||||||
(invoke "faketime" "2021-01-22" "./tests/all.sh"))))
|
(invoke "faketime" "2021-06-01" "./nss/tests/all.sh"))
|
||||||
(replace 'install
|
(format #t "test suite not run~%"))))
|
||||||
(lambda* (#:key outputs #:allow-other-keys)
|
(replace 'install
|
||||||
(let* ((out (assoc-ref outputs "out"))
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
(bin (string-append (assoc-ref outputs "bin") "/bin"))
|
(let* ((out (assoc-ref outputs "out"))
|
||||||
(inc (string-append out "/include/nss"))
|
(bin (string-append (assoc-ref outputs "bin") "/bin"))
|
||||||
(lib (string-append out "/lib/nss"))
|
(inc (string-append out "/include/nss"))
|
||||||
(obj (match (scandir "../dist" (cut string-suffix? "OBJ" <>))
|
(lib (string-append out "/lib/nss"))
|
||||||
((obj) (string-append "../dist/" obj)))))
|
(obj (match (scandir "dist" (cut string-suffix? "OBJ" <>))
|
||||||
;; Install nss-config to $out/bin.
|
((obj) (string-append "dist/" obj)))))
|
||||||
(install-file (string-append obj "/bin/nss-config")
|
;; Install nss-config to $out/bin.
|
||||||
(string-append out "/bin"))
|
(install-file (string-append obj "/bin/nss-config")
|
||||||
(delete-file (string-append obj "/bin/nss-config"))
|
(string-append out "/bin"))
|
||||||
;; Install nss.pc to $out/lib/pkgconfig.
|
(delete-file (string-append obj "/bin/nss-config"))
|
||||||
(install-file (string-append obj "/lib/pkgconfig/nss.pc")
|
;; Install nss.pc to $out/lib/pkgconfig.
|
||||||
(string-append out "/lib/pkgconfig"))
|
(install-file (string-append obj "/lib/pkgconfig/nss.pc")
|
||||||
(delete-file (string-append obj "/lib/pkgconfig/nss.pc"))
|
(string-append out "/lib/pkgconfig"))
|
||||||
(rmdir (string-append obj "/lib/pkgconfig"))
|
(delete-file (string-append obj "/lib/pkgconfig/nss.pc"))
|
||||||
;; Install other files.
|
(rmdir (string-append obj "/lib/pkgconfig"))
|
||||||
(mkdir-p inc)
|
;; Install other files.
|
||||||
(copy-recursively "../dist/public/nss" inc)
|
(copy-recursively "dist/public/nss" inc)
|
||||||
(copy-recursively (string-append obj "/bin") bin)
|
(copy-recursively (string-append obj "/bin") bin)
|
||||||
(copy-recursively (string-append obj "/lib") lib)))))))
|
(copy-recursively (string-append obj "/lib") lib)))))))
|
||||||
(inputs
|
(inputs
|
||||||
`(;; XXX: Build with SQLite 3.33 to work around
|
`(;; XXX: Build with SQLite 3.33 to work around
|
||||||
;; https://bugzilla.mozilla.org/show_bug.cgi?id=1714874
|
;; https://bugzilla.mozilla.org/show_bug.cgi?id=1714874
|
||||||
("sqlite" ,sqlite-3.33)
|
("sqlite" ,sqlite-3.33)
|
||||||
("zlib" ,zlib)))
|
("zlib" ,zlib)))
|
||||||
(propagated-inputs `(("nspr" ,nspr))) ; required by nss.pc.
|
(propagated-inputs
|
||||||
(native-inputs `(("perl" ,perl)
|
`(("nspr" ,nspr))) ;required by nss.pc.
|
||||||
("libfaketime" ,libfaketime))) ;for tests
|
(native-inputs
|
||||||
|
`(("perl" ,perl)
|
||||||
|
("libfaketime" ,libfaketime))) ;for tests
|
||||||
|
|
||||||
;; The NSS test suite takes around 48 hours on Loongson 3A (MIPS) when
|
;; The NSS test suite takes around 48 hours on Loongson 3A (MIPS) when
|
||||||
;; another build is happening concurrently on the same machine.
|
;; another build is happening concurrently on the same machine.
|
||||||
(properties '((timeout . 216000))) ; 60 hours
|
(properties '((timeout . 216000))) ;60 hours
|
||||||
|
|
||||||
(home-page
|
(home-page "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS")
|
||||||
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS")
|
(synopsis "Network Security Services")
|
||||||
(synopsis "Network Security Services")
|
(description
|
||||||
(description
|
"Network Security Services (@dfn{NSS}) is a set of libraries designed to
|
||||||
"Network Security Services (@dfn{NSS}) is a set of libraries designed to
|
|
||||||
support cross-platform development of security-enabled client and server
|
support cross-platform development of security-enabled client and server
|
||||||
applications. Applications built with NSS can support SSL v2 and v3, TLS,
|
applications. Applications built with NSS can support SSL v2 and v3, TLS,
|
||||||
PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other
|
PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other
|
||||||
security standards.")
|
security standards.")
|
||||||
(license license:mpl2.0))))
|
(license license:mpl2.0)))
|
||||||
|
|
|
@ -1,79 +1,25 @@
|
||||||
From 1b3c48499abb000d708abe5f05413c1f4155e086 Mon Sep 17 00:00:00 2001
|
Description: Create nss.pc and nss-config
|
||||||
From: Jory Pratt <anarchy@gentoo.org>
|
Author: Lars Wendler <polynomial-c@gentoo.org>
|
||||||
Date: Mon, 8 Jun 2020 12:22:29 -0500
|
Source: http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-libs/nss/files/nss-3.17.1-gentoo-fixups.patch
|
||||||
Subject: [PATCH] Add pkg-config and nss-config for Gentoo
|
|
||||||
|
|
||||||
Modifications to use with Guix and the latest NSS source checkout code: use
|
Modifications:
|
||||||
'install' instead of 'ln -sf' and adapt the relative file names.
|
Change libdir from ${prefix}/lib64 to ${prefix}/lib/nss.
|
||||||
|
Remove optional patching in nss/Makefile.
|
||||||
|
Include -L$libdir in output from "nss-config --libs".
|
||||||
|
|
||||||
---
|
Later adapted to apply cleanly to nss-3.53.
|
||||||
Makefile | 15 +----
|
|
||||||
config/Makefile | 40 ++++++++++++
|
|
||||||
config/nss-config.in | 145 +++++++++++++++++++++++++++++++++++++++++++
|
|
||||||
config/nss.pc.in | 12 ++++
|
|
||||||
manifest.mn | 2 +-
|
|
||||||
5 files changed, 200 insertions(+), 14 deletions(-)
|
|
||||||
create mode 100644 config/Makefile
|
|
||||||
create mode 100644 config/nss-config.in
|
|
||||||
create mode 100644 config/nss.pc.in
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
--- nss-3.21/nss/config/Makefile
|
||||||
index eb4ed1a..f979d90 100644
|
+++ nss-3.21/nss/config/Makefile
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -4,6 +4,8 @@
|
|
||||||
# License, v. 2.0. If a copy of the MPL was not distributed with this
|
|
||||||
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
|
|
||||||
|
|
||||||
+default: nss_build_all
|
|
||||||
+
|
|
||||||
#######################################################################
|
|
||||||
# (1) Include initial platform-independent assignments (MANDATORY). #
|
|
||||||
#######################################################################
|
|
||||||
@@ -48,12 +50,9 @@ include $(CORE_DEPTH)/coreconf/rules.mk
|
|
||||||
#######################################################################
|
|
||||||
|
|
||||||
nss_build_all:
|
|
||||||
- $(MAKE) build_nspr
|
|
||||||
$(MAKE) all
|
|
||||||
- $(MAKE) latest
|
|
||||||
|
|
||||||
nss_clean_all:
|
|
||||||
- $(MAKE) clobber_nspr
|
|
||||||
$(MAKE) clobber
|
|
||||||
|
|
||||||
NSPR_CONFIG_STATUS = $(CORE_DEPTH)/../nspr/$(OBJDIR_NAME)/config.status
|
|
||||||
@@ -138,16 +137,6 @@ $(NSPR_CONFIG_STATUS): $(NSPR_CONFIGURE)
|
|
||||||
--prefix='$(NSS_GYP_PREFIX)'
|
|
||||||
endif
|
|
||||||
|
|
||||||
-build_nspr: $(NSPR_CONFIG_STATUS)
|
|
||||||
- $(MAKE) -C $(CORE_DEPTH)/../nspr/$(OBJDIR_NAME)
|
|
||||||
- $(MAKE) -C $(CORE_DEPTH)/../nspr/$(OBJDIR_NAME)/pr/tests
|
|
||||||
-
|
|
||||||
-install_nspr: build_nspr
|
|
||||||
- $(MAKE) -C $(CORE_DEPTH)/../nspr/$(OBJDIR_NAME) install
|
|
||||||
-
|
|
||||||
-clobber_nspr: $(NSPR_CONFIG_STATUS)
|
|
||||||
- $(MAKE) -C $(CORE_DEPTH)/../nspr/$(OBJDIR_NAME) clobber
|
|
||||||
-
|
|
||||||
build_docs:
|
|
||||||
$(MAKE) -C $(CORE_DEPTH)/doc
|
|
||||||
|
|
||||||
diff --git a/config/Makefile b/config/Makefile
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..aaf1991
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/config/Makefile
|
|
||||||
@@ -0,0 +1,40 @@
|
@@ -0,0 +1,40 @@
|
||||||
+CORE_DEPTH = ..
|
+CORE_DEPTH = ..
|
||||||
+DEPTH = ..
|
+DEPTH = ..
|
||||||
+
|
+
|
||||||
+include $(CORE_DEPTH)/coreconf/config.mk
|
+include $(CORE_DEPTH)/coreconf/config.mk
|
||||||
+
|
+
|
||||||
+NSS_MAJOR_VERSION = $(shell grep -F "NSS_VMAJOR" ../lib/nss/nss.h | awk '{print $$3}')
|
+NSS_MAJOR_VERSION = `grep "NSS_VMAJOR" ../lib/nss/nss.h | awk '{print $$3}'`
|
||||||
+NSS_MINOR_VERSION = $(shell grep -F "NSS_VMINOR" ../lib/nss/nss.h | awk '{print $$3}')
|
+NSS_MINOR_VERSION = `grep "NSS_VMINOR" ../lib/nss/nss.h | awk '{print $$3}'`
|
||||||
+NSS_PATCH_VERSION = $(shell grep -F "NSS_VPATCH" ../lib/nss/nss.h | awk '{print $$3}')
|
+NSS_PATCH_VERSION = `grep "NSS_VPATCH" ../lib/nss/nss.h | awk '{print $$3}'`
|
||||||
+PREFIX = /usr
|
+PREFIX = /usr
|
||||||
+
|
+
|
||||||
+all: export libs
|
+all: export libs
|
||||||
|
@ -83,14 +29,14 @@ index 0000000..aaf1991
|
||||||
+ mkdir -p $(DIST)/lib/pkgconfig
|
+ mkdir -p $(DIST)/lib/pkgconfig
|
||||||
+ sed -e "s,@prefix@,$(PREFIX)," \
|
+ sed -e "s,@prefix@,$(PREFIX)," \
|
||||||
+ -e "s,@exec_prefix@,\$${prefix}," \
|
+ -e "s,@exec_prefix@,\$${prefix}," \
|
||||||
+ -e "s,@libdir@,\$${prefix}/lib64," \
|
+ -e "s,@libdir@,\$${prefix}/lib/nss," \
|
||||||
+ -e "s,@includedir@,\$${prefix}/include/nss," \
|
+ -e "s,@includedir@,\$${prefix}/include/nss," \
|
||||||
+ -e "s,@NSS_MAJOR_VERSION@,$(NSS_MAJOR_VERSION),g" \
|
+ -e "s,@NSS_MAJOR_VERSION@,$(NSS_MAJOR_VERSION),g" \
|
||||||
+ -e "s,@NSS_MINOR_VERSION@,$(NSS_MINOR_VERSION)," \
|
+ -e "s,@NSS_MINOR_VERSION@,$(NSS_MINOR_VERSION)," \
|
||||||
+ -e "s,@NSS_PATCH_VERSION@,$(NSS_PATCH_VERSION)," \
|
+ -e "s,@NSS_PATCH_VERSION@,$(NSS_PATCH_VERSION)," \
|
||||||
+ nss.pc.in > nss.pc
|
+ nss.pc.in > nss.pc
|
||||||
+ chmod 0644 nss.pc
|
+ chmod 0644 nss.pc
|
||||||
+ install nss.pc $(DIST)/lib/pkgconfig
|
+ cp nss.pc $(DIST)/lib/pkgconfig
|
||||||
+
|
+
|
||||||
+ # Create the nss-config script
|
+ # Create the nss-config script
|
||||||
+ mkdir -p $(DIST)/bin
|
+ mkdir -p $(DIST)/bin
|
||||||
|
@ -100,17 +46,14 @@ index 0000000..aaf1991
|
||||||
+ -e "s,@NSS_PATCH_VERSION@,$(NSS_PATCH_VERSION)," \
|
+ -e "s,@NSS_PATCH_VERSION@,$(NSS_PATCH_VERSION)," \
|
||||||
+ nss-config.in > nss-config
|
+ nss-config.in > nss-config
|
||||||
+ chmod 0755 nss-config
|
+ chmod 0755 nss-config
|
||||||
+ install nss-config $(DIST)/bin
|
+ cp nss-config $(DIST)/bin
|
||||||
+
|
+
|
||||||
+libs:
|
+libs:
|
||||||
+
|
+
|
||||||
+dummy: all export libs
|
+dummy: all export libs
|
||||||
+
|
+
|
||||||
diff --git a/config/nss-config.in b/config/nss-config.in
|
--- nss-3.21/nss/config/nss-config.in
|
||||||
new file mode 100644
|
+++ nss-3.21/nss/config/nss-config.in
|
||||||
index 0000000..3a957b8
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/config/nss-config.in
|
|
||||||
@@ -0,0 +1,145 @@
|
@@ -0,0 +1,145 @@
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
+
|
+
|
||||||
|
@ -152,31 +95,31 @@ index 0000000..3a957b8
|
||||||
+
|
+
|
||||||
+while test $# -gt 0; do
|
+while test $# -gt 0; do
|
||||||
+ case "$1" in
|
+ case "$1" in
|
||||||
+ -*=*) optarg=$(echo "$1" | sed 's/[-_a-zA-Z0-9]*=//') ;;
|
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
|
||||||
+ *) optarg= ;;
|
+ *) optarg= ;;
|
||||||
+ esac
|
+ esac
|
||||||
+
|
+
|
||||||
+ case $1 in
|
+ case $1 in
|
||||||
+ --prefix=*)
|
+ --prefix=*)
|
||||||
+ prefix=${optarg}
|
+ prefix=$optarg
|
||||||
+ ;;
|
+ ;;
|
||||||
+ --prefix)
|
+ --prefix)
|
||||||
+ echo_prefix=yes
|
+ echo_prefix=yes
|
||||||
+ ;;
|
+ ;;
|
||||||
+ --exec-prefix=*)
|
+ --exec-prefix=*)
|
||||||
+ exec_prefix=${optarg}
|
+ exec_prefix=$optarg
|
||||||
+ ;;
|
+ ;;
|
||||||
+ --exec-prefix)
|
+ --exec-prefix)
|
||||||
+ echo_exec_prefix=yes
|
+ echo_exec_prefix=yes
|
||||||
+ ;;
|
+ ;;
|
||||||
+ --includedir=*)
|
+ --includedir=*)
|
||||||
+ includedir=${optarg}
|
+ includedir=$optarg
|
||||||
+ ;;
|
+ ;;
|
||||||
+ --includedir)
|
+ --includedir)
|
||||||
+ echo_includedir=yes
|
+ echo_includedir=yes
|
||||||
+ ;;
|
+ ;;
|
||||||
+ --libdir=*)
|
+ --libdir=*)
|
||||||
+ libdir=${optarg}
|
+ libdir=$optarg
|
||||||
+ ;;
|
+ ;;
|
||||||
+ --libdir)
|
+ --libdir)
|
||||||
+ echo_libdir=yes
|
+ echo_libdir=yes
|
||||||
|
@ -210,58 +153,55 @@ index 0000000..3a957b8
|
||||||
+done
|
+done
|
||||||
+
|
+
|
||||||
+# Set variables that may be dependent upon other variables
|
+# Set variables that may be dependent upon other variables
|
||||||
+if test -z "${exec_prefix}"; then
|
+if test -z "$exec_prefix"; then
|
||||||
+ exec_prefix=$(pkg-config --variable=exec_prefix nss)
|
+ exec_prefix=`pkg-config --variable=exec_prefix nss`
|
||||||
+fi
|
+fi
|
||||||
+if test -z "${includedir}"; then
|
+if test -z "$includedir"; then
|
||||||
+ includedir=$(pkg-config --variable=includedir nss)
|
+ includedir=`pkg-config --variable=includedir nss`
|
||||||
+fi
|
+fi
|
||||||
+if test -z "${libdir}"; then
|
+if test -z "$libdir"; then
|
||||||
+ libdir=$(pkg-config --variable=libdir nss)
|
+ libdir=`pkg-config --variable=libdir nss`
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
+if test "${echo_prefix}" = "yes"; then
|
+if test "$echo_prefix" = "yes"; then
|
||||||
+ echo ${prefix}
|
+ echo $prefix
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
+if test "${echo_exec_prefix}" = "yes"; then
|
+if test "$echo_exec_prefix" = "yes"; then
|
||||||
+ echo ${exec_prefix}
|
+ echo $exec_prefix
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
+if test "${echo_includedir}" = "yes"; then
|
+if test "$echo_includedir" = "yes"; then
|
||||||
+ echo ${includedir}
|
+ echo $includedir
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
+if test "${echo_libdir}" = "yes"; then
|
+if test "$echo_libdir" = "yes"; then
|
||||||
+ echo ${libdir}
|
+ echo $libdir
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
+if test "${echo_cflags}" = "yes"; then
|
+if test "$echo_cflags" = "yes"; then
|
||||||
+ echo -I${includedir}
|
+ echo -I$includedir
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
+if test "${echo_libs}" = "yes"; then
|
+if test "$echo_libs" = "yes"; then
|
||||||
+ libdirs=""
|
+ libdirs=-L$libdir
|
||||||
+ if test -n "${lib_ssl}"; then
|
+ if test -n "$lib_ssl"; then
|
||||||
+ libdirs="${libdirs} -lssl${major_version}"
|
+ libdirs="$libdirs -lssl${major_version}"
|
||||||
+ fi
|
+ fi
|
||||||
+ if test -n "${lib_smime}"; then
|
+ if test -n "$lib_smime"; then
|
||||||
+ libdirs="${libdirs} -lsmime${major_version}"
|
+ libdirs="$libdirs -lsmime${major_version}"
|
||||||
+ fi
|
+ fi
|
||||||
+ if test -n "${lib_nss}"; then
|
+ if test -n "$lib_nss"; then
|
||||||
+ libdirs="${libdirs} -lnss${major_version}"
|
+ libdirs="$libdirs -lnss${major_version}"
|
||||||
+ fi
|
+ fi
|
||||||
+ if test -n "${lib_nssutil}"; then
|
+ if test -n "$lib_nssutil"; then
|
||||||
+ libdirs="${libdirs} -lnssutil${major_version}"
|
+ libdirs="$libdirs -lnssutil${major_version}"
|
||||||
+ fi
|
+ fi
|
||||||
+ echo ${libdirs}
|
+ echo $libdirs
|
||||||
+fi
|
+fi
|
||||||
+
|
+
|
||||||
diff --git a/config/nss.pc.in b/config/nss.pc.in
|
--- nss-3.21/nss/config/nss.pc.in
|
||||||
new file mode 100644
|
+++ nss-3.21/nss/config/nss.pc.in
|
||||||
index 0000000..03f1e39
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/config/nss.pc.in
|
|
||||||
@@ -0,0 +1,12 @@
|
@@ -0,0 +1,12 @@
|
||||||
+prefix=@prefix@
|
+prefix=@prefix@
|
||||||
+exec_prefix=@exec_prefix@
|
+exec_prefix=@exec_prefix@
|
||||||
|
@ -271,23 +211,18 @@ index 0000000..03f1e39
|
||||||
+Name: NSS
|
+Name: NSS
|
||||||
+Description: Network Security Services
|
+Description: Network Security Services
|
||||||
+Version: @NSS_MAJOR_VERSION@.@NSS_MINOR_VERSION@.@NSS_PATCH_VERSION@
|
+Version: @NSS_MAJOR_VERSION@.@NSS_MINOR_VERSION@.@NSS_PATCH_VERSION@
|
||||||
+Requires: nspr >= 4.25
|
+Requires: nspr >= 4.8
|
||||||
+Libs: -lssl3 -lsmime3 -lnss3 -lnssutil3
|
+Libs: -L${libdir} -lssl3 -lsmime3 -lnss3 -lnssutil3
|
||||||
+Cflags: -I${includedir}
|
+Cflags: -I${includedir}
|
||||||
+
|
+
|
||||||
diff --git a/manifest.mn b/manifest.mn
|
--- nss-3.21/nss/manifest.mn
|
||||||
index dada8ab..72dc9b3 100644
|
+++ nss-3.21/nss/manifest.mn
|
||||||
--- a/manifest.mn
|
@@ -10,7 +10,7 @@
|
||||||
+++ b/manifest.mn
|
|
||||||
@@ -10,7 +10,7 @@ IMPORTS = nspr20/v4.8 \
|
|
||||||
|
|
||||||
RELEASE = nss
|
RELEASE = nss
|
||||||
|
|
||||||
-DIRS = coreconf lib cmd cpputil gtests
|
-DIRS = coreconf lib cmd cpputil gtests
|
||||||
+DIRS = coreconf lib cmd cpputil config
|
+DIRS = coreconf lib cmd cpputil gtests config
|
||||||
|
|
||||||
lib: coreconf
|
lib: coreconf
|
||||||
cmd: lib
|
cmd: lib
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
||||||
|
|
|
@ -4,9 +4,9 @@ the second argument should be NULL with recent glibc. See:
|
||||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96832
|
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96832
|
||||||
https://sourceware.org/bugzilla/show_bug.cgi?id=26545
|
https://sourceware.org/bugzilla/show_bug.cgi?id=26545
|
||||||
|
|
||||||
diff --git a/coreconf/nsinstall/nsinstall.c b/coreconf/nsinstall/nsinstall.c
|
diff --git a/nss/coreconf/nsinstall/nsinstall.c b/nss/coreconf/nsinstall/nsinstall.c
|
||||||
--- a/coreconf/nsinstall/nsinstall.c
|
--- a/nss/coreconf/nsinstall/nsinstall.c
|
||||||
+++ b/coreconf/nsinstall/nsinstall.c
|
+++ b/nss/coreconf/nsinstall/nsinstall.c
|
||||||
@@ -236,14 +236,20 @@ main(int argc, char **argv)
|
@@ -236,14 +236,20 @@ main(int argc, char **argv)
|
||||||
return 0;
|
return 0;
|
||||||
|
|
||||||
|
|
|
@ -3,8 +3,8 @@ machine. Even a busy x86_64 machine can use more than 5s on some tests.
|
||||||
|
|
||||||
Increase timeouts to increase chances of a successful build.
|
Increase timeouts to increase chances of a successful build.
|
||||||
|
|
||||||
--- a/gtests/ssl_gtest/tls_connect.cc 2017-03-14 22:47:30.855813629 +0100
|
--- a/nss/gtests/ssl_gtest/tls_connect.cc 2017-03-14 22:47:30.855813629 +0100
|
||||||
+++ b/gtests/ssl_gtest/tls_connect.cc 2017-03-14 22:48:49.042335273 +0100
|
+++ b/nss/gtests/ssl_gtest/tls_connect.cc 2017-03-14 22:48:49.042335273 +0100
|
||||||
@@ -245,7 +245,7 @@
|
@@ -245,7 +245,7 @@
|
||||||
|
|
||||||
ASSERT_TRUE_WAIT((client_->state() != TlsAgent::STATE_CONNECTING) &&
|
ASSERT_TRUE_WAIT((client_->state() != TlsAgent::STATE_CONNECTING) &&
|
||||||
|
|
Reference in New Issue