me
/
guix
Archived
1
0
Fork 0

gnu: hmmer: Build reproducibly.

* gnu/packages/patches/hmmer-remove-cpu-specificity.patch: New file.
* gnu/packages/bioinformatics.scm (hmmer): Use it.
master
Ben J. Woodcroft 2017-03-10 20:25:00 +10:00 committed by Ben Woodcroft
parent 5ded35d89d
commit 79f09fa239
No known key found for this signature in database
GPG Key ID: 2A6AD9F4AAC20DF6
2 changed files with 33 additions and 9 deletions

View File

@ -2839,15 +2839,17 @@ indexing scheme is called a @dfn{Hierarchical Graph FM index} (HGFM).")
(package (package
(name "hmmer") (name "hmmer")
(version "3.1b2") (version "3.1b2")
(source (origin (source
(method url-fetch) (origin
(uri (string-append (method url-fetch)
"http://eddylab.org/software/hmmer" (uri (string-append
(version-prefix version 1) "/" "http://eddylab.org/software/hmmer"
version "/hmmer-" version ".tar.gz")) (version-prefix version 1) "/"
(sha256 version "/hmmer-" version ".tar.gz"))
(base32 (sha256
"0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx")))) (base32
"0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx"))
(patches (search-patches "hmmer-remove-cpu-specificity.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(native-inputs `(("perl" ,perl))) (native-inputs `(("perl" ,perl)))
(home-page "http://hmmer.org/") (home-page "http://hmmer.org/")

View File

@ -0,0 +1,22 @@
This patch removes compilation flags which make the build for the machine
where compilation takes place, rendering the build not reproducible.
diff --git a/configure b/configure
index 8b6aaef..49a6afc 100755
--- a/configure
+++ b/configure
@@ -6125,14 +6125,6 @@ fi # guess arch
if test "x$ax_gcc_arch" != x -a "x$ax_gcc_arch" != xno; then
for arch in $ax_gcc_arch; do
- if test "x$acx_maxopt_portable" = xyes; then # if we require portable code
- flags="-mtune=$arch"
- # -mcpu=$arch and m$arch generate nonportable code on every arch except
- # x86. And some other arches (e.g. Alpha) don't accept -mtune. Grrr.
- case $host_cpu in i*86|x86_64*) flags="$flags -mcpu=$arch -m$arch";; esac
- else
- flags="-march=$arch -mcpu=$arch -m$arch"
- fi
for flag in $flags; do
as_CACHEVAR=`$as_echo "ax_cv_check_cflags__$flag" | $as_tr_sh`
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts $flag" >&5