gnu: Remove python-3.4.
* gnu/packages/python.scm (python-3.4): Remove variable. * gnu/packages/patches/python-3.4-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
be81133a13
commit
7cb68a3cb3
|
@ -853,7 +853,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-2.7-source-date-epoch.patch \
|
||||
%D%/packages/patches/python-3-deterministic-build-info.patch \
|
||||
%D%/packages/patches/python-3-search-paths.patch \
|
||||
%D%/packages/patches/python-3.4-fix-tests.patch \
|
||||
%D%/packages/patches/python-3.5-fix-tests.patch \
|
||||
%D%/packages/patches/python-3.5-getentropy-on-old-kernels.patch \
|
||||
%D%/packages/patches/python-dendropy-fix-tests.patch \
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- Lib/test/test_posixpath.py 2014-03-01 05:46:56.984311000 +0100
|
||||
+++ Lib/test/test_posixpath.py 2014-03-07 00:59:20.888311000 +0100
|
||||
@@ -319,7 +319,11 @@
|
||||
del env['HOME']
|
||||
home = pwd.getpwuid(os.getuid()).pw_dir
|
||||
# $HOME can end with a trailing /, so strip it (see #17809)
|
||||
- self.assertEqual(posixpath.expanduser("~"), home.rstrip("/"))
|
||||
+ # The Guix builders have '/' as a home directory, so
|
||||
+ # home.rstrip("/") will be an empty string and the test will
|
||||
+ # fail. Let's just disable it since it does not really make
|
||||
+ # sense with such a bizarre setup.
|
||||
+ # self.assertEqual(posixpath.expanduser("~"), home.rstrip("/"))
|
|
@ -344,23 +344,6 @@ data types.")
|
|||
(version-major+minor version)
|
||||
"/site-packages"))))))))
|
||||
|
||||
(define-public python-3.4
|
||||
(package (inherit python-3.5)
|
||||
(version "3.4.5")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://www.python.org/ftp/python/"
|
||||
version "/Python-" version ".tar.xz"))
|
||||
(patches (search-patches
|
||||
"python-fix-tests.patch"
|
||||
"python-3.4-fix-tests.patch"
|
||||
"python-3-deterministic-build-info.patch"
|
||||
"python-3-search-paths.patch"))
|
||||
(patch-flags '("-p0"))
|
||||
(sha256
|
||||
(base32
|
||||
"12l9klp778wklxmckhghniy5hklss8r26995pyd00qbllk4b2r7f"))))))
|
||||
|
||||
;; Current 3.x version.
|
||||
(define-public python-3 python-3.5)
|
||||
|
||||
|
|
Reference in New Issue