gnu: cursynth: Upgrade to 1.5.
* gnu/packages/cursynth.scm (cursynth)[source]: Upgrade to 1.5. New 'patches' field. * gnu/packages/patches/cursynth-wave-rand.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.master
parent
edc28d3c42
commit
7cd157e221
|
@ -283,6 +283,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/cssc-gets-undeclared.patch \
|
gnu/packages/patches/cssc-gets-undeclared.patch \
|
||||||
gnu/packages/patches/cssc-missing-include.patch \
|
gnu/packages/patches/cssc-missing-include.patch \
|
||||||
gnu/packages/patches/curl-fix-test172.patch \
|
gnu/packages/patches/curl-fix-test172.patch \
|
||||||
|
gnu/packages/patches/cursynth-wave-rand.patch \
|
||||||
gnu/packages/patches/dbus-localstatedir.patch \
|
gnu/packages/patches/dbus-localstatedir.patch \
|
||||||
gnu/packages/patches/diffutils-gets-undeclared.patch \
|
gnu/packages/patches/diffutils-gets-undeclared.patch \
|
||||||
gnu/packages/patches/dmd-getpw.patch \
|
gnu/packages/patches/dmd-getpw.patch \
|
||||||
|
|
|
@ -29,14 +29,15 @@
|
||||||
(define-public cursynth
|
(define-public cursynth
|
||||||
(package
|
(package
|
||||||
(name "cursynth")
|
(name "cursynth")
|
||||||
(version "1.4")
|
(version "1.5")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/cursynth/cursynth-"
|
(uri (string-append "mirror://gnu/cursynth/cursynth-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1p9c54v9b0jjx33sammqsdi5xw65csly4cr1i08wv9x6r2yib55m"))))
|
(base32 "1dhphsya41rv8z6yqcv9l6fwbslsds4zh1y56zizi39nd996d40v"))
|
||||||
|
(patches (list (search-patch "cursynth-wave-rand.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs `(("pkg-config" ,pkg-config)))
|
(native-inputs `(("pkg-config" ,pkg-config)))
|
||||||
;; TODO: See https://github.com/iyoko/cursynth/issues/4 which currently
|
;; TODO: See https://github.com/iyoko/cursynth/issues/4 which currently
|
||||||
|
|
|
@ -0,0 +1,12 @@
|
||||||
|
Related to https://github.com/mtytel/cursynth/issues/9
|
||||||
|
|
||||||
|
--- a/mopo/src/wave.h 2014-06-25 14:10:57.827369578 -0500
|
||||||
|
+++ b/mopo/src/wave.h 2014-06-25 14:08:15.795376354 -0500
|
||||||
|
@@ -19,6 +19,7 @@
|
||||||
|
#define WAVE_H
|
||||||
|
|
||||||
|
#include "mopo.h"
|
||||||
|
+#include <cstdlib>
|
||||||
|
#include <cmath>
|
||||||
|
|
||||||
|
#define LOOKUP_SIZE 2048
|
Reference in New Issue