gnu: libksysguard: Update to 6.1.2.
* gnu/packages/kde-plasma.scm (libksysguard): Update to 6.1.2. [source]: Remvoe patches. [inputs]: Remove plasma-framework, qtbase-5, qtdeclarative-5, qtscript, qtwebchannel-5, qtwebengine-5, and qtx11extras; add libplasma, qtdeclarative, qtwebchannel, and qtwebengine. [native-inputs]: Remove qttools-5; add qttools. [arguments]: Set #:qtbase to qtbase. * gnu/packages/patches/libksysguard-qdiriterator-follow-symlinks.patch: Remove it. * gnu/local.mk (dist_patch_DATA): Unregister it. Change-Id: Ic5b88315da7682dcd47ec19894b8ed88b87d6688master
parent
69149f1fb6
commit
7ce98fe4d9
|
@ -1638,7 +1638,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libofa-ftbfs-2.diff \
|
||||
%D%/packages/patches/libotr-test-auth-fix.patch \
|
||||
%D%/packages/patches/libksieve-Fix-missing-link-libraries.patch \
|
||||
%D%/packages/patches/libksysguard-qdiriterator-follow-symlinks.patch \
|
||||
%D%/packages/patches/libmad-armv7-thumb-pt1.patch \
|
||||
%D%/packages/patches/libmad-armv7-thumb-pt2.patch \
|
||||
%D%/packages/patches/libmad-length-check.patch \
|
||||
|
|
|
@ -1090,17 +1090,16 @@ basic needs and easy to configure for those who want special setups.")
|
|||
(define-public libksysguard
|
||||
(package
|
||||
(name "libksysguard")
|
||||
(version "5.27.7")
|
||||
(version "6.1.2")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://kde/stable/plasma/" version
|
||||
"/libksysguard-" version ".tar.xz"))
|
||||
(patches (search-patches "libksysguard-qdiriterator-follow-symlinks.patch"))
|
||||
(sha256
|
||||
(base32 "066bjar4105bfyry6ni7nnikz66bqzy5nvssz6vm4np3aa996ak8"))))
|
||||
(base32 "1l1fy5i9yxh7fnxfyfsk0hnyd1vfzac336kcfwklkqa7l796hpc0"))))
|
||||
(native-inputs
|
||||
(list bash-minimal extra-cmake-modules pkg-config qttools-5))
|
||||
(list bash-minimal extra-cmake-modules pkg-config qttools))
|
||||
(inputs
|
||||
(list kauth
|
||||
kcompletion
|
||||
|
@ -1120,17 +1119,16 @@ basic needs and easy to configure for those who want special setups.")
|
|||
libcap
|
||||
libpcap
|
||||
`(,lm-sensors "lib")
|
||||
plasma-framework
|
||||
qtbase-5
|
||||
qtdeclarative-5
|
||||
qtscript
|
||||
qtwebchannel-5
|
||||
qtwebengine-5
|
||||
qtx11extras
|
||||
libplasma
|
||||
qtdeclarative
|
||||
qtwebchannel
|
||||
qtwebengine
|
||||
zlib))
|
||||
(build-system qt-build-system)
|
||||
(arguments
|
||||
(list #:phases #~(modify-phases %standard-phases
|
||||
(list
|
||||
#:qtbase qtbase
|
||||
#:phases #~(modify-phases %standard-phases
|
||||
(add-after 'unpack 'fix-test
|
||||
(lambda* _
|
||||
(substitute* "autotests/processtest.cpp"
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
From 46164a50de4102d02ae9d1d480acdd4b12303db8 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Tuegel <ttuegel@gmail.com>
|
||||
Date: Wed, 14 Oct 2015 07:07:22 -0500
|
||||
Subject: [PATCH] qdiriterator follow symlinks
|
||||
|
||||
---
|
||||
processui/scripting.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/processui/scripting.cpp b/processui/scripting.cpp
|
||||
index efed8ff..841761a 100644
|
||||
--- a/processui/scripting.cpp
|
||||
+++ b/processui/scripting.cpp
|
||||
@@ -293,7 +293,7 @@ void Scripting::loadContextMenu()
|
||||
const QStringList dirs =
|
||||
QStandardPaths::locateAll(QStandardPaths::GenericDataLocation, QStringLiteral("ksysguard/scripts/"), QStandardPaths::LocateDirectory);
|
||||
for (const QString &dir : dirs) {
|
||||
- QDirIterator it(dir, QStringList() << QStringLiteral("*.desktop"), QDir::NoFilter, QDirIterator::Subdirectories);
|
||||
+ QDirIterator it(dir, QStringList() << QStringLiteral("*.desktop"), QDir::NoFilter, QDirIterator::Subdirectories | QDirIterator::FollowSymlinks);
|
||||
while (it.hasNext()) {
|
||||
scripts.append(it.next());
|
||||
}
|
||||
--
|
||||
2.5.2
|
Reference in New Issue