gnu: glib: Drop glib-tests-homedir.patch.
* gnu/packages/glib.scm (glib)[source]: Remove glib-tests-homedir.patch. [arguments]: Set HOME and disable '/gdbus/codegen-peer-to-peer' test. * gnu/packages/patches/glib-tests-homedir.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it.master
parent
0f795a0a53
commit
7dd99e5573
|
@ -486,7 +486,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/ghostscript-runpath.patch \
|
gnu/packages/patches/ghostscript-runpath.patch \
|
||||||
gnu/packages/patches/glib-networking-ssl-cert-file.patch \
|
gnu/packages/patches/glib-networking-ssl-cert-file.patch \
|
||||||
gnu/packages/patches/glib-tests-desktop.patch \
|
gnu/packages/patches/glib-tests-desktop.patch \
|
||||||
gnu/packages/patches/glib-tests-homedir.patch \
|
|
||||||
gnu/packages/patches/glib-tests-prlimit.patch \
|
gnu/packages/patches/glib-tests-prlimit.patch \
|
||||||
gnu/packages/patches/glib-tests-timer.patch \
|
gnu/packages/patches/glib-tests-timer.patch \
|
||||||
gnu/packages/patches/glib-tests-gapplication.patch \
|
gnu/packages/patches/glib-tests-gapplication.patch \
|
||||||
|
|
|
@ -138,8 +138,7 @@ shared NFS home directories.")
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1yzxr1ip3l0m9ydk5nq32piq70c9f17p5f0jyvlsghzbaawh67ss"))
|
"1yzxr1ip3l0m9ydk5nq32piq70c9f17p5f0jyvlsghzbaawh67ss"))
|
||||||
(patches (search-patches "glib-tests-homedir.patch"
|
(patches (search-patches "glib-tests-desktop.patch"
|
||||||
"glib-tests-desktop.patch"
|
|
||||||
"glib-tests-prlimit.patch"
|
"glib-tests-prlimit.patch"
|
||||||
"glib-tests-timer.patch"
|
"glib-tests-timer.patch"
|
||||||
"glib-tests-gapplication.patch"))))
|
"glib-tests-gapplication.patch"))))
|
||||||
|
@ -170,6 +169,7 @@ shared NFS home directories.")
|
||||||
"/share/zoneinfo"))
|
"/share/zoneinfo"))
|
||||||
|
|
||||||
;; Some tests want write access there.
|
;; Some tests want write access there.
|
||||||
|
(setenv "HOME" (getcwd))
|
||||||
(setenv "XDG_CACHE_HOME" (getcwd))
|
(setenv "XDG_CACHE_HOME" (getcwd))
|
||||||
|
|
||||||
(substitute* '("glib/gspawn.c"
|
(substitute* '("glib/gspawn.c"
|
||||||
|
@ -178,6 +178,9 @@ shared NFS home directories.")
|
||||||
(("/bin/sh")
|
(("/bin/sh")
|
||||||
(string-append (assoc-ref inputs "bash") "/bin/sh")))
|
(string-append (assoc-ref inputs "bash") "/bin/sh")))
|
||||||
|
|
||||||
|
;; Disable a test that requires /etc/machine-id.
|
||||||
|
(substitute* "gio/tests/gdbus-peer.c"
|
||||||
|
(("g_test_add_func.*/gdbus/codegen-peer-to-peer.*") ""))
|
||||||
;; Disable a test that requires dbus.
|
;; Disable a test that requires dbus.
|
||||||
(substitute* "gio/tests/gdbus-serialization.c"
|
(substitute* "gio/tests/gdbus-serialization.c"
|
||||||
(("g_test_add_func \
|
(("g_test_add_func \
|
||||||
|
|
|
@ -1,59 +0,0 @@
|
||||||
`g_get_home_dir' looks at /etc/passwd first, which fails in chroot builds.
|
|
||||||
The gdbus tests use it to lookup .dbus-keyrings, so they cannot run in our
|
|
||||||
chroot build environment. Thus, disable them.
|
|
||||||
|
|
||||||
--- glib-2.34.3/gio/tests/gdbus-connection-flush.c 2013-01-16 17:29:46.000000000 +0100
|
|
||||||
+++ glib-2.34.3/gio/tests/gdbus-connection-flush.c 2013-01-16 17:29:47.000000000 +0100
|
|
||||||
@@ -373,10 +373,6 @@ main (int argc,
|
|
||||||
g_type_init ();
|
|
||||||
g_test_init (&argc, &argv, NULL);
|
|
||||||
|
|
||||||
- g_test_add ("/gdbus/connection/flush/busy", Fixture, NULL,
|
|
||||||
- setup, test_flush_busy, teardown);
|
|
||||||
- g_test_add ("/gdbus/connection/flush/idle", Fixture, NULL,
|
|
||||||
- setup, test_flush_idle, teardown);
|
|
||||||
|
|
||||||
ret = g_test_run();
|
|
||||||
|
|
||||||
--- glib-2.38.0.orig/gio/tests/gdbus-peer.c 2013-08-08 12:00:40.000000000 +0200
|
|
||||||
+++ glib-2.38.0/gio/tests/gdbus-peer.c 2013-09-30 19:36:40.000000000 +0200
|
|
||||||
@@ -1746,11 +1746,6 @@
|
|
||||||
|
|
||||||
g_test_add_func ("/gdbus/peer-to-peer", test_peer);
|
|
||||||
g_test_add_func ("/gdbus/delayed-message-processing", delayed_message_processing);
|
|
||||||
- g_test_add_func ("/gdbus/nonce-tcp", test_nonce_tcp);
|
|
||||||
-
|
|
||||||
- g_test_add_func ("/gdbus/tcp-anonymous", test_tcp_anonymous);
|
|
||||||
- g_test_add_func ("/gdbus/credentials", test_credentials);
|
|
||||||
- g_test_add_func ("/gdbus/codegen-peer-to-peer", codegen_test_peer);
|
|
||||||
|
|
||||||
ret = g_test_run();
|
|
||||||
|
|
||||||
--- glib-2.37.1/gio/tests/gdbus-exit-on-close.c 2013-06-07 23:41:34.000000000 +0200
|
|
||||||
+++ glib-2.37.1/gio/tests/gdbus-exit-on-close.c 2013-06-07 23:41:40.000000000 +0200
|
|
||||||
@@ -211,6 +211,7 @@ main (int argc,
|
|
||||||
|
|
||||||
g_test_init (&argc, &argv, NULL);
|
|
||||||
|
|
||||||
+ return g_test_run();
|
|
||||||
for (i = 0; cases[i].name != NULL; i++)
|
|
||||||
{
|
|
||||||
gchar *name;
|
|
||||||
@@ -224,5 +225,4 @@ main (int argc,
|
|
||||||
g_free (name);
|
|
||||||
}
|
|
||||||
|
|
||||||
- return g_test_run();
|
|
||||||
}
|
|
||||||
|
|
||||||
--- glib-2.34.3/gio/tests/gdbus-non-socket.c 2013-01-16 18:13:25.000000000 +0100
|
|
||||||
+++ glib-2.34.3/gio/tests/gdbus-non-socket.c 2013-01-16 18:13:27.000000000 +0100
|
|
||||||
@@ -294,7 +294,6 @@ main (int argc,
|
|
||||||
g_type_init ();
|
|
||||||
g_test_init (&argc, &argv, NULL);
|
|
||||||
|
|
||||||
- g_test_add_func ("/gdbus/non-socket", test_non_socket);
|
|
||||||
|
|
||||||
ret = g_test_run();
|
|
||||||
|
|
||||||
|
|
Reference in New Issue