gnu: shadow: Update to 4.9.
* gnu/packages/admin.scm (shadow): Update to 4.9. [source]: Remove hurd patch, merged upstream. [phases]{fix-linking-to-pam}: New phase. * gnu/packages/patches/shadow-hurd-pctrl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.master
parent
b082fdb4b5
commit
7ecc2e3d2b
|
@ -1791,7 +1791,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/serf-python3.patch \
|
%D%/packages/patches/serf-python3.patch \
|
||||||
%D%/packages/patches/shakespeare-spl-fix-grammar.patch \
|
%D%/packages/patches/shakespeare-spl-fix-grammar.patch \
|
||||||
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
||||||
%D%/packages/patches/shadow-hurd-pctrl.patch \
|
|
||||||
%D%/packages/patches/shishi-fix-libgcrypt-detection.patch \
|
%D%/packages/patches/shishi-fix-libgcrypt-detection.patch \
|
||||||
%D%/packages/patches/slim-session.patch \
|
%D%/packages/patches/slim-session.patch \
|
||||||
%D%/packages/patches/slim-config.patch \
|
%D%/packages/patches/slim-config.patch \
|
||||||
|
|
|
@ -805,16 +805,15 @@ hostname.")
|
||||||
(define-public shadow
|
(define-public shadow
|
||||||
(package
|
(package
|
||||||
(name "shadow")
|
(name "shadow")
|
||||||
(version "4.8.1")
|
(version "4.9")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
"https://github.com/shadow-maint/shadow/releases/"
|
"https://github.com/shadow-maint/shadow/releases/"
|
||||||
"download/" version "/shadow-" version ".tar.xz"))
|
"download/v" version "/shadow-" version ".tar.xz"))
|
||||||
(patches (search-patches "shadow-hurd-pctrl.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0qmfq50sdhz6xilgxvinblll8j2iqfl7hwk45bq744y4plq4dbd3"))))
|
"0i4iijbshnwnsrskxzrh18xgmzff0hdpsnnkmyc2gdn1x4n1zv7y"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(;; Assume System V `setpgrp (void)', which is the default on GNU
|
`(;; Assume System V `setpgrp (void)', which is the default on GNU
|
||||||
|
@ -825,9 +824,16 @@ hostname.")
|
||||||
'("--with-libpam"))
|
'("--with-libpam"))
|
||||||
"shadow_cv_logdir=/var/log"
|
"shadow_cv_logdir=/var/log"
|
||||||
"ac_cv_func_setpgrp_void=yes")
|
"ac_cv_func_setpgrp_void=yes")
|
||||||
|
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
|
(add-after 'unpack 'fix-linking-to-pam
|
||||||
|
(lambda _
|
||||||
|
;; There's a build system problem in 4.9 that causes link
|
||||||
|
;; failures with the pam libraries (see:
|
||||||
|
;; https://github.com/shadow-maint/shadow/issues/407).
|
||||||
|
(substitute* "libsubid/Makefile.in"
|
||||||
|
(("\\$\\(LIBTCB\\)" all)
|
||||||
|
(string-append all " $(LIBPAM)")))))
|
||||||
,@(if (%current-target-system)
|
,@(if (%current-target-system)
|
||||||
'((add-before 'configure 'set-runtime-shell
|
'((add-before 'configure 'set-runtime-shell
|
||||||
(lambda* (#:key inputs #:allow-other-keys)
|
(lambda* (#:key inputs #:allow-other-keys)
|
||||||
|
@ -848,8 +854,7 @@ hostname.")
|
||||||
"libc"))))
|
"libc"))))
|
||||||
(substitute* "lib/nscd.c"
|
(substitute* "lib/nscd.c"
|
||||||
(("/usr/sbin/nscd")
|
(("/usr/sbin/nscd")
|
||||||
(string-append libc "/sbin/nscd")))
|
(string-append libc "/sbin/nscd"))))))
|
||||||
#t)))
|
|
||||||
(add-after 'install 'remove-groups
|
(add-after 'install 'remove-groups
|
||||||
(lambda* (#:key outputs #:allow-other-keys)
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
;; Remove `groups', which is already provided by Coreutils.
|
;; Remove `groups', which is already provided by Coreutils.
|
||||||
|
@ -857,9 +862,7 @@ hostname.")
|
||||||
(bin (string-append out "/bin"))
|
(bin (string-append out "/bin"))
|
||||||
(man (string-append out "/share/man")))
|
(man (string-append out "/share/man")))
|
||||||
(delete-file (string-append bin "/groups"))
|
(delete-file (string-append bin "/groups"))
|
||||||
(for-each delete-file (find-files man "^groups\\."))
|
(for-each delete-file (find-files man "^groups\\."))))))))
|
||||||
#t))))))
|
|
||||||
|
|
||||||
(inputs
|
(inputs
|
||||||
`(,@(if (hurd-target?)
|
`(,@(if (hurd-target?)
|
||||||
'()
|
'()
|
||||||
|
|
|
@ -621,10 +621,10 @@ the freedesktop.org XDG Base Directory specification.")
|
||||||
;; existing in the build environment.
|
;; existing in the build environment.
|
||||||
(invoke "sed" "/src\\/test\\/test-user-util.c/,+2s/^/#/g"
|
(invoke "sed" "/src\\/test\\/test-user-util.c/,+2s/^/#/g"
|
||||||
"-i" "src/test/meson.build")
|
"-i" "src/test/meson.build")
|
||||||
;; FIXME: This one times out for unknown reasons.
|
;; ;; FIXME: This one times out for unknown reasons.
|
||||||
(invoke "sed"
|
;; (invoke "sed"
|
||||||
"/src\\/libelogind\\/sd-event\\/test-event.c/,+2s/^/#/g"
|
;; "/src\\/libelogind\\/sd-event\\/test-event.c/,+2s/^/#/g"
|
||||||
"-i" "src/test/meson.build")
|
;; "-i" "src/test/meson.build")
|
||||||
;; This test tries to copy some bytes from /usr/lib/os-release,
|
;; This test tries to copy some bytes from /usr/lib/os-release,
|
||||||
;; which does not exist in the build container. Choose something
|
;; which does not exist in the build container. Choose something
|
||||||
;; more likely to be available.
|
;; more likely to be available.
|
||||||
|
|
|
@ -1,16 +0,0 @@
|
||||||
Avoid including sys/prctl.h on the Hurd.
|
|
||||||
|
|
||||||
Upstream status: Not submitted.
|
|
||||||
|
|
||||||
--- shadow-4.8.1/libmisc/idmapping.c.orig 2020-03-07 16:32:05.000000000 -0500
|
|
||||||
+++ shadow-4.8.1/libmisc/idmapping.c 2020-03-07 16:32:27.000000000 -0500
|
|
||||||
@@ -36,8 +36,8 @@
|
|
||||||
#include <stdio.h>
|
|
||||||
#include "prototypes.h"
|
|
||||||
#include "idmapping.h"
|
|
||||||
-#include <sys/prctl.h>
|
|
||||||
#if HAVE_SYS_CAPABILITY_H
|
|
||||||
+#include <sys/prctl.h>
|
|
||||||
#include <sys/capability.h>
|
|
||||||
#endif
|
|
||||||
|
|
Reference in New Issue