gnu: LLVM, Clang: Add 11.0.0.
* gnu/packages/patches/clang-11.0-libc-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/llvm.scm (llvm-11, clang-runtime-11, clang-11, clang-toolchain-11): New variables.master
parent
f1db068adb
commit
7f79358def
|
@ -861,6 +861,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/clang-7.0-libc-search-path.patch \
|
%D%/packages/patches/clang-7.0-libc-search-path.patch \
|
||||||
%D%/packages/patches/clang-9.0-libc-search-path.patch \
|
%D%/packages/patches/clang-9.0-libc-search-path.patch \
|
||||||
%D%/packages/patches/clang-10.0-libc-search-path.patch \
|
%D%/packages/patches/clang-10.0-libc-search-path.patch \
|
||||||
|
%D%/packages/patches/clang-11.0-libc-search-path.patch \
|
||||||
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
|
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
|
||||||
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
|
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
|
||||||
%D%/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch \
|
%D%/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch \
|
||||||
|
|
|
@ -450,17 +450,17 @@ output), and Binutils.")
|
||||||
("libc-debug" ,glibc "debug")
|
("libc-debug" ,glibc "debug")
|
||||||
("libc-static" ,glibc "static")))))
|
("libc-static" ,glibc "static")))))
|
||||||
|
|
||||||
(define-public llvm-10
|
(define-public llvm-11
|
||||||
(package
|
(package
|
||||||
(name "llvm")
|
(name "llvm")
|
||||||
(version "10.0.0")
|
(version "11.0.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (llvm-uri "llvm" version))
|
(uri (llvm-uri "llvm" version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1pwgm6cr0xr5a0hrbqs1zvsvvjvy0yq1y47c96804wcs795s90yz"))))
|
"0s94lwil98w7zb7cjrbnxli0z7gklb312pkw74xs1d6zk346hgwi"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(outputs '("out" "opt-viewer"))
|
(outputs '("out" "opt-viewer"))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
|
@ -512,6 +512,39 @@ languages is in development. The compiler infrastructure includes mirror sets
|
||||||
of programming tools as well as libraries with equivalent functionality.")
|
of programming tools as well as libraries with equivalent functionality.")
|
||||||
(license license:asl2.0))) ;with LLVM exceptions, see LICENSE.txt
|
(license license:asl2.0))) ;with LLVM exceptions, see LICENSE.txt
|
||||||
|
|
||||||
|
(define-public clang-runtime-11
|
||||||
|
(clang-runtime-from-llvm
|
||||||
|
llvm-11
|
||||||
|
"0d5j5l8phwqjjscmk8rmqn0i2i0abl537gdbkagl8fjpzy1gyjip"))
|
||||||
|
|
||||||
|
(define-public clang-11
|
||||||
|
(clang-from-llvm llvm-11 clang-runtime-11
|
||||||
|
"02ajkij85966vd150iy246mv16dsaph1kfi0y8wnncp8w6nar5hg"
|
||||||
|
#:patches '("clang-11.0-libc-search-path.patch")
|
||||||
|
#:tools-extra
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (llvm-uri "clang-tools-extra"
|
||||||
|
(package-version llvm-11)))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"02bcwwn54661madhq4nxc069s7p7pj5gpqi8ww50w3anbpviilzy")))))
|
||||||
|
|
||||||
|
(define-public clang-toolchain-11
|
||||||
|
(make-clang-toolchain clang-11))
|
||||||
|
|
||||||
|
(define-public llvm-10
|
||||||
|
(package
|
||||||
|
(inherit llvm-11)
|
||||||
|
(version "10.0.0")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (llvm-uri "llvm" version))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1pwgm6cr0xr5a0hrbqs1zvsvvjvy0yq1y47c96804wcs795s90yz"))))))
|
||||||
|
|
||||||
(define-public clang-runtime-10
|
(define-public clang-runtime-10
|
||||||
(clang-runtime-from-llvm
|
(clang-runtime-from-llvm
|
||||||
llvm-10
|
llvm-10
|
||||||
|
|
|
@ -0,0 +1,89 @@
|
||||||
|
Clang attempts to guess file names based on the OS and distro (yes!),
|
||||||
|
but unfortunately, that doesn't work for us.
|
||||||
|
|
||||||
|
This patch makes it easy to insert libc's $libdir so that Clang passes the
|
||||||
|
correct absolute file name of crt1.o etc. to 'ld'. It also disables all
|
||||||
|
the distro-specific stuff and removes the hard-coded FHS directory names
|
||||||
|
to make sure Clang also works on non-Guix systems.
|
||||||
|
|
||||||
|
diff --git a/lib/Driver/ToolChains/Gnu.cpp b/lib/Driver/ToolChains/Gnu.cpp
|
||||||
|
--- a/lib/Driver/ToolChains/Gnu.cpp
|
||||||
|
+++ b/lib/Driver/ToolChains/Gnu.cpp
|
||||||
|
@@ -2797,7 +2797,7 @@ void Generic_GCC::AddMultilibPaths(const Driver &D,
|
||||||
|
// the cross. Note that GCC does include some of these directories in some
|
||||||
|
// configurations but this seems somewhere between questionable and simply
|
||||||
|
// a bug.
|
||||||
|
- if (StringRef(LibPath).startswith(SysRoot)) {
|
||||||
|
+ if (0) {
|
||||||
|
addPathIfExists(D, LibPath + "/" + MultiarchTriple, Paths);
|
||||||
|
addPathIfExists(D, LibPath + "/../" + OSLibDir, Paths);
|
||||||
|
}
|
||||||
|
@@ -2811,6 +2811,10 @@ void Generic_GCC::AddMultiarchPaths(const Driver &D,
|
||||||
|
// Try walking via the GCC triple path in case of biarch or multiarch GCC
|
||||||
|
// installations with strange symlinks.
|
||||||
|
if (GCCInstallation.isValid()) {
|
||||||
|
+
|
||||||
|
+// The following code would end up adding things like
|
||||||
|
+// "/usr/lib/x86_64-unknown-linux-gnu/../../lib64" to the search path.
|
||||||
|
+#if 0
|
||||||
|
addPathIfExists(D,
|
||||||
|
SysRoot + "/usr/lib/" + GCCInstallation.getTriple().str() +
|
||||||
|
"/../../" + OSLibDir,
|
||||||
|
@@ -2823,6 +2827,7 @@ void Generic_GCC::AddMultiarchPaths(const Driver &D,
|
||||||
|
D, GCCInstallation.getInstallPath() + BiarchSibling.gccSuffix(),
|
||||||
|
Paths);
|
||||||
|
}
|
||||||
|
+#endif // Guix
|
||||||
|
|
||||||
|
// See comments above on the multilib variant for details of why this is
|
||||||
|
// included even from outside the sysroot.
|
||||||
|
diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
|
||||||
|
--- a/lib/Driver/ToolChains/Linux.cpp
|
||||||
|
+++ b/lib/Driver/ToolChains/Linux.cpp
|
||||||
|
@@ -219,6 +219,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||||
|
|
||||||
|
Generic_GCC::PushPPaths(PPaths);
|
||||||
|
|
||||||
|
+// Comment out the distro-specific tweaks so that they don't bite when
|
||||||
|
+// using Guix on a foreign distro.
|
||||||
|
+#if 0
|
||||||
|
Distro Distro(D.getVFS(), Triple);
|
||||||
|
|
||||||
|
if (Distro.IsAlpineLinux() || Triple.isAndroid()) {
|
||||||
|
@@ -284,6 +287,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||||
|
|
||||||
|
if (IsAndroid || Distro.IsOpenSUSE())
|
||||||
|
ExtraOpts.push_back("--enable-new-dtags");
|
||||||
|
+#endif // Guix
|
||||||
|
|
||||||
|
// The selection of paths to try here is designed to match the patterns which
|
||||||
|
// the GCC driver itself uses, as this is part of the GCC-compatible driver.
|
||||||
|
@@ -310,6 +314,8 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||||
|
addPathIfExists(D, SysRoot + "/lib/" + MultiarchTriple, Paths);
|
||||||
|
addPathIfExists(D, SysRoot + "/lib/../" + OSLibDir, Paths);
|
||||||
|
|
||||||
|
+// This requires the commented distro tweaks above.
|
||||||
|
+#if 0
|
||||||
|
if (IsAndroid) {
|
||||||
|
// Android sysroots contain a library directory for each supported OS
|
||||||
|
// version as well as some unversioned libraries in the usual multiarch
|
||||||
|
@@ -338,6 +344,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||||
|
addPathIfExists(D, SysRoot + "/" + OSLibDir + "/" + ABIName, Paths);
|
||||||
|
addPathIfExists(D, SysRoot + "/usr/" + OSLibDir + "/" + ABIName, Paths);
|
||||||
|
}
|
||||||
|
+#endif // Guix
|
||||||
|
|
||||||
|
Generic_GCC::AddMultiarchPaths(D, SysRoot, OSLibDir, Paths);
|
||||||
|
|
||||||
|
@@ -349,8 +356,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||||
|
if (StringRef(D.Dir).startswith(SysRoot))
|
||||||
|
addPathIfExists(D, D.Dir + "/../lib", Paths);
|
||||||
|
|
||||||
|
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
||||||
|
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
||||||
|
+ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
|
||||||
|
+ // and friends can be found.
|
||||||
|
+ addPathIfExists(D, "@GLIBC_LIBDIR@", Paths);
|
||||||
|
}
|
||||||
|
|
||||||
|
ToolChain::CXXStdlibType Linux::GetDefaultCXXStdlibType() const {
|
Reference in New Issue