gnu: ruby-safe-yaml: Update to 1.0.5.
* gnu/packages/ruby.scm(ruby-save-yaml): Update to 1.0.5. * gnu/packages/patches/ruby-safe-yaml-add-require-time.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
55cc5ef80d
commit
7fa83fa860
|
@ -1331,7 +1331,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/retroarch-disable-online-updater.patch \
|
%D%/packages/patches/retroarch-disable-online-updater.patch \
|
||||||
%D%/packages/patches/ruby-rubygems-276-for-ruby24.patch \
|
%D%/packages/patches/ruby-rubygems-276-for-ruby24.patch \
|
||||||
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \
|
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \
|
||||||
%D%/packages/patches/ruby-safe-yaml-add-require-time.patch \
|
|
||||||
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
|
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
|
||||||
%D%/packages/patches/runc-CVE-2019-5736.patch \
|
%D%/packages/patches/runc-CVE-2019-5736.patch \
|
||||||
%D%/packages/patches/rust-1.19-mrustc.patch \
|
%D%/packages/patches/rust-1.19-mrustc.patch \
|
||||||
|
|
|
@ -1,19 +0,0 @@
|
||||||
From 9dd1e8d9ad0396a8c9092c2e9f17d498c58e0208 Mon Sep 17 00:00:00 2001
|
|
||||||
From: elifoster <elifosterwy@gmail.com>
|
|
||||||
Date: Tue, 5 Dec 2017 14:30:13 -0800
|
|
||||||
Subject: [PATCH] Fix uninitialized constant DateTime Close #80
|
|
||||||
|
|
||||||
---
|
|
||||||
lib/safe_yaml/parse/date.rb | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/lib/safe_yaml/parse/date.rb b/lib/safe_yaml/parse/date.rb
|
|
||||||
index cd3c62a..3a30a8b 100644
|
|
||||||
--- a/lib/safe_yaml/parse/date.rb
|
|
||||||
+++ b/lib/safe_yaml/parse/date.rb
|
|
||||||
@@ -1,3 +1,5 @@
|
|
||||||
+require 'time'
|
|
||||||
+
|
|
||||||
module SafeYAML
|
|
||||||
class Parse
|
|
||||||
class Date
|
|
|
@ -8284,10 +8284,9 @@ indentation will probably be an issue and hence this gem.")
|
||||||
(define-public ruby-safe-yaml
|
(define-public ruby-safe-yaml
|
||||||
(package
|
(package
|
||||||
(name "ruby-safe-yaml")
|
(name "ruby-safe-yaml")
|
||||||
(version "1.0.4")
|
(version "1.0.5")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
;; TODO Fetch from the git repository so a patch can be applied
|
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
(uri (git-reference
|
(uri (git-reference
|
||||||
(url "https://github.com/dtao/safe_yaml.git")
|
(url "https://github.com/dtao/safe_yaml.git")
|
||||||
|
@ -8295,9 +8294,7 @@ indentation will probably be an issue and hence this gem.")
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1wnln8xdy8g6kwdj4amm8773xwffqxpf2sxslk6jjh2wxsy1lrig"))
|
"1a0wh7y3va2m7bjza95na2snw0vrdh9syz40mpjvjphbc4ph3pzg"))))
|
||||||
(patches
|
|
||||||
(search-patches "ruby-safe-yaml-add-require-time.patch"))))
|
|
||||||
(build-system ruby-build-system)
|
(build-system ruby-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("ruby-rspec" ,ruby-rspec)
|
`(("ruby-rspec" ,ruby-rspec)
|
||||||
|
|
Reference in New Issue