gnu: portaudio: Update to 190600.20161030.
* gnu/packages/audio.scm (portaudio): Update to 190600.20161030. * gnu/packages/patches/portaudio-audacity-compat.patch: Adjust line endings.master
parent
eb3574fb7d
commit
80420acb5e
|
@ -2433,7 +2433,7 @@ portions of LAME.")
|
||||||
(define-public portaudio
|
(define-public portaudio
|
||||||
(package
|
(package
|
||||||
(name "portaudio")
|
(name "portaudio")
|
||||||
(version "19.20140130")
|
(version "190600.20161030")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -2442,7 +2442,7 @@ portions of LAME.")
|
||||||
(string-map (lambda (c) (if (char=? c #\.) #\_ c)) version)
|
(string-map (lambda (c) (if (char=? c #\.) #\_ c)) version)
|
||||||
".tgz"))
|
".tgz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0mwddk4qzybaf85wqfhxqlf0c5im9il8z03rd4n127k8y2jj9q4g"))
|
(base32 "04qmin6nj144b8qb9kkd9a52xfvm0qdgm8bg8jbl7s3frmyiv8pm"))
|
||||||
(patches (search-patches "portaudio-audacity-compat.patch"))))
|
(patches (search-patches "portaudio-audacity-compat.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
|
|
|
@ -7,27 +7,27 @@ See <http://music.columbia.edu/pipermail/portaudio/2015-March/016611.html>.
|
||||||
--- a/include/pa_win_ds.h
|
--- a/include/pa_win_ds.h
|
||||||
+++ b/include/pa_win_ds.h
|
+++ b/include/pa_win_ds.h
|
||||||
@@ -89,6 +89,21 @@
|
@@ -89,6 +89,21 @@
|
||||||
|
|
||||||
}PaWinDirectSoundStreamInfo;
|
}PaWinDirectSoundStreamInfo;
|
||||||
|
|
||||||
+/** Retrieve the GUID of the input device.
|
+/** Retrieve the GUID of the input device.
|
||||||
+
|
+
|
||||||
+ @param stream The stream to query.
|
+ @param stream The stream to query.
|
||||||
+
|
+
|
||||||
+ @return A pointer to the GUID, or NULL if none.
|
+ @return A pointer to the GUID, or NULL if none.
|
||||||
+*/
|
+*/
|
||||||
+LPGUID PaWinDS_GetStreamInputGUID( PaStream* s );
|
+LPGUID PaWinDS_GetStreamInputGUID( PaStream* s );
|
||||||
+
|
+
|
||||||
+/** Retrieve the GUID of the output device.
|
+/** Retrieve the GUID of the output device.
|
||||||
+
|
+
|
||||||
+ @param stream The stream to query.
|
+ @param stream The stream to query.
|
||||||
+
|
+
|
||||||
+ @return A pointer to the GUID, or NULL if none.
|
+ @return A pointer to the GUID, or NULL if none.
|
||||||
+*/
|
+*/
|
||||||
+LPGUID PaWinDS_GetStreamOutputGUID( PaStream* s );
|
+LPGUID PaWinDS_GetStreamOutputGUID( PaStream* s );
|
||||||
|
|
||||||
|
|
||||||
#ifdef __cplusplus
|
#ifdef __cplusplus
|
||||||
--- a/include/portaudio.h
|
--- a/include/portaudio.h
|
||||||
+++ b/include/portaudio.h
|
+++ b/include/portaudio.h
|
||||||
@@ -1146,6 +1146,15 @@
|
@@ -1146,6 +1146,15 @@
|
||||||
|
@ -224,15 +224,15 @@ See <http://music.columbia.edu/pipermail/portaudio/2015-March/016611.html>.
|
||||||
--- a/src/hostapi/coreaudio/pa_mac_core_blocking.c
|
--- a/src/hostapi/coreaudio/pa_mac_core_blocking.c
|
||||||
+++ b/src/hostapi/coreaudio/pa_mac_core_blocking.c
|
+++ b/src/hostapi/coreaudio/pa_mac_core_blocking.c
|
||||||
@@ -66,6 +66,9 @@
|
@@ -66,6 +66,9 @@
|
||||||
#ifdef MOSX_USE_NON_ATOMIC_FLAG_BITS
|
#ifdef MOSX_USE_NON_ATOMIC_FLAG_BITS
|
||||||
# define OSAtomicOr32( a, b ) ( (*(b)) |= (a) )
|
# define OSAtomicOr32( a, b ) ( (*(b)) |= (a) )
|
||||||
# define OSAtomicAnd32( a, b ) ( (*(b)) &= (a) )
|
# define OSAtomicAnd32( a, b ) ( (*(b)) &= (a) )
|
||||||
+#elif MAC_OS_X_VERSION_MAX_ALLOWED <= MAC_OS_X_VERSION_10_3
|
+#elif MAC_OS_X_VERSION_MAX_ALLOWED <= MAC_OS_X_VERSION_10_3
|
||||||
+# define OSAtomicOr32( a, b ) BitOrAtomic( a, (UInt32 *) b )
|
+# define OSAtomicOr32( a, b ) BitOrAtomic( a, (UInt32 *) b )
|
||||||
+# define OSAtomicAnd32( a, b ) BitAndAtomic( a, (UInt32 *) b )
|
+# define OSAtomicAnd32( a, b ) BitAndAtomic( a, (UInt32 *) b )
|
||||||
#else
|
#else
|
||||||
# include <libkern/OSAtomic.h>
|
# include <libkern/OSAtomic.h>
|
||||||
#endif
|
#endif
|
||||||
--- a/src/hostapi/alsa/pa_linux_alsa.c
|
--- a/src/hostapi/alsa/pa_linux_alsa.c
|
||||||
+++ b/src/hostapi/alsa/pa_linux_alsa.c
|
+++ b/src/hostapi/alsa/pa_linux_alsa.c
|
||||||
@@ -611,6 +611,7 @@
|
@@ -611,6 +611,7 @@
|
||||||
|
|
Reference in New Issue