me
/
guix
Archived
1
0
Fork 0

gnu: abseil-cpp: Fix build on i686-linux.

* gnu/packages/cpp.scm (abseil-cpp)[source]: Add patch.
(abseil-cpp-20220623.1)[source]: Same.
* gnu/packages/patches/abseil-cpp-20220623.1-no-kepsilon-i686.patch: New
file.
* gnu/local.mk (dist_patch_DATA): Register it.

Change-Id: I27b9abc2c44ff6dc313209f4b0b12542a92d6fcd
master
Efraim Flashner 2024-05-21 09:25:07 +03:00
parent e50fc5380e
commit 81d08d7970
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 30 additions and 2 deletions

View File

@ -913,6 +913,7 @@ dist_patch_DATA = \
%D%/packages/patches/abiword-explictly-cast-bools.patch \
%D%/packages/patches/abseil-cpp-20200923.3-adjust-sysinfo.patch \
%D%/packages/patches/abseil-cpp-20200923.3-duration-test.patch \
%D%/packages/patches/abseil-cpp-20220623.1-no-kepsilon-i686.patch \
%D%/packages/patches/abseil-cpp-fix-strerror_test.patch \
%D%/packages/patches/adb-add-libraries.patch \
%D%/packages/patches/adb-libssl_11-compatibility.patch \

View File

@ -1456,7 +1456,9 @@ Google's C++ code base.")
(file-name (git-file-name name version))
(sha256
(base32
"0vxh2a74g4s45yr8kdjqnzl64k10qdlc0hbnn987a4cnwdj4bp9r"))))
"0vxh2a74g4s45yr8kdjqnzl64k10qdlc0hbnn987a4cnwdj4bp9r"))
(patches
(search-patches "abseil-cpp-20220623.1-no-kepsilon-i686.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments base)
((#:configure-flags flags)
@ -1477,7 +1479,9 @@ Google's C++ code base.")
(file-name (git-file-name name version))
(sha256
(base32
"1ydkkbanrpkp5i814arzsk973kyzhhjhagnp392rq6rrv16apldq"))))
"1ydkkbanrpkp5i814arzsk973kyzhhjhagnp392rq6rrv16apldq"))
(patches
(search-patches "abseil-cpp-20220623.1-no-kepsilon-i686.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments base)
((#:phases phases)

View File

@ -0,0 +1,23 @@
After an upstream code dump on 20220314 when this code was added this test started to fail on i686-linux.
diff --git a/absl/random/uniform_real_distribution_test.cc b/absl/random/uniform_real_distribution_test.cc
index 260aac96..0abef9b0 100644
--- a/absl/random/uniform_real_distribution_test.cc
+++ b/absl/random/uniform_real_distribution_test.cc
@@ -228,6 +228,8 @@ TYPED_TEST(UniformRealDistributionTest, ViolatesPreconditionsDeathTest) {
#endif // GTEST_HAS_DEATH_TEST
#if defined(NDEBUG)
+ // Except apparently not with 387 math
+#if !((defined(__i386__) || defined(_M_IX86)) && FLT_EVAL_METHOD != 0)
// opt-mode, for invalid parameters, will generate a garbage value,
// but should not enter an infinite loop.
absl::InsecureBitGen gen;
@@ -243,6 +245,7 @@ TYPED_TEST(UniformRealDistributionTest, ViolatesPreconditionsDeathTest) {
// Infinite result.
EXPECT_FALSE(std::isfinite(x)) << x;
}
+#endif // skip on i386
#endif // NDEBUG
}
#ifdef _MSC_VER