gnu: python-magic: Update to 0.4.27.
* gnu/packages/patches/python-magic-python-bytecode.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Unregister it. * gnu/packages/python-xyz.scm (python-magic): Update to 0.4.27. [source]<patches>: Remove field. [#:phases]<check>: Do not invoke ‘tests.py’. Signed-off-by: Andreas Enge <andreas@enge.fr>master
parent
794e8880b9
commit
827df9d1dd
|
@ -1776,7 +1776,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python-pyflakes-test-location.patch \
|
%D%/packages/patches/python-pyflakes-test-location.patch \
|
||||||
%D%/packages/patches/python-flint-includes.patch \
|
%D%/packages/patches/python-flint-includes.patch \
|
||||||
%D%/packages/patches/python-libxml2-utf8.patch \
|
%D%/packages/patches/python-libxml2-utf8.patch \
|
||||||
%D%/packages/patches/python-magic-python-bytecode.patch \
|
|
||||||
%D%/packages/patches/python-memcached-syntax-warnings.patch \
|
%D%/packages/patches/python-memcached-syntax-warnings.patch \
|
||||||
%D%/packages/patches/python-mox3-python3.6-compat.patch \
|
%D%/packages/patches/python-mox3-python3.6-compat.patch \
|
||||||
%D%/packages/patches/python-parso-unit-tests-in-3.10.patch \
|
%D%/packages/patches/python-parso-unit-tests-in-3.10.patch \
|
||||||
|
|
|
@ -1,19 +0,0 @@
|
||||||
File 5.41 changed the MIME type of Python bytecode; adjust accordingly.
|
|
||||||
|
|
||||||
Taken from upstream:
|
|
||||||
|
|
||||||
https://github.com/ahupp/python-magic/commit/0ae7e7ceac0e80e03adc75c858bb378c0427331a
|
|
||||||
|
|
||||||
diff --git a/test/test.py b/test/test.py
|
|
||||||
index 0c4621c..e443b84 100755
|
|
||||||
--- a/test/test.py
|
|
||||||
+++ b/test/test.py
|
|
||||||
@@ -90,7 +90,7 @@ def test_mime_types(self):
|
|
||||||
try:
|
|
||||||
m = magic.Magic(mime=True)
|
|
||||||
self.assert_values(m, {
|
|
||||||
- 'magic._pyc_': ('application/octet-stream', 'text/x-bytecode.python'),
|
|
||||||
+ 'magic._pyc_': ('application/octet-stream', 'text/x-bytecode.python', 'application/x-bytecode.python'),
|
|
||||||
'test.pdf': 'application/pdf',
|
|
||||||
'test.gz': ('application/gzip', 'application/x-gzip'),
|
|
||||||
'test.snappy.parquet': 'application/octet-stream',
|
|
|
@ -16857,17 +16857,16 @@ for Python inspired by modern web development.")
|
||||||
(define-public python-magic
|
(define-public python-magic
|
||||||
(package
|
(package
|
||||||
(name "python-magic")
|
(name "python-magic")
|
||||||
(version "0.4.24")
|
(version "0.4.27")
|
||||||
(home-page "https://github.com/ahupp/python-magic")
|
(home-page "https://github.com/ahupp/python-magic")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
(uri (git-reference (url home-page) (commit version)))
|
(uri (git-reference (url home-page) (commit version)))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(patches (search-patches "python-magic-python-bytecode.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"17jalhjbfd600lzfz296m0nvgp6c7vx1mgz82jbzn8hgdzknf4w0"))))
|
"1x11kfn4g244fia9a7y4ly8dqv5zsxfg3l5azc54dl6gkp2bk7vx"))))
|
||||||
(build-system python-build-system)
|
(build-system python-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:phases (modify-phases %standard-phases
|
'(#:phases (modify-phases %standard-phases
|
||||||
|
@ -16889,7 +16888,6 @@ for Python inspired by modern web development.")
|
||||||
(setenv "LC_ALL" "en_US.UTF-8")
|
(setenv "LC_ALL" "en_US.UTF-8")
|
||||||
(if tests?
|
(if tests?
|
||||||
(with-directory-excursion "test"
|
(with-directory-excursion "test"
|
||||||
(invoke "python" "./test.py")
|
|
||||||
(invoke "python" "./libmagic_test.py"))
|
(invoke "python" "./libmagic_test.py"))
|
||||||
(format #t "test suite not run~%")))))))
|
(format #t "test suite not run~%")))))))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
|
|
Reference in New Issue