me
/
guix
Archived
1
0
Fork 0

gnu: rcs: Update to 5.10.1.

* gnu/packages/version-control.scm (rcs): Update to 5.10.1.
[source]: Remove patch.
* gnu/packages/patches/rcs-5.10.0-no-stdin.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Efraim Flashner 2022-02-04 15:03:07 +02:00
parent 3d969e230d
commit 84ca88e756
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 4 additions and 63 deletions

View File

@ -1762,7 +1762,6 @@ dist_patch_DATA = \
%D%/packages/patches/raptor2-heap-overflow.patch \
%D%/packages/patches/ratpoints-sturm_and_rp_private.patch \
%D%/packages/patches/ratpoison-shell.patch \
%D%/packages/patches/rcs-5.10.0-no-stdin.patch \
%D%/packages/patches/rct-add-missing-headers.patch \
%D%/packages/patches/readline-link-ncurses.patch \
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \

View File

@ -1,57 +0,0 @@
http://git.savannah.gnu.org/cgit/rcs.git/patch/?id=8883c4f5a29be18e9ea09bd27a7b660830de45bb
From 8883c4f5a29be18e9ea09bd27a7b660830de45bb Mon Sep 17 00:00:00 2001
From: Thien-Thi Nguyen <ttn@gnu.org>
Date: Fri, 23 Oct 2020 09:23:49 -0400
Subject: [v] Don't test signal handling if stdin not ok.
<https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
* tests/t632: If stdin is not open and connected to
a tty, skip the signal handling portion of the test.
---
tests/ChangeLog | 9 +++++++++
tests/t632 | 9 +++++++++
2 files changed, 18 insertions(+)
diff --git a/tests/ChangeLog b/tests/ChangeLog
index c3715c0..0565058 100644
--- a/tests/ChangeLog
+++ b/tests/ChangeLog
@@ -1,3 +1,12 @@
+2020-10-23 Thien-Thi Nguyen <ttn@gnu.org>
+
+ [v] Don't test signal handling if stdin not ok.
+
+ <https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
+
+ * t632: If stdin is not open and connected to
+ a tty, skip the signal handling portion of the test.
+
2020-10-20 Thien-Thi Nguyen <ttn@gnu.org>
Release: 5.10.0
diff --git a/tests/t632 b/tests/t632
index df6acc9..677ec8c 100644
--- a/tests/t632
+++ b/tests/t632
@@ -40,6 +40,15 @@ echo | co -l -I $w \
# (This is skipped if GNU coreutils timeout(1) is not available.)
##
+# <https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
+# The timeout test needs co(1) to block on input.
+# If stdin is not open and connected to a tty, skip out.
+if test -t 0 ; then
+ echo STDIN OK
+else
+ exit 0
+fi
+
# TODO: Don't be lame! Pick one:
# (a) Mimic timeout(1) w/ sh commands.
# (b) Incorporate heart of timeout(1) into ./btdt and use that.
--
cgit v1.2.1

View File

@ -2011,15 +2011,14 @@ projects, from individuals to large-scale enterprise operations.")
(define-public rcs
(package
(name "rcs")
(version "5.10.0")
(version "5.10.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/rcs/rcs-"
version ".tar.xz"))
version ".tar.lz"))
(sha256
(base32
"1if5pa4iip2p70gljm54nggfdnsfjxa4cqz8fpj07lvsijary39s"))
(patches (search-patches "rcs-5.10.0-no-stdin.patch"))))
"1iac4d1dhsfy5zb0n3p605pihdq702v06r4g8vi8b2saf88gxpa3"))))
(build-system gnu-build-system)
(arguments `(#:phases
(modify-phases %standard-phases
@ -2031,7 +2030,7 @@ projects, from individuals to large-scale enterprise operations.")
(chmod "src/rcsfreeze" #o755)
(install-file "src/rcsfreeze" bin)
(install-file "man/rcsfreeze.1" man1)))))))
(native-inputs (list ed))
(native-inputs (list ed lzip))
(home-page "https://www.gnu.org/software/rcs/")
(synopsis "Per-file local revision control system")
(description