gnu: ccache: Update to 4.4.1.
* gnu/packages/ccache.scm (ccache): Update to 4.4.1. [source]: Add patch. [arguments]: Remove explicit #t return values from phases. * gnu/packages/patches/ccache-fix-basedir-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.master
parent
134e1b12f2
commit
85d757b53d
|
@ -915,6 +915,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/calibre-remove-test-unrar.patch \
|
||||
%D%/packages/patches/casync-renameat2-declaration.patch \
|
||||
%D%/packages/patches/catdoc-CVE-2017-11110.patch \
|
||||
%D%/packages/patches/ccache-fix-basedir-test.patch \
|
||||
%D%/packages/patches/circos-remove-findbin.patch \
|
||||
%D%/packages/patches/cdparanoia-fpic.patch \
|
||||
%D%/packages/patches/cdrtools-3.01-mkisofs-isoinfo.patch \
|
||||
|
|
|
@ -31,22 +31,23 @@
|
|||
(define-public ccache
|
||||
(package
|
||||
(name "ccache")
|
||||
(version "4.4")
|
||||
(version "4.4.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/ccache/ccache/releases/download/v"
|
||||
version "/ccache-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "0qbmcs6c3m071vsd1ppa31r8s0dzpaw5y38z8ga1bz48rwpfl2xl"))))
|
||||
(base32 "0nc1mlmj92lfa25d12nzf5n55az6zfx38n0z1qqkkzjxn6sxzmpb"))
|
||||
(patches
|
||||
(search-patches "ccache-fix-basedir-test.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs `(("perl" ,perl) ; for test/run
|
||||
("which" ,(@ (gnu packages base) which))))
|
||||
(inputs `(("zlib" ,zlib)
|
||||
("zstd" ,zstd "lib")))
|
||||
(arguments
|
||||
'(;; Disable redis backend explicitly. Build system insists on present dependency
|
||||
;; or on explicit flag.
|
||||
'( ;; The Redis backend must be explicitly disabled to build without Redis.
|
||||
#:configure-flags
|
||||
'("-DREDIS_STORAGE_BACKEND=OFF")
|
||||
|
||||
|
@ -55,13 +56,11 @@
|
|||
(add-before 'configure 'setup-tests
|
||||
(lambda _
|
||||
(substitute* '("unittest/test_hashutil.cpp" "test/suites/base.bash")
|
||||
(("#!/bin/sh") (string-append "#!" (which "sh"))))
|
||||
#t))
|
||||
(("#!/bin/sh") (string-append "#!" (which "sh"))))))
|
||||
(add-before 'check 'set-home
|
||||
;; Tests require a writable HOME.
|
||||
(lambda _
|
||||
(setenv "HOME" (getenv "TMPDIR"))
|
||||
#t)))))
|
||||
(setenv "HOME" (getenv "TMPDIR")))))))
|
||||
(home-page "https://ccache.dev/")
|
||||
(synopsis "Compiler cache")
|
||||
(description
|
||||
|
|
|
@ -0,0 +1,26 @@
|
|||
From ad18f15287b83cee5a45b63e02b31c6a601a134f Mon Sep 17 00:00:00 2001
|
||||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Mon, 27 Sep 2021 19:36:30 +0200
|
||||
Subject: [PATCH] gnu: ccache: Fix basedir test.
|
||||
|
||||
Applied upstream.
|
||||
---
|
||||
test/suites/basedir.bash | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test/suites/basedir.bash b/test/suites/basedir.bash
|
||||
index 479c632..34e5cb7 100644
|
||||
--- a/test/suites/basedir.bash
|
||||
+++ b/test/suites/basedir.bash
|
||||
@@ -269,7 +269,7 @@ EOF
|
||||
EOF
|
||||
backdate test.h
|
||||
|
||||
- pwd="$(/bin/pwd -P)"
|
||||
+ pwd="$(pwd -P)"
|
||||
$REAL_COMPILER -c $pwd/test.c 2>reference.stderr
|
||||
|
||||
CCACHE_ABSSTDERR=1 CCACHE_BASEDIR="$pwd" $CCACHE_COMPILE -c $pwd/test.c 2>ccache.stderr
|
||||
--
|
||||
2.33.0
|
||||
|
Reference in New Issue