me
/
guix
Archived
1
0
Fork 0

gnu: Remove python2-pygobject.

* gnu/packages/glib.scm (python2-pygobject, python2-pygobject-2): Delete
variables.
(python-pygobject)[properties]: Delete field.
* gnu/packages/patches/python2-pygobject-2-deprecation.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
* gnu/packages/gnome.scm (libsecret): Remove commented Python 2 inputs.
Maxim Cournoyer 2022-05-01 02:26:52 -04:00
parent 26876b6600
commit 88a77bdda1
No known key found for this signature in database
GPG Key ID: 1260E46482E63562
4 changed files with 1 additions and 116 deletions

View File

@ -1710,7 +1710,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pycrypto-time-clock.patch \
%D%/packages/patches/python-pyan3-fix-absolute-path-bug.patch \
%D%/packages/patches/python-pyan3-fix-positional-arguments.patch \
%D%/packages/patches/python2-pygobject-2-deprecation.patch \
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
%D%/packages/patches/python-pytorch-runpath.patch \
%D%/packages/patches/python-pytorch-system-libraries.patch \

View File

@ -816,44 +816,6 @@ useful for C++.")
(modify-inputs (package-propagated-inputs glibmm)
(replace "libsigc++" libsigc++-2)))))
(define-public python2-pygobject-2
(package
(name "python2-pygobject")
;; This was the last version to declare the 2.0 platform number, i.e. its
;; pkg-config files were named pygobject-2.0.pc
(version "2.28.7")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/pygobject/"
(version-major+minor version)
"/pygobject-" version ".tar.xz"))
(sha256
(base32
"0nkam61rsn7y3wik3vw46wk5q2cjfh2iph57hl9m39rc8jijb7dv"))
(patches (search-patches "python2-pygobject-2-deprecation.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)
("glib-bin" ,glib "bin") ;for tests: glib-compile-schemas
("pkg-config" ,pkg-config)
("dbus" ,dbus))) ;for tests
(inputs
`(("python" ,python-2)
("glib" ,glib)
("python2-pycairo" ,python2-pycairo)
("gobject-introspection" ,gobject-introspection)))
(propagated-inputs
(list libffi)) ;mentioned in pygobject-2.0.pc
(arguments
`(#:tests? #f ;segfaults during tests
#:configure-flags '("LIBS=-lcairo-gobject")))
(home-page "https://pypi.org/project/PyGObject/")
(synopsis "Python bindings for GObject")
(description
"Python bindings for GLib, GObject, and GIO.")
(license license:lgpl2.1+)))
(define-public python-pygobject
(package
(name "python-pygobject")
@ -902,37 +864,7 @@ useful for C++.")
(synopsis "Python bindings for GObject")
(description
"Python bindings for GLib, GObject, and GIO.")
(license license:lgpl2.1+)
(properties `((python2-variant . ,(delay python2-pygobject))))))
(define-public python2-pygobject
(let ((base (strip-python2-variant python-pygobject)))
(package/inherit base
(name "python2-pygobject")
;; Note: We use python-build-system here, because Meson only supports
;; Python 3, and needs PYTHONPATH etc set up correctly, which makes it
;; difficult to use for Python 2 projects.
(build-system python-build-system)
(arguments
`(#:python ,python-2
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'delete-broken-tests
(lambda _
;; FIXME: this test freezes and times out.
(delete-file "tests/test_mainloop.py")
;; FIXME: this test fails with this kind of error:
;; AssertionError: <Handlers.SIG_IGN: 1> != <built-in function default_int_handler
(delete-file "tests/test_ossig.py")
#t)))))
(inputs
`(("python-pycairo" ,python2-pycairo)
("gobject-introspection" ,gobject-introspection)))
(native-inputs
`(("glib-bin" ,glib "bin")
("pkg-config" ,pkg-config)
("python-pytest" ,python2-pytest))))))
(license license:lgpl2.1+)))
(define-public perl-glib
(package

View File

@ -4990,13 +4990,6 @@ and the GLib main loop, to integrate well with GNOME applications.")
("pkg-config" ,pkg-config)
("vala" ,vala)
("xsltproc" ,libxslt)))
;; These are needed for the tests.
;; FIXME: Add gjs once available.
;("dbus" ,dbus)
;("python2" ,python-2)
;("python2-dbus" ,python2-dbus)
;("python2-pygobject" ,python2-pygobject)
;("python2-pygobject-2" ,python2-pygobject-2)))
(propagated-inputs
(list glib)) ; required by libsecret-1.pc
(inputs

View File

@ -1,39 +0,0 @@
From e5df32ffbf37481dbb6a70c4d4e7b7b9778c5549 Mon Sep 17 00:00:00 2001
From: "John (J5) Palmieri" <johnp@redhat.com>
Date: Sat, 13 Aug 2011 04:13:28 -0400
Subject: remove references to deprecated GI_INFO_TYPE_ERROR_DOMAIN
diff --git a/gi/pygi-info.c b/gi/pygi-info.c
index 8729e25..007b609 100644
--- a/gi/pygi-info.c
+++ b/gi/pygi-info.c
@@ -165,9 +165,6 @@ _pygi_info_new (GIBaseInfo *info)
case GI_INFO_TYPE_CONSTANT:
type = &PyGIConstantInfo_Type;
break;
- case GI_INFO_TYPE_ERROR_DOMAIN:
- type = &PyGIErrorDomainInfo_Type;
- break;
case GI_INFO_TYPE_UNION:
type = &PyGIUnionInfo_Type;
break;
@@ -484,7 +481,6 @@ _pygi_g_type_info_size (GITypeInfo *type_info)
case GI_INFO_TYPE_INVALID:
case GI_INFO_TYPE_FUNCTION:
case GI_INFO_TYPE_CONSTANT:
- case GI_INFO_TYPE_ERROR_DOMAIN:
case GI_INFO_TYPE_VALUE:
case GI_INFO_TYPE_SIGNAL:
case GI_INFO_TYPE_PROPERTY:
@@ -863,7 +859,6 @@ pygi_g_struct_info_is_simple (GIStructInfo *struct_info)
case GI_INFO_TYPE_INVALID:
case GI_INFO_TYPE_FUNCTION:
case GI_INFO_TYPE_CONSTANT:
- case GI_INFO_TYPE_ERROR_DOMAIN:
case GI_INFO_TYPE_VALUE:
case GI_INFO_TYPE_SIGNAL:
case GI_INFO_TYPE_PROPERTY:
--
cgit v0.10.1