gnu: qtwayland: Fix build with GCC 11.
* gnu/packages/patches/qtwayland-gcc-11.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/qt.scm (qtwayland)[source](patches): New field.
parent
d8d4b81147
commit
88f976d160
|
@ -1750,6 +1750,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/qtscript-disable-tests.patch \
|
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||||
%D%/packages/patches/quagga-reproducible-build.patch \
|
%D%/packages/patches/quagga-reproducible-build.patch \
|
||||||
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
||||||
|
%D%/packages/patches/qtwayland-gcc-11.patch \
|
||||||
%D%/packages/patches/qtwebkit-pbutils-include.patch \
|
%D%/packages/patches/qtwebkit-pbutils-include.patch \
|
||||||
%D%/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch \
|
%D%/packages/patches/qtwebkit-fix-building-with-bison-3.7.patch \
|
||||||
%D%/packages/patches/qtwebkit-fix-building-with-python-3.9.patch \
|
%D%/packages/patches/qtwebkit-fix-building-with-python-3.9.patch \
|
||||||
|
|
|
@ -0,0 +1,18 @@
|
||||||
|
Add missing import for newer libstdc++.
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
|
||||||
|
https://github.com/qt/qtwayland/commit/1aa6ec2c778504d96543f6cdc2b9199a7b066fc1
|
||||||
|
|
||||||
|
diff --git a/tests/auto/client/shared/corecompositor.cpp b/tests/auto/client/shared/corecompositor.cpp
|
||||||
|
index 5c6c83baa..fa9b7662a 100644
|
||||||
|
--- a/tests/auto/client/shared/corecompositor.cpp
|
||||||
|
+++ b/tests/auto/client/shared/corecompositor.cpp
|
||||||
|
@@ -27,6 +27,7 @@
|
||||||
|
****************************************************************************/
|
||||||
|
|
||||||
|
#include "corecompositor.h"
|
||||||
|
+#include <thread>
|
||||||
|
|
||||||
|
namespace MockCompositor {
|
||||||
|
|
|
@ -1456,6 +1456,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (qt5-urls name version))
|
(uri (qt5-urls name version))
|
||||||
|
(patches (search-patches "qtwayland-gcc-11.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1ddfx4nak16xx0zh1kl836zxvpbixmmjyplsmfmg65pqkwi34dqr"))))
|
"1ddfx4nak16xx0zh1kl836zxvpbixmmjyplsmfmg65pqkwi34dqr"))))
|
||||||
|
|
Reference in New Issue