me
/
guix
Archived
1
0
Fork 0

gnu: mailutils: Fix unitialized variable in readmsg.

Fixes <https://bugs.gnu.org/43088>.

* gnu/packages/patches/mailutils-fix-uninitialized-variable.patch: New
file.
* gnu/packages/mail.scm (mailutils)[source]: Add patch.
* gnu/local.mk (dist_patch_DATA): Register patch.
master
Pierre Langlois 2020-09-13 13:02:52 +01:00
parent d7f7ed39be
commit 891b045f38
No known key found for this signature in database
GPG Key ID: A8FC9E447F4F7D54
3 changed files with 31 additions and 1 deletions

View File

@ -1291,6 +1291,7 @@ dist_patch_DATA = \
%D%/packages/patches/luajit-no_ldconfig.patch \
%D%/packages/patches/luit-posix.patch \
%D%/packages/patches/lvm2-static-link.patch \
%D%/packages/patches/mailutils-fix-uninitialized-variable.patch \
%D%/packages/patches/make-impure-dirs.patch \
%D%/packages/patches/mariadb-client-test-32bit.patch \
%D%/packages/patches/mars-install.patch \

View File

@ -197,7 +197,10 @@ example, modify the message headers or body, or encrypt or sign the message.")
version ".tar.xz"))
(sha256
(base32
"17smrxjdgbbzbzakik30vj46q4iib85ksqhb82jr4vjp57akszh9"))))
"17smrxjdgbbzbzakik30vj46q4iib85ksqhb82jr4vjp57akszh9"))
(patches
;; Fixes https://issues.guix.gnu.org/43088.
(search-patches "mailutils-fix-uninitialized-variable.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases

View File

@ -0,0 +1,26 @@
From 5ca6382fe8adb5bc436a6d873c8b86c69d5abfd1 Mon Sep 17 00:00:00 2001
From: Sergey Poznyakoff <gray@gnu.org>
Date: Sun, 13 Sep 2020 14:43:46 +0300
Subject: [PATCH] Fix uninitialized variable in readmsg
* readmsg/readmsg.c (main): Initialize weedc.
---
readmsg/readmsg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/readmsg/readmsg.c b/readmsg/readmsg.c
index 9f305bb9c..3a9f420db 100644
--- a/readmsg/readmsg.c
+++ b/readmsg/readmsg.c
@@ -466,7 +466,7 @@ main (int argc, char **argv)
mu_mailbox_t mbox = NULL;
struct mu_wordsplit ws;
char **weedv;
- int weedc;
+ int weedc = 0;
int unix_header = 0;
/* Native Language Support */
--
2.28.0