gnu: r-mixedpower: Update to b2b87068.
* gnu/packages/statistics.scm (r-mixedpower): Update to commit b2b87068546327d8f592d141e5482e0478c1b2ee, remove patch. * gnu/packages/patches/r-mixedpower-r2power.patch: Remove file. * gnu/local.mk: Unregister it.master
parent
a117510a8c
commit
89acc4d5c6
|
@ -1817,7 +1817,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/racket-zuo-bin-sh.patch \
|
||||
%D%/packages/patches/remake-impure-dirs.patch \
|
||||
%D%/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch \
|
||||
%D%/packages/patches/r-mixedpower-r2power.patch \
|
||||
%D%/packages/patches/rng-tools-revert-build-randstat.patch \
|
||||
%D%/packages/patches/rocm-comgr-3.1.0-dependencies.patch \
|
||||
%D%/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch \
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
From e882fda905150649aa887c72731144330ca297b5 Mon Sep 17 00:00:00 2001
|
||||
From: Lars-Dominik Braun <lars@6xq.net>
|
||||
Date: Fri, 28 Oct 2022 09:18:11 +0200
|
||||
Subject: [PATCH] Fix R2power with R>=4.2
|
||||
|
||||
The previous commit missed this if statement.
|
||||
---
|
||||
R/meta_functions.R | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/R/meta_functions.R b/R/meta_functions.R
|
||||
index a65f0c1..fb3feba 100644
|
||||
--- a/R/meta_functions.R
|
||||
+++ b/R/meta_functions.R
|
||||
@@ -172,7 +172,7 @@ R2power <- function(model, data, fixed_effects, simvar,
|
||||
} # end if databased
|
||||
|
||||
# 2. SESOI
|
||||
- suppressWarnings(if (SESOI != F){ # supress warning generated by if statement if SESOI =! F
|
||||
+ suppressWarnings(if (!is.logical(SESOI)){
|
||||
|
||||
# change beta coeficients to SESOI values
|
||||
model@beta <- SESOI
|
||||
--
|
||||
2.37.4
|
||||
|
|
@ -7276,9 +7276,10 @@ models, using simulation. It was designed to work with models fit using the
|
|||
(license license:gpl2+)))
|
||||
|
||||
(define-public r-mixedpower
|
||||
;; This commit contains fixes for R>=4.2. A newer release does not exist.
|
||||
(let ((commit "6520195481bca3ce01862ef80a28c53b0a35d0f5")
|
||||
(revision "1"))
|
||||
;; This commit contains fixes for R>=4.2 and contains new features. A
|
||||
;; newer release does not exist.
|
||||
(let ((commit "b2b87068546327d8f592d141e5482e0478c1b2ee")
|
||||
(revision "2"))
|
||||
(package
|
||||
(name "r-mixedpower")
|
||||
(version (git-version "2.0" revision commit))
|
||||
|
@ -7291,9 +7292,7 @@ models, using simulation. It was designed to work with models fit using the
|
|||
(commit commit)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "114z9pvya2jg10y804ga41gq00r7zcw4a7c7234ybhmv3jqw78q1"))
|
||||
(patches
|
||||
(search-patches "r-mixedpower-r2power.patch"))))
|
||||
(base32 "0pys66a6c1k2fp5qk9grhzg1q1d3q51rggcilmdssimkmcsm234z"))))
|
||||
(properties `((upstream-name . "mixedpower")))
|
||||
(build-system r-build-system)
|
||||
(propagated-inputs
|
||||
|
|
Reference in New Issue