gnu: pidgin: Upgrade to 2.14.1.
* gnu/packages/messaging.scm (pidgin) [version]: Modify. [source]<origin>[sha256]: Modify base32. [patches]<search-patches>[pidgin-libnm.patch]: Remove obsolete patch. * gnu/packages/patches/pidgin-libnm.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove entry. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>master
parent
f0e429a218
commit
89f4f0baa9
|
@ -1471,7 +1471,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/picard-fix-id3-rename-test.patch \
|
%D%/packages/patches/picard-fix-id3-rename-test.patch \
|
||||||
%D%/packages/patches/picprog-non-intel-support.patch \
|
%D%/packages/patches/picprog-non-intel-support.patch \
|
||||||
%D%/packages/patches/pidgin-add-search-path.patch \
|
%D%/packages/patches/pidgin-add-search-path.patch \
|
||||||
%D%/packages/patches/pidgin-libnm.patch \
|
|
||||||
%D%/packages/patches/pinball-const-fix.patch \
|
%D%/packages/patches/pinball-const-fix.patch \
|
||||||
%D%/packages/patches/pinball-cstddef.patch \
|
%D%/packages/patches/pinball-cstddef.patch \
|
||||||
%D%/packages/patches/pinball-missing-separators.patch \
|
%D%/packages/patches/pinball-missing-separators.patch \
|
||||||
|
|
|
@ -718,25 +718,22 @@ authentication.")
|
||||||
(define-public pidgin
|
(define-public pidgin
|
||||||
(package
|
(package
|
||||||
(name "pidgin")
|
(name "pidgin")
|
||||||
(version "2.13.0")
|
(version "2.14.1")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri
|
(uri
|
||||||
(string-append "mirror://sourceforge/pidgin/Pidgin/"
|
(string-append "mirror://sourceforge/pidgin/Pidgin/"
|
||||||
version "/pidgin-" version ".tar.bz2"))
|
version "/pidgin-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "13vdqj70315p9rzgnbxjp9c51mdzf1l4jg1kvnylc4bidw61air7"))
|
(base32 "1c4dzxg9c3d9zfqqa7jwijj9rv9fm6w95igmpljwy88lxq7v5w11"))
|
||||||
(patches
|
(patches
|
||||||
(search-patches
|
(search-patches
|
||||||
"pidgin-add-search-path.patch"
|
"pidgin-add-search-path.patch"))
|
||||||
;; Remove the snippet and bootstrapping
|
|
||||||
;; native-inputs together with this patch.
|
|
||||||
"pidgin-libnm.patch"))
|
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
'(begin
|
'(begin
|
||||||
;; Remove stale generated file after applying pidgin-libnm.patch.
|
;; Remove stale generated file after applying patches.
|
||||||
(delete-file "configure")
|
(delete-file "configure")
|
||||||
#t))))
|
#t))))
|
||||||
(build-system glib-or-gtk-build-system)
|
(build-system glib-or-gtk-build-system)
|
||||||
|
|
|
@ -1,60 +0,0 @@
|
||||||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
|
||||||
Date: Sun, 24 May 2020 16:11:01 +0200
|
|
||||||
Subject: [PATCH] gnu: pidgin: Find libnm.
|
|
||||||
|
|
||||||
Copied verbatim from[0].
|
|
||||||
|
|
||||||
[0]: https://git.archlinux.org/svntogit/packages.git/plain/trunk/pidgin-nm-1.0.patch?h=packages/pidgin
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 04836fa..0a2d451 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -1423,18 +1423,24 @@ fi
|
|
||||||
dnl Check for NetworkManager.h; if we don't have it, oh well
|
|
||||||
if test "x$enable_dbus" = "xyes" ; then
|
|
||||||
if test "x$enable_nm" = "xyes" ; then
|
|
||||||
- PKG_CHECK_MODULES(NETWORKMANAGER, [NetworkManager >= 0.5.0], [
|
|
||||||
+ PKG_CHECK_MODULES(NETWORKMANAGER, [libnm], [
|
|
||||||
AC_SUBST(NETWORKMANAGER_CFLAGS)
|
|
||||||
AC_SUBST(NETWORKMANAGER_LIBS)
|
|
||||||
AC_DEFINE(HAVE_NETWORKMANAGER, 1, [Define if we have NetworkManager.])
|
|
||||||
], [
|
|
||||||
- enable_nm=no
|
|
||||||
- if test "x$force_deps" = "xyes" ; then
|
|
||||||
- AC_MSG_ERROR([
|
|
||||||
+ PKG_CHECK_MODULES(NETWORKMANAGER, [NetworkManager >= 0.5.0], [
|
|
||||||
+ AC_SUBST(NETWORKMANAGER_CFLAGS)
|
|
||||||
+ AC_SUBST(NETWORKMANAGER_LIBS)
|
|
||||||
+ AC_DEFINE(HAVE_NETWORKMANAGER, 1, [Define if we have NetworkManager.])
|
|
||||||
+ ], [
|
|
||||||
+ enable_nm=no
|
|
||||||
+ if test "x$force_deps" = "xyes" ; then
|
|
||||||
+ AC_MSG_ERROR([
|
|
||||||
NetworkManager development headers not found.
|
|
||||||
Use --disable-nm if you do not need NetworkManager support.
|
|
||||||
])
|
|
||||||
- fi])
|
|
||||||
+ fi])
|
|
||||||
+ ])
|
|
||||||
fi
|
|
||||||
else
|
|
||||||
enable_nm=no
|
|
||||||
diff --git a/libpurple/network.c b/libpurple/network.c
|
|
||||||
index c43e3c7..b17e439 100644
|
|
||||||
--- a/libpurple/network.c
|
|
||||||
+++ b/libpurple/network.c
|
|
||||||
@@ -939,8 +939,13 @@ nm_update_state(NMState state)
|
|
||||||
#if NM_CHECK_VERSION(0,8,992)
|
|
||||||
case NM_STATE_DISCONNECTING:
|
|
||||||
#endif
|
|
||||||
+#if NM_CHECK_VERSION(1,0,0)
|
|
||||||
+ if (prev != NM_STATE_CONNECTED_GLOBAL && prev != NM_STATE_UNKNOWN)
|
|
||||||
+ break;
|
|
||||||
+#else
|
|
||||||
if (prev != NM_STATE_CONNECTED && prev != NM_STATE_UNKNOWN)
|
|
||||||
break;
|
|
||||||
+#endif
|
|
||||||
if (ui_ops != NULL && ui_ops->network_disconnected != NULL)
|
|
||||||
ui_ops->network_disconnected();
|
|
||||||
break;
|
|
Reference in New Issue