gnu: Add perl-finance-quote.
* gnu/packages/web.scm (perl-finance-quote): New variable. * gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.master
parent
bb1ba6b8f7
commit
8b45993235
|
@ -592,6 +592,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/patchelf-rework-for-arm.patch \
|
gnu/packages/patches/patchelf-rework-for-arm.patch \
|
||||||
gnu/packages/patches/patchutils-xfail-gendiff-tests.patch \
|
gnu/packages/patches/patchutils-xfail-gendiff-tests.patch \
|
||||||
gnu/packages/patches/patch-hurd-path-max.patch \
|
gnu/packages/patches/patch-hurd-path-max.patch \
|
||||||
|
gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
|
||||||
gnu/packages/patches/perl-gd-options-passthrough-and-fontconfig.patch \
|
gnu/packages/patches/perl-gd-options-passthrough-and-fontconfig.patch \
|
||||||
gnu/packages/patches/perl-module-pluggable-search.patch \
|
gnu/packages/patches/perl-module-pluggable-search.patch \
|
||||||
gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch \
|
gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch \
|
||||||
|
|
|
@ -0,0 +1,15 @@
|
||||||
|
Rather than unconditionally using Mozilla's CA certificates, let the user tell
|
||||||
|
LWP's UserAgent where to find certificates with the PERL_LWP_SSL_CA_FILE,
|
||||||
|
HTTPS_CA_FILE, PERL_LWP_SSL_CA_PATH, or HTTPS_CA_DIR environment variables
|
||||||
|
instead.
|
||||||
|
|
||||||
|
--- Finance-Quote-1.37/lib/Finance/Quote/Tiaacref.pm.orig 2015-02-01 13:24:41.000000000 -0600
|
||||||
|
+++ Finance-Quote-1.37/lib/Finance/Quote/Tiaacref.pm 2015-07-07 20:09:47.278885944 -0500
|
||||||
|
@@ -30,7 +30,6 @@
|
||||||
|
package Finance::Quote::Tiaacref;
|
||||||
|
require 5.005;
|
||||||
|
require LWP::Protocol::https;
|
||||||
|
-require Mozilla::CA;
|
||||||
|
|
||||||
|
use strict;
|
||||||
|
|
|
@ -1673,6 +1673,39 @@ with Encode::decode(locale => $string).")
|
||||||
which can be used to parse directory listings.")
|
which can be used to parse directory listings.")
|
||||||
(home-page "http://search.cpan.org/~gaas/File-Listing/")))
|
(home-page "http://search.cpan.org/~gaas/File-Listing/")))
|
||||||
|
|
||||||
|
(define-public perl-finance-quote
|
||||||
|
(package
|
||||||
|
(name "perl-finance-quote")
|
||||||
|
(version "1.37")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "https://cpan.metacpan.org/authors/id/E/EC/ECOCODE/"
|
||||||
|
"Finance-Quote-" version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1b6pbh7f76fb5sa4f0lhx085xy55pprz5v7z7li7pqiyw7i4f4bf"))
|
||||||
|
(patches (list
|
||||||
|
(search-patch "perl-finance-quote-unuse-mozilla-ca.patch")))))
|
||||||
|
(build-system perl-build-system)
|
||||||
|
(propagated-inputs
|
||||||
|
`(("perl-datetime" ,perl-datetime)
|
||||||
|
("perl-html-parser" ,perl-html-parser)
|
||||||
|
("perl-html-tableextract" ,perl-html-tableextract)
|
||||||
|
("perl-html-tree" ,perl-html-tree)
|
||||||
|
("perl-http-cookies" ,perl-http-cookies)
|
||||||
|
("perl-http-message" ,perl-http-message)
|
||||||
|
("perl-json" ,perl-json)
|
||||||
|
("perl-libwww" ,perl-libwww)
|
||||||
|
("perl-lwp-protocol-https" ,perl-lwp-protocol-https)
|
||||||
|
("perl-uri" ,perl-uri)))
|
||||||
|
(home-page "http://search.cpan.org/dist/Finance-Quote")
|
||||||
|
(synopsis "Stock and mutual fund quotes")
|
||||||
|
(description
|
||||||
|
"Finance::Quote gets stock quotes from various internet sources, including
|
||||||
|
Yahoo! Finance, Fidelity Investments, and the Australian Stock Exchange.")
|
||||||
|
(license l:gpl2)))
|
||||||
|
|
||||||
(define-public perl-gssapi
|
(define-public perl-gssapi
|
||||||
(package
|
(package
|
||||||
(name "perl-gssapi")
|
(name "perl-gssapi")
|
||||||
|
|
Reference in New Issue