me
/
guix
Archived
1
0
Fork 0

gnu: mesa: Skip another test.

* gnu/packages/patches/mesa-skip-disk-cache-test.patch: Rename to ...
* gnu/packages/patches/mesa-skip-tests.patch: ... new file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/gl.scm (mesa)[source]: Adjust accordingly.
master
Leo Famulari 2021-01-18 14:39:13 -05:00
parent 6985a1acb3
commit 8b55544212
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
4 changed files with 51 additions and 21 deletions

View File

@ -1348,7 +1348,7 @@ dist_patch_DATA = \
%D%/packages/patches/libmemcached-build-with-gcc7.patch \
%D%/packages/patches/libmhash-hmac-fix-uaf.patch \
%D%/packages/patches/mediastreamer2-srtp2.patch \
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
%D%/packages/patches/mesa-skip-tests.patch \
%D%/packages/patches/mescc-tools-boot.patch \
%D%/packages/patches/meson-for-build-rpath.patch \
%D%/packages/patches/metabat-fix-compilation.patch \

View File

@ -249,7 +249,7 @@ also known as DXTn or DXTC) for Mesa.")
(base32
"14m09bk7akj0k02lg8fhvvzbdsashlbdsgl2cw7wbqfj2mhdqwh5"))
(patches
(search-patches "mesa-skip-disk-cache-test.patch"))))
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
(propagated-inputs
`(;; The following are in the Requires.private field of gl.pc.

View File

@ -1,19 +0,0 @@
disk_cache_create() here looks up the users home directory from <pwd.h>
which resolves to "/" in the build environment. I could not find an easy
way to set the home directory to something else, so we disable this test
for now.
--- a/src/compiler/glsl/tests/cache_test.c
+++ b/src/compiler/glsl/tests/cache_test.c
@@ -170,11 +170,6 @@
unsetenv("MESA_GLSL_CACHE_DIR");
unsetenv("XDG_CACHE_HOME");
- cache = disk_cache_create("test", "make_check", 0);
- expect_non_null(cache, "disk_cache_create with no environment variables");
-
- disk_cache_destroy(cache);
-
/* Test with XDG_CACHE_HOME set */
setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
cache = disk_cache_create("test", "make_check", 0);

View File

@ -0,0 +1,49 @@
disk_cache_create() here looks up the users home directory from <pwd.h>
which resolves to "/" in the build environment. I could not find an easy
way to set the home directory to something else, so we disable this test
for now.
--- a/src/compiler/glsl/tests/cache_test.c
+++ b/src/compiler/glsl/tests/cache_test.c
@@ -170,11 +170,6 @@
unsetenv("MESA_GLSL_CACHE_DIR");
unsetenv("XDG_CACHE_HOME");
- cache = disk_cache_create("test", "make_check", 0);
- expect_non_null(cache, "disk_cache_create with no environment variables");
-
- disk_cache_destroy(cache);
-
/* Test with XDG_CACHE_HOME set */
setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
cache = disk_cache_create("test", "make_check", 0);
This test fails on i686-linux. I couldn't come up with a regex that
could be used to disable it just on i686-linux, so we disable it
completely with this patch:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
diff --git a/src/util/meson.build b/src/util/meson.build
index 0893f64..909b3e0 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -289,18 +289,6 @@ if with_tests
suite : ['util'],
)
- test(
- 'u_debug_stack',
- executable(
- 'u_debug_stack_test',
- files('u_debug_stack_test.cpp'),
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
- dependencies : [idep_mesautil, idep_gtest],
- c_args : [c_msvc_compat_args],
- ),
- suite : ['util'],
- )
-
process_test_exe = executable(
'process_test',
files('process_test.c'),