me
/
guix
Archived
1
0
Fork 0

gnu: Qt: Update to 5.14.2.

* gnu/packages/qt.scm (qtsvg, qtimageformats, qtx11extras,
qtxmlpatterns, qtconnectivity, qtwebsockets, qtsensors,
qtmultimedia, qtserialport, qtserialbus, qtwebchannel,
qtwebview, qtlocation, qttools, qtscript, qtquickcontrols,
qtquickcontrols2, qtgraphicaleffects, qtgamepad, qtscxml,
qtpurchasing, qtcharts, qtdatavis3d, qtnetworkauth,
qtspeech, qtwebengine): Update to 5.14.2.
(qtcanvas3d): Remove variable.  Upstream deprecated it.
(qtbase)[source](patches): Remove qtbase-QTBUG-81715.patch.
[arguments]: Drop X11lib substitution: patched dir no longer exists.
(qtwayland)[arguments]: Disable two tests, and add phase to prevent fatal DBus
warnings.
(qtwebglplugin)[inputs]: Add ZLIB.
(qtremoteobjects): Disable some tests that fail due to missing network.
(qtdeclarative)[native-inputs]: Add VULKAN-HEADERS.
(qtwebengine)[source](snippet): Adjust list of preserved files.
[inputs]: Add VULKAN-HEADERS.
* gnu/packages/patches/qtbase-QTBUG-81715.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.

Co-authored-by: Marius Bakke <mbakke@fastmail.com>
master
TomZ 2020-04-23 00:21:31 +02:00 committed by Marius Bakke
parent 9d3965edca
commit 8d1ab36a56
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
4 changed files with 123 additions and 172 deletions

View File

@ -1442,7 +1442,6 @@ dist_patch_DATA = \
%D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtbase-moc-ignore-gcc-macro.patch \
%D%/packages/patches/qtbase-use-TZDIR.patch \
%D%/packages/patches/qtbase-QTBUG-81715.patch \
%D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/quagga-reproducible-build.patch \
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \

View File

@ -1,40 +0,0 @@
From 8a3fde00bf53d99e9e4853e8ab97b0e1bcf74915 Mon Sep 17 00:00:00 2001
From: Joerg Bornemann <joerg.bornemann@qt.io>
Date: Wed, 29 Jan 2020 11:06:35 +0100
Subject: [PATCH] Fix qt5_make_output_file macro for paths containing dots
Commit 89bd5a7e broke CMake projects that use dots in their build
paths, because the used regular expression matches the directory part
of the path as well.
The regex wants to achieve the same as get_filename_component(...
NAME_WLE) which is available since CMake 3.14. Re-implement the
NAME_WLE functionality for older CMake versions by using multiple
get_filename_component calls.
Fixes: QTBUG-81715
Task-number: QTBUG-80295
Change-Id: I2ef053300948f6e1b2c0c5eafac35105f193d4e6
Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
---
diff --git a/src/corelib/Qt5CoreMacros.cmake b/src/corelib/Qt5CoreMacros.cmake
index 7735e51..b3da640 100644
--- a/src/corelib/Qt5CoreMacros.cmake
+++ b/src/corelib/Qt5CoreMacros.cmake
@@ -59,7 +59,14 @@
set(_outfile "${CMAKE_CURRENT_BINARY_DIR}/${rel}")
string(REPLACE ".." "__" _outfile ${_outfile})
get_filename_component(outpath ${_outfile} PATH)
- string(REGEX REPLACE "\\.[^.]*$" "" _outfile ${_outfile})
+ if(CMAKE_VERSION VERSION_LESS "3.14")
+ get_filename_component(_outfile_ext ${_outfile} EXT)
+ get_filename_component(_outfile_ext ${_outfile_ext} NAME_WE)
+ get_filename_component(_outfile ${_outfile} NAME_WE)
+ string(APPEND _outfile ${_outfile_ext})
+ else()
+ get_filename_component(_outfile ${_outfile} NAME_WLE)
+ endif()
file(MAKE_DIRECTORY ${outpath})
set(${outfile} ${outpath}/${prefix}${_outfile}.${ext})
endmacro()

View File

@ -4,8 +4,8 @@ important to be able to update it fast.
Based on a patch fron NixOS.
===================================================================
--- qtbase-opensource-src-5.9.4.orig/src/corelib/tools/qtimezoneprivate_tz.cpp
+++ qtbase-opensource-src-5.9.4/src/corelib/tools/qtimezoneprivate_tz.cpp
--- qtbase-opensource-src-5.14.2.orig/src/corelib/time/qtimezoneprivate_tz.cpp
+++ qtbase-opensource-src-5.15.2/src/corelib/time/qtimezoneprivate_tz.cpp
@@ -70,7 +70,11 @@
// Parse zone.tab table, assume lists all installed zones, if not will need to read directories
static QTzTimeZoneHash loadTzTimeZones()

View File

@ -16,6 +16,7 @@
;;; Copyright © 2020 Mike Rosset <mike.rosset@gmail.com>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020 TomZ <tomz@freedommail.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@ -352,7 +353,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(define-public qtbase
(package
(name "qtbase")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -361,11 +362,10 @@ developers using C++ or QML, a CSS & JavaScript like language.")
version ".tar.xz"))
(sha256
(base32
"0pb68d30clksdhgy8n6rrs838bb3qcsfq4pv463yy2nr4p5kk2di"))
"12mjsahlma9rw3vz9a6b5h2s6ylg8b34hxc2vnlna5ll429fgfa8"))
;; Use TZDIR to avoid depending on package "tzdata".
(patches (search-patches "qtbase-use-TZDIR.patch"
"qtbase-moc-ignore-gcc-macro.patch"
"qtbase-QTBUG-81715.patch"))
"qtbase-moc-ignore-gcc-macro.patch"))
(modules '((guix build utils)))
(snippet
;; corelib uses bundled harfbuzz, md4, md5, sha3
@ -571,14 +571,6 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"src/network/kernel/qhostinfo_unix.cpp")
(("^\\s*(lib.setFileName\\(QLatin1String\\(\")(resolv\"\\)\\);)" _ a b)
(string-append a glibc "/lib/lib" b))))
;; X11/locale (compose path)
(substitute* "src/plugins/platforminputcontexts/compose/generator/qtablegenerator.cpp"
;; Don't search in /usr/…/X11/locale, …
(("^\\s*m_possibleLocations.append\\(QStringLiteral\\(\"/usr/.*/X11/locale\"\\)\\);" line)
(string-append "// " line))
;; … but use libx11's path
(("^\\s*(m_possibleLocations.append\\(QStringLiteral\\()X11_PREFIX \"(/.*/X11/locale\"\\)\\);)" _ a b)
(string-append a "\"" (assoc-ref inputs "libx11") b)))
;; libGL
(substitute* "src/plugins/platforms/xcb/gl_integrations/xcb_glx/qglxintegration.cpp"
(("^\\s*(QLibrary lib\\(QLatin1String\\(\")(GL\"\\)\\);)" _ a b)
@ -618,7 +610,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(define-public qtsvg
(package (inherit qtbase)
(name "qtsvg")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -627,7 +619,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
version ".tar.xz"))
(sha256
(base32
"1f3vqv3s83gjillhgi0wghyf3825fgy1ffhvkxhdk673shb0kxjb"))))
"18dmfc8s428fzbk7k5vl3212b25455ayrz7s716nwyiy3ahgmmy7"))))
(propagated-inputs `())
(native-inputs `(("perl" ,perl)))
(inputs
@ -693,7 +685,7 @@ HostData=lib/qt5
(define-public qtimageformats
(package (inherit qtsvg)
(name "qtimageformats")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -702,7 +694,7 @@ HostData=lib/qt5
version ".tar.xz"))
(sha256
(base32
"02zpcbx71dz6xvga07dnzqwdfz9pjmy673n706fj8pxq9zi9xlcv"))
"132g4rlm61pdcpcrclr1rwpbrxn7va4wjfb021mh8pn1cl0wlgkk"))
(modules '((guix build utils)))
(snippet
'(begin
@ -724,7 +716,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
(define-public qtx11extras
(package (inherit qtsvg)
(name "qtx11extras")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -733,7 +725,7 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
version ".tar.xz"))
(sha256
(base32
"15hb90n47khsp3qnzyjd3mh8gi9qvy07dqdr4qspiww43r5mz293"))))
"0njlh6d327nll7d8qaqrwr5x15m9yzgyar2j45qigs1f7ah896my"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -748,7 +740,7 @@ from within Qt 5.")))
(define-public qtxmlpatterns
(package (inherit qtsvg)
(name "qtxmlpatterns")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -757,7 +749,7 @@ from within Qt 5.")))
version ".tar.xz"))
(sha256
(base32
"0ys1kf0zdn8gak1ik9p7i7bdyfz2frvklcyz013s9wm1550h20lh"))))
"1dyg1z4349k04yyzn8xbp4f5qjgm60gz6wgzp80khpilcmk8g6i1"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f) ; TODO: Enable the tests
@ -779,7 +771,7 @@ xmlpatternsvalidator.")))
(define-public qtdeclarative
(package (inherit qtsvg)
(name "qtdeclarative")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -788,7 +780,7 @@ xmlpatternsvalidator.")))
version ".tar.xz"))
(sha256
(base32
"1gg9xbv8ah4p55ws97brwn0csl0k3j1x6zdknrrsnh7j6nh0bp2w"))))
"0l0nhc2si6dl9r4s1bs45z90qqigs8jnrsyjjdy38q4pvix63i53"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -797,7 +789,8 @@ xmlpatternsvalidator.")))
("pkg-config" ,pkg-config)
("python" ,python)
("python-wrapper" ,python-wrapper)
("qtsvg" ,qtsvg)))
("qtsvg" ,qtsvg)
("vulkan-headers" ,vulkan-headers)))
(inputs
`(("mesa" ,mesa)
("qtbase" ,qtbase)))
@ -811,7 +804,7 @@ with JavaScript and C++.")))
(define-public qtconnectivity
(package (inherit qtsvg)
(name "qtconnectivity")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -820,7 +813,7 @@ with JavaScript and C++.")))
version ".tar.xz"))
(sha256
(base32
"06h71pd5w5prh722mcbgmx7l71xvh5xpjrlbg17yblx0n6wlhwb4"))))
"0a5wzin635b926b8prdwfazgy1vhyf8m6an64wp2lpkp78z7prmb"))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)
@ -835,7 +828,7 @@ with Bluetooth and NFC.")))
(define-public qtwebsockets
(package (inherit qtsvg)
(name "qtwebsockets")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -844,7 +837,7 @@ with Bluetooth and NFC.")))
version ".tar.xz"))
(sha256
(base32
"05rv52pp5zg4g14zh7c6jc77l426056b8xyr40ps6cpmb0jkrlbg"))))
"116amx4mnv50k0fpswgpr5x8wjny8nbffrjmld01pzhkhfqn4vph"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -862,7 +855,7 @@ consume data received from the server, or both.")))
(define-public qtsensors
(package (inherit qtsvg)
(name "qtsensors")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -871,7 +864,7 @@ consume data received from the server, or both.")))
version ".tar.xz"))
(sha256
(base32
"0h77h34rn6cgy5qiqq163pj3bhbka1ydkfgjcx01ns1g9sgym6ib"))))
"0qccpgbhyg9k4x5nni7xm0pyvaqia3zrcd42cn7ksf5h21lwmkxw"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:parallel-tests? _ #f) #f) ; can lead to race condition
@ -895,7 +888,7 @@ recognition API for devices.")))
(define-public qtmultimedia
(package (inherit qtsvg)
(name "qtmultimedia")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -904,7 +897,7 @@ recognition API for devices.")))
version ".tar.xz"))
(sha256
(base32
"07fvnjywn3hkrxfbxasmy83jr6jq9lf1grasfwij54hz6y0smg98"))
"1sczzcvk3c5gczz53yvp8ma6gp8aixk5pcq7wh344c9md3g8xkbs"))
(modules '((guix build utils)))
(snippet
'(begin
@ -946,7 +939,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
(define-public qtwayland
(package (inherit qtsvg)
(name "qtwayland")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -955,7 +948,7 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
version ".tar.xz"))
(sha256
(base32
"1ib61zh6jrab3yz592p47ldfgphi4i184kqf14vhwn31akibh6pw"))
"0al3yypy3fin62n8d1859jh0mn0fbpa161l7f37hgd4gf75365nk"))
(modules '((guix build utils)))
(snippet
;; The examples try to build and cause the build to fail
@ -966,13 +959,21 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
`(modify-phases ,phases
(add-before 'check 'set-ld-library-path
;; <https://lists.gnu.org/archive/html/guix-devel/2017-09/msg00019.html>
;;
;; Make the uninstalled libQt5WaylandClient.so.5 available to the
;; wayland platform plugin.
(add-after 'unpack 'disable-failing-tests
(lambda _
(setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/lib"))
;; FIXME: tst_seatv4::animatedCursor() fails for no good
;; reason and breaks these two tests.
(substitute* "tests/auto/client/seatv4/tst_seatv4.cpp"
(((string-append "QVERIFY\\(!cursorSurface\\(\\)->"
"m_waitingFrameCallbacks\\.empty\\(\\)\\);"))
"")
(("QTRY_COMPARE\\(bufferSpy\\.count\\(\\), 1\\);")
""))
#t))
(add-before 'check 'set-test-environment
(lambda _
;; Do not fail just because /etc/machine-id is missing.
(setenv "DBUS_FATAL_WARNINGS" "0")
#t))))))
(native-inputs
`(("glib" ,glib)
@ -998,7 +999,7 @@ compositor libraries.")))
(define-public qtserialport
(package (inherit qtsvg)
(name "qtserialport")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1007,7 +1008,7 @@ compositor libraries.")))
version ".tar.xz"))
(sha256
(base32
"07vjv3p7n7n5v15wdpi8x5sbnvyjqdh85qfzf9mz8l6ppqp2hk12"))))
"08ga9a1lwj83872nxablk602z1dq0la6jqsiicvd7m1sfbfpgnd6"))))
(native-inputs `(("perl" ,perl)))
(inputs
`(("qtbase" ,qtbase)
@ -1032,7 +1033,7 @@ interacting with serial ports from within Qt.")))
(define-public qtserialbus
(package (inherit qtsvg)
(name "qtserialbus")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1041,7 +1042,7 @@ interacting with serial ports from within Qt.")))
version ".tar.xz"))
(sha256
(base32
"1bkyk1v7bcq657n88a6675lj55vl9y8v46h4kf27v58yjzgiw842"))))
"14bahg82jciciqkl74q9hvf3a8kp3pk5v731vp2416k4b8bn4xqb"))))
(inputs
`(("qtbase" ,qtbase)
("qtserialport" ,qtserialport)))
@ -1053,7 +1054,7 @@ and others.")))
(define-public qtwebchannel
(package (inherit qtsvg)
(name "qtwebchannel")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1062,7 +1063,7 @@ and others.")))
version ".tar.xz"))
(sha256
(base32
"0xff3fbbpcl0kkq0rg9npj127ycirygicbkxlf0v593sjpjp5bmh"))))
"0x7q66994pw6cd0f505bmirw1sssqs740zaw8lyqqqr32m2ch7bx"))))
(native-inputs
`(("perl" ,perl)
("qtdeclarative" ,qtdeclarative)
@ -1077,7 +1078,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
(define-public qtwebglplugin
(package (inherit qtsvg)
(name "qtwebglplugin")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1086,7 +1087,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
version ".tar.xz"))
(sha256
(base32
"0fswnmhb8fm7wqgzv8cjy1j2sgb5mhx80jl411laawn7bf2ysjg0"))))
"05rl657848fsprsnabdqb5z363c6drjc32k59223vl351f8ihhgb"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@ -1100,7 +1101,8 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
`(("mesa" ,mesa)
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtwebsockets" ,qtwebsockets)))
("qtwebsockets" ,qtwebsockets)
("zlib" ,zlib)))
(synopsis "QPA plugin for running an application via a browser using
streamed WebGL commands")
(description "Qt back end that uses WebGL for rendering. It allows Qt
@ -1112,7 +1114,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
(define-public qtwebview
(package (inherit qtsvg)
(name "qtwebview")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1121,7 +1123,7 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
version ".tar.xz"))
(sha256
(base32
"1rvvkg6dl34hklllnlzlcffik746f15lzxdnwggc97dmx8n2vy6k"))))
"0jzzcm7z5njkddzfhmyjz4dbbzq8h93980cci4479zc4xq9r47y6"))))
(native-inputs
`(("perl" ,perl)))
(inputs
@ -1135,7 +1137,7 @@ native APIs where it makes sense.")))
(define-public qtlocation
(package (inherit qtsvg)
(name "qtlocation")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1144,7 +1146,7 @@ native APIs where it makes sense.")))
version ".tar.xz"))
(sha256
(base32
"07vq4aycayq2bg8yi4awidb25xyvws2ajbnrmad3rnpg1fw0bsfi"))))
"1k3m8zhbv04yrqvj7jlnh8f9xczdsmla59j9gcwsqvbg76y0hxy3"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1165,7 +1167,7 @@ positioning and geolocation plugins.")))
(define-public qttools
(package (inherit qtsvg)
(name "qttools")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1174,7 +1176,7 @@ positioning and geolocation plugins.")))
version ".tar.xz"))
(sha256
(base32
"0j1rl368sjknsmwp2f7bwqcb0sx13l3l4dxbm70873si9l8rf2l6"))))
"1iakl3hlyg51ri1czmis8mmb257b0y1zk2a2knybd3mq69wczc2v"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1193,7 +1195,7 @@ that helps in Qt development.")))
(define-public qtscript
(package (inherit qtsvg)
(name "qtscript")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1202,7 +1204,7 @@ that helps in Qt development.")))
version ".tar.xz"))
(sha256
(base32
"06a02230mj4bd8qvjaf2q97grzbj1c1rq36x7236fnhjsikbq7fa"))
"1zlvg3hc6h70d789g3kv6dxbwswzkskkm00bdgl01grwrdy4izg9"))
(patches (search-patches "qtscript-disable-tests.patch"))))
(native-inputs
`(("perl" ,perl)
@ -1217,7 +1219,7 @@ ECMAScript and Qt.")))
(define-public qtquickcontrols
(package (inherit qtsvg)
(name "qtquickcontrols")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1226,7 +1228,7 @@ ECMAScript and Qt.")))
version ".tar.xz"))
(sha256
(base32
"1rar337vv0dx52r2gxwiwy1axn0fpy79rka09xizjlxsdg3vnf0h"))))
"0qa4dlhn3iv9yvaic8hw86v6h8rn9sgq8xjfdaym04pfshfyypfm"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1241,7 +1243,7 @@ can be used to build complete interfaces in Qt Quick.")))
(define-public qtquickcontrols2
(package (inherit qtsvg)
(name "qtquickcontrols2")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1250,7 +1252,7 @@ can be used to build complete interfaces in Qt Quick.")))
version ".tar.xz"))
(sha256
(base32
"0dx2jag6l5a80220fvmf49z1psliqf1ijqx6jsvvzv81mpjjd59s"))))
"0q0mk2mjlf9ll0gdrdzxy8096s6g9draaqiwrlvdpa7lv14x7xzs"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1266,7 +1268,7 @@ not available.")))
(define-public qtgraphicaleffects
(package (inherit qtsvg)
(name "qtgraphicaleffects")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1275,7 +1277,7 @@ not available.")))
version ".tar.xz"))
(sha256
(base32
"1knapc14a80cn2f5bbfj7lhq9flr3v0gwjg9ka7xl8y642235w02"))))
"03xmwhapv0b2qj661iaqqrvhxc7qiid0acrp6rj85824ha2pyyj8"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1293,7 +1295,7 @@ coloring, and many more.")))
(define-public qtgamepad
(package (inherit qtsvg)
(name "qtgamepad")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1302,7 +1304,7 @@ coloring, and many more.")))
version ".tar.xz"))
(sha256
(base32
"150y7bc755l9y8w7nkg3gfw5n6rlj9hhq0ibc9g1xgllpr18qqq7"))))
"00wd3h465waxdghg2vdhs5pkj0xikwjn88l12477dksm8zdslzgp"))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)))
@ -1323,7 +1325,7 @@ and mobile applications targeting TV-like form factors.")))
(define-public qtscxml
(package (inherit qtsvg)
(name "qtscxml")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1332,7 +1334,7 @@ and mobile applications targeting TV-like form factors.")))
version ".tar.xz"))
(sha256
(base32
"1dpvjkvwc3fj86vay8q8vzym73cix7ri2ianx87ck0gqjny51adg"))
"141pfschv6zmcvvn3pi7f5vb4nf96zpngy80f9bly1sn58syl303"))
(modules '((guix build utils)))
(snippet
'(begin
@ -1354,7 +1356,7 @@ also contains functionality to support data models and executable content.")))
(define-public qtpurchasing
(package (inherit qtsvg)
(name "qtpurchasing")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1363,7 +1365,7 @@ also contains functionality to support data models and executable content.")))
version ".tar.xz"))
(sha256
(base32
"0xjsn7p629ni68vk4xlw2cvcs53ipcqv1pa4hck0nabddcgcnzkg"))))
"0lg8x7g7dkf95xwxq8b4yw4ypdz68igkscya96xwbklg3q08gc39"))))
(inputs
`(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)))
@ -1371,49 +1373,10 @@ also contains functionality to support data models and executable content.")))
(description "The Qt Purchasing module provides and in-app API for
purchasing goods and services.")))
(define-public qtcanvas3d
(package (inherit qtsvg)
(name "qtcanvas3d")
(version "5.12.7")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
(version-major+minor version) "/" version
"/submodules/" name "-everywhere-src-"
version ".tar.xz"))
(sha256
(base32
"0l0c1p6jwz5rygyxslfw7jw3wbd23w5n9zg04aqlh5g15qx52fmn"))
(modules '((guix build utils)))
(snippet
'(begin
(delete-file-recursively "examples/canvas3d/3rdparty")
#t))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
;; Building the tests depends on the bundled 3rd party javascript files,
;; and the test phase fails to import QtCanvas3D, causing the phase to
;; fail, so we skip building them for now.
((#:phases phases)
`(modify-phases ,phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(invoke "qmake" "QT_BUILD_PARTS = libs tools"
(string-append "PREFIX=" out)))))))
((#:tests? _ #f) #f))) ; TODO: Enable the tests
(native-inputs `())
(inputs
`(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)))
(synopsis "Qt Canvas 3D module")
(description "The Qt Canvas 3D module provides a way to make WebGL-like 3D
drawing calls from Qt Quick JavaScript.")))
(define-public qtcharts
(package (inherit qtsvg)
(name "qtcharts")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1422,7 +1385,7 @@ drawing calls from Qt Quick JavaScript.")))
version ".tar.xz"))
(sha256
(base32
"0pyg2lpxmhf4amj57zihp5ry0y9m39xq5hbcx4hqj78bdm96ah23"))))
"1drvm15i6n10b6a1acgarig120ppvqh3r6fqqdn8i3blx81m5cmd"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1440,7 +1403,7 @@ selecting one of the charts themes.")
(define-public qtdatavis3d
(package (inherit qtsvg)
(name "qtdatavis3d")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1449,7 +1412,7 @@ selecting one of the charts themes.")
version ".tar.xz"))
(sha256
(base32
"09wbv4g29sq5z2fphk2910albr3iv3l14nch3ml77w6drw9mgzq7"))))
"080fkpxg70m3c697wfnkjhca58b7r1xsqd559jzb21985pdh6g3j"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
@ -1467,7 +1430,7 @@ customized by using themes or by adding custom items and labels to them.")
(define-public qtnetworkauth
(package (inherit qtsvg)
(name "qtnetworkauth")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1476,7 +1439,7 @@ customized by using themes or by adding custom items and labels to them.")
version ".tar.xz"))
(sha256
(base32
"0sspni7zllhspk70yjj2d0li9r4rs3iflnksj8mvjx2yl9qpryyb"))))
"0pi6p7bq54kzij2p69cgib7n55k69jsq0yqq09yli645s4ym202g"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@ -1496,7 +1459,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
(define-public qtremoteobjects
(package (inherit qtsvg)
(name "qtremoteobjects")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1505,7 +1468,7 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
version ".tar.xz"))
(sha256
(base32
"03qjj7l63wn1zqkmlja9yrnc38rf6b3apnmsn0kw0h61x72awskd"))))
"1mhlws5w0igf5hw0l90p6dz6k7w16dqfbnk2li0zxdmayk2039m6"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:phases phases)
@ -1516,6 +1479,10 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
(substitute* "tests/auto/qml/qml.pro"
(("integration") "# integration")
(("usertypes") "# usertypes"))
;; disable failing tests: they need network
(substitute* "tests/auto/auto.pro"
(("integration_multiprocess proxy_multiprocess integration_external restart")
"integration_multiprocess"))
#t))))))
(inputs
`(("qtbase" ,qtbase)
@ -1529,7 +1496,7 @@ processes or computers.")))
(define-public qtspeech
(package (inherit qtsvg)
(name "qtspeech")
(version "5.12.7")
(version "5.14.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases/qt/"
@ -1538,7 +1505,7 @@ processes or computers.")))
version ".tar.xz"))
(sha256
(base32
"0q30m9l28zsdzdmny7wjskd2fjfrgh1l595wir6bhwhil95g3i0c"))))
"1nn6kspbp8hfkz1jhzc1qx1m9z7r1bgkdqgi9n4vl1q25yk8x7jy"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
@ -1573,7 +1540,7 @@ message.")))
version ".tar.xz"))
(sha256
(base32
"1yj6pcj945fpbc7nihav0plxpx8ikylmxjy7wqdv5znslgf59dw3"))
"0iy9lsl6zxlkca6x2p1506hbj3wmhnaipg23z027wfccbnkxcsg1"))
(modules '((ice-9 ftw)
(ice-9 match)
(srfi srfi-1)
@ -1582,7 +1549,8 @@ message.")))
(snippet
'(begin
(let ((preserved-third-party-files
'("base/third_party/dmg_fp"
'("base/third_party/cityhash"
"base/third_party/dmg_fp"
"base/third_party/dynamic_annotations"
"base/third_party/icu"
"base/third_party/libevent"
@ -1591,23 +1559,30 @@ message.")))
"base/third_party/symbolize"
"base/third_party/xdg_mime"
"base/third_party/xdg_user_dirs"
"net/third_party/http2"
"net/third_party/mozilla_security_manager"
"net/third_party/nss"
"net/third_party/spdy"
"net/third_party/quic"
"net/third_party/quiche"
"net/third_party/uri_template"
"third_party/abseil-cpp"
"third_party/angle"
"third_party/angle/src/common/third_party/base"
"third_party/angle/src/common/third_party/smhasher"
"third_party/angle/src/common/third_party/xxhash"
"third_party/angle/src/third_party/compiler"
"third_party/axe-core"
"third_party/blink"
"third_party/boringssl"
"third_party/boringssl/src/third_party/fiat"
"third_party/boringssl/src/third_party/sike"
"third_party/boringssl/linux-x86_64/crypto/third_party/sike"
"third_party/boringssl/linux-aarch64/crypto/third_party/sike"
"third_party/breakpad"
"third_party/brotli"
"third_party/ced"
"third_party/cld_3"
"third_party/crc32c"
"third_party/dav1d"
"third_party/dawn"
"third_party/ffmpeg"
"third_party/googletest"
"third_party/hunspell"
@ -1615,11 +1590,13 @@ message.")))
"third_party/icu"
"third_party/inspector_protocol"
"third_party/jinja2"
"third_party/jsoncpp"
"third_party/jstemplate"
"third_party/khronos"
"third_party/leveldatabase"
"third_party/libaddressinput"
"third_party/libjingle_xmpp"
"third_party/libjpeg"
"third_party/libpng"
"third_party/libsrtp"
"third_party/libsync"
@ -1632,11 +1609,14 @@ message.")))
"third_party/libyuv"
"third_party/lss"
"third_party/markupsafe"
"third_party/mesa"
"third_party/metrics_proto"
"third_party/modp_b64"
"third_party/nasm"
"third_party/one_euro_filter"
"third_party/opus"
"third_party/ots"
"third_party/perfetto"
"third_party/pffft"
"third_party/ply"
"third_party/polymer"
"third_party/protobuf"
@ -1644,14 +1624,25 @@ message.")))
"third_party/re2"
"third_party/rnnoise"
"third_party/skia"
"third_party/skia/include/third_party/skcms/skcms.h"
"third_party/skia/include/third_party/vulkan"
"third_party/skia/third_party/gif"
"third_party/skia/third_party/skcms"
"third_party/skia/third_party/vulkanmemoryallocator"
"third_party/smhasher"
"third_party/snappy"
"third_party/sqlite"
"third_party/usb_ids"
"third_party/usrsctp"
"third_party/web-animations-js"
"third_party/webrtc"
"third_party/webrtc/common_audio/third_party/fft4g"
"third_party/webrtc/common_audio/third_party/spl_sqrt_floor"
"third_party/webrtc/modules/third_party/fft"
"third_party/webrtc/modules/third_party/g711"
"third_party/webrtc/modules/third_party/g722"
"third_party/webrtc/rtc_base/third_party/base64"
"third_party/webrtc/rtc_base/third_party/sigslot"
"third_party/webrtc_overrides"
"third_party/widevine/cdm/widevine_cdm_common.h"
"third_party/widevine/cdm/widevine_cdm_version.h"
@ -1661,7 +1652,8 @@ message.")))
"url/third_party/mozilla"
"v8/src/third_party/utf8-decoder"
"v8/src/third_party/valgrind"
"v8/third_party/antlr4"
"v8/src/third_party/siphash"
"v8/third_party/v8/builtins"
"v8/third_party/inspector_protocol"))
(protected (make-regexp "\\.(gn|gyp)i?$")))
(define preserved-club
@ -1690,9 +1682,9 @@ message.")))
(list (string-join (list-head dirs delim) "/"))
(list-tail dirs delim))))
(define (remove-loudly file)
(format #t "deleting ~a...~%" file)
(force-output)
(delete-file file))
(format #t "deleting ~a...~%" file)
(force-output)
(delete-file file))
(define (delete-unwanted-files child stat flag base level)
(match flag
((or 'regular 'symlink 'stale-symlink)
@ -1741,9 +1733,8 @@ message.")))
"third_party/analytics/google-analytics-bundle.js"
(lambda (port)
(const #t)))))
;; Do not enable support for loading the Widevine DRM plugin.
(substitute* "src/core/config/common.pri"
(substitute* "src/buildtools/config/common.pri"
(("enable_widevine=true")
"enable_widevine=false"))
#t)))))
@ -1806,6 +1797,7 @@ message.")))
("snappy" ,snappy)
("udev" ,eudev)
("valgrind" ,valgrind)
("vulkan-headers" ,vulkan-headers)
("xcb-util" ,xcb-util)))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)