me
/
guix
Archived
1
0
Fork 0

gnu: python-memcached: Add patch to fix syntax warnings.

* gnu/packages/patches/python-memcached-syntax-warnings.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/python-xyz.scm (python-memcached)[source]: Add it.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
master
Tanguy Le Carrour 2020-06-16 13:51:13 +02:00 committed by Efraim Flashner
parent daca70770a
commit 8d5c55b2e8
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 28 additions and 1 deletions

View File

@ -35,6 +35,7 @@
# Copyright © 2020 Ryan Prior <rprior@protonmail.com>
# Copyright © 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
# Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
# Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
#
# This file is part of GNU Guix.
#
@ -1426,6 +1427,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-jedi-sort-project-test.patch \
%D%/packages/patches/python-libxml2-utf8.patch \
%D%/packages/patches/python-memcached-syntax-warnings.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \
%D%/packages/patches/python-packaging-test-arch.patch \

View File

@ -0,0 +1,24 @@
Problem reported upstream:
https://github.com/linsomniac/python-memcached/issues/176
---
memcache.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/memcache.py b/memcache.py
index 05b6657..b935681 100644
--- a/memcache.py
+++ b/memcache.py
@@ -1300,8 +1300,8 @@ class Client(threading.local):
key = key[1]
if key is None:
raise Client.MemcachedKeyNoneError("Key is None")
- if key is '':
- if key_extra_len is 0:
+ if key == '':
+ if key_extra_len == 0:
raise Client.MemcachedKeyNoneError("Key is empty")
# key is empty but there is some other component to key
--
2.26.2

View File

@ -11779,7 +11779,8 @@ running in.")
(uri (pypi-uri "python-memcached" version))
(sha256
(base32
"0kvyapavbirk2x3n1jx4yb9nyigrj1s3x15nm3qhpvhkpqvqdqm2"))))
"0kvyapavbirk2x3n1jx4yb9nyigrj1s3x15nm3qhpvhkpqvqdqm2"))
(patches (search-patches "python-memcached-syntax-warnings.patch"))))
(build-system python-build-system)
(propagated-inputs `(("python-six" ,python-six)))
(home-page