gnu: plotutils: Allow compilation with newer libpng.
* gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/patches/plotutils-libpng-jmpbuf.patch: New file. * gnu/packages/plotutils.scm (plotutils): Add `plotutils-libpng-jmpbuf.patch' as an input, and apply it.master
parent
f50ad3e777
commit
8e5e7299d1
|
@ -189,7 +189,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/glib-tests-prlimit.patch \
|
||||
gnu/packages/patches/glibc-bootstrap-system.patch \
|
||||
gnu/packages/patches/glibc-no-ld-so-cache.patch \
|
||||
gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch \
|
||||
gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch \
|
||||
gnu/packages/patches/grub-gets-undeclared.patch \
|
||||
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||
gnu/packages/patches/guile-default-utf8.patch \
|
||||
|
@ -204,8 +204,9 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/make-impure-dirs.patch \
|
||||
gnu/packages/patches/mcron-install.patch \
|
||||
gnu/packages/patches/perl-no-sys-dirs.patch \
|
||||
gnu/packages/patches/python-fix-dbm.patch \
|
||||
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
|
||||
gnu/packages/patches/procps-make-3.82.patch \
|
||||
gnu/packages/patches/python-fix-dbm.patch \
|
||||
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
||||
gnu/packages/patches/readline-link-ncurses.patch \
|
||||
gnu/packages/patches/scheme48-tests.patch \
|
||||
|
|
|
@ -0,0 +1,23 @@
|
|||
Use the `png_jmpbuf' accessor, as recommended since libpng 1.4.0:
|
||||
http://www.libpng.org/pub/png/src/libpng-1.2.x-to-1.4.x-summary.txt .
|
||||
|
||||
--- plotutils-2.6/libplot/z_write.c 2013-07-12 17:19:12.000000000 +0200
|
||||
+++ plotutils-2.6/libplot/z_write.c 2013-07-12 17:19:07.000000000 +0200
|
||||
@@ -164,7 +164,7 @@ _pl_z_maybe_output_image (S___(Plotter *
|
||||
}
|
||||
|
||||
/* cleanup after libpng errors (error handler does a longjmp) */
|
||||
- if (setjmp (png_ptr->jmpbuf))
|
||||
+ if (setjmp (png_jmpbuf (png_ptr)))
|
||||
{
|
||||
png_destroy_write_struct (&png_ptr, (png_info **)NULL);
|
||||
return -1;
|
||||
@@ -444,7 +444,7 @@ _our_error_fn_stdio (png_struct *png_ptr
|
||||
#endif
|
||||
}
|
||||
|
||||
- longjmp (png_ptr->jmpbuf, 1);
|
||||
+ longjmp (png_jmpbuf (png_ptr), 1);
|
||||
}
|
||||
|
||||
static void
|
|
@ -22,7 +22,8 @@
|
|||
#:use-module (guix download)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (gnu packages xorg)
|
||||
#:use-module (gnu packages libpng))
|
||||
#:use-module (gnu packages libpng)
|
||||
#:use-module (gnu packages))
|
||||
|
||||
(define-public plotutils
|
||||
(package
|
||||
|
@ -36,10 +37,13 @@
|
|||
(base32
|
||||
"1arkyizn5wbgvbh53aziv3s6lmd3wm9lqzkhxb3hijlp1y124hjg"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments '(#:patches (list (assoc-ref %build-inputs "patch/jmpbuf"))))
|
||||
(inputs `(("libpng" ,libpng)
|
||||
("libx11" ,libx11)
|
||||
("libxt" ,libxt)
|
||||
("libxaw" ,libxaw)))
|
||||
("libxaw" ,libxaw)
|
||||
("patch/jmpbuf"
|
||||
,(search-patch "plotutils-libpng-jmpbuf.patch"))))
|
||||
(home-page
|
||||
"http://www.gnu.org/software/plotutils/")
|
||||
(synopsis "Plotting utilities and library")
|
||||
|
|
Reference in New Issue