gnu: kwayland: Update to 5.108.0.
* gnu/packages/kde-frameworks.scm (kwayland): Update to 5.108.0. [arguments]: Run tests with testWaylandRegistry, testPlasmaShell and testPlasmaWindowModel skipped. * gnu/packages/patches/kwayland-skip-flaky-test.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Unregister it. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>master
parent
c277d7f634
commit
8f99f824d2
|
@ -1467,7 +1467,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/kobodeluxe-graphics-window-signed-char.patch \
|
||||
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
|
||||
%D%/packages/patches/kodi-mesa-eglchromium.patch \
|
||||
%D%/packages/patches/kwayland-skip-flaky-test.patch \
|
||||
%D%/packages/patches/laby-make-install.patch \
|
||||
%D%/packages/patches/laby-use-tmpdir-from-runtime.patch \
|
||||
%D%/packages/patches/ldns-drill-examples.patch \
|
||||
|
|
|
@ -1090,17 +1090,16 @@ protocols used in KDE Plasma.")
|
|||
(define-public kwayland
|
||||
(package
|
||||
(name "kwayland")
|
||||
(version "5.98.0")
|
||||
(version "5.108.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"mirror://kde/stable/frameworks/"
|
||||
(version-major+minor version) "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(patches (search-patches "kwayland-skip-flaky-test.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0c0953gm63xhrqb7aspvf28wi7x31mrgaid23dw5gqphkbgis5qw"))))
|
||||
"11xk1rzizmqb0haqkg24kdd54a3fdqrxr2kh056irbnksp9p8k03"))))
|
||||
(build-system qt-build-system)
|
||||
(native-inputs
|
||||
(list extra-cmake-modules pkg-config))
|
||||
|
@ -1119,7 +1118,14 @@ protocols used in KDE Plasma.")
|
|||
#~(modify-phases %standard-phases
|
||||
(add-before 'check 'set-XDG_RUNTIME_DIR
|
||||
(lambda _
|
||||
(setenv "XDG_RUNTIME_DIR" (getcwd)))))))
|
||||
(setenv "XDG_RUNTIME_DIR" (getcwd))))
|
||||
(replace 'check
|
||||
(lambda* (#:key tests? #:allow-other-keys)
|
||||
(when tests?
|
||||
(invoke "ctest" "-E"
|
||||
;; XXX: maybe is upstream bug
|
||||
"(kwayland-testWaylandRegistry|\
|
||||
kwayland-testPlasmaShell|kwayland-testPlasmaWindowModel)")))))))
|
||||
(home-page "https://community.kde.org/Frameworks")
|
||||
(synopsis "Qt-style API to interact with the wayland client and server")
|
||||
(description "As the names suggest they implement a Client respectively a
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
This test fails in the Guix CI for unknown and difficult to debug reasons.
|
||||
|
||||
diff --git a/autotests/client/test_plasma_window_model.cpp b/autotests/client/test_plasma_window_model.cpp
|
||||
--- a/autotests/client/test_plasma_window_model.cpp
|
||||
+++ b/autotests/client/test_plasma_window_model.cpp
|
||||
@@ -545,6 +545,7 @@ void PlasmaWindowModelTest::testPid()
|
||||
|
||||
void PlasmaWindowModelTest::testVirtualDesktops()
|
||||
{
|
||||
+ QSKIP("This test fails on the Guix CI (FIXME)");
|
||||
auto model = m_pw->createWindowModel();
|
||||
QVERIFY(model);
|
||||
QSignalSpy rowInsertedSpy(model, &PlasmaWindowModel::rowsInserted);
|
Reference in New Issue