Remove leftover patches.
* gnu/packages/patches/guix-test-networking.patch: Delete it. * gnu/packages/patches/libtool-skip-tests.patch: Delete it. * gnu/packages/patches/python-sqlite-3.8.4-test-fix.patch: Delete it. * gnu/packages/patches/udev-gir-libtool.patch: Delete it. * gnu-system.am (dist_patch_DATA): Remove them as well.master
parent
dd51caac55
commit
8fda1b7970
|
@ -448,7 +448,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/guile-default-utf8.patch \
|
||||
gnu/packages/patches/guile-linux-syscalls.patch \
|
||||
gnu/packages/patches/guile-relocatable.patch \
|
||||
gnu/packages/patches/guix-test-networking.patch \
|
||||
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||
gnu/packages/patches/hop-linker-flags.patch \
|
||||
|
@ -466,7 +465,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/liboop-mips64-deplibs-fix.patch \
|
||||
gnu/packages/patches/libmad-mips-newgcc.patch \
|
||||
gnu/packages/patches/libtheora-config-guess.patch \
|
||||
gnu/packages/patches/libtool-skip-tests.patch \
|
||||
gnu/packages/patches/libtool-skip-tests2.patch \
|
||||
gnu/packages/patches/libssh-CVE-2014-0017.patch \
|
||||
gnu/packages/patches/libvpx-fix-armhf-link.patch \
|
||||
|
@ -524,7 +522,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/pyqt-configure.patch \
|
||||
gnu/packages/patches/python-fix-tests.patch \
|
||||
gnu/packages/patches/python-libffi-mips-n32-fix.patch \
|
||||
gnu/packages/patches/python-sqlite-3.8.4-test-fix.patch \
|
||||
gnu/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
|
||||
gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch \
|
||||
gnu/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
||||
|
@ -550,7 +547,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/teckit-cstdio.patch \
|
||||
gnu/packages/patches/texi2html-document-encoding.patch \
|
||||
gnu/packages/patches/texi2html-i18n.patch \
|
||||
gnu/packages/patches/udev-gir-libtool.patch \
|
||||
gnu/packages/patches/unzip-CVE-2014-8139.patch \
|
||||
gnu/packages/patches/unzip-CVE-2014-8140.patch \
|
||||
gnu/packages/patches/unzip-CVE-2014-8141.patch \
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
Skip that test when the network is unreachable.
|
||||
|
||||
diff --git a/tests/packages.scm b/tests/packages.scm
|
||||
index 04e3b0b..6ac215b 100644
|
||||
--- a/tests/packages.scm
|
||||
+++ b/tests/packages.scm
|
||||
@@ -139,6 +139,8 @@
|
||||
(and (direct-store-path? source)
|
||||
(string-suffix? "utils.scm" source))))
|
||||
|
||||
+(unless (false-if-exception (getaddrinfo "www.gnu.org" "80" AI_NUMERICSERV))
|
||||
+ (test-skip 1))
|
||||
(test-equal "package-source-derivation, snippet"
|
||||
"OK"
|
||||
(let* ((file (search-bootstrap-binary "guile-2.0.9.tar.xz"
|
|
@ -1,55 +0,0 @@
|
|||
Because our GCC 'lib' spec automatically adds '-rpath' for each '-L'
|
||||
and a couple more '-rpath, there are two test failures:
|
||||
one in demo.test, and one in destdir.at. Disable these.
|
||||
|
||||
Also skip the nopic test on ARM and MIPS systems.
|
||||
|
||||
--- libtool-2.4.6/tests/demo.at.orig 2015-01-16 13:52:04.000000000 -0500
|
||||
+++ libtool-2.4.6/tests/demo.at 2015-02-16 10:48:51.435851966 -0500
|
||||
@@ -510,7 +510,7 @@
|
||||
AT_SETUP([force non-PIC objects])
|
||||
|
||||
AT_CHECK([case $host in
|
||||
-hppa*|x86_64*|s390*)
|
||||
+hppa*|x86_64*|s390*|arm*|mips*)
|
||||
# These hosts cannot use non-PIC shared libs
|
||||
exit 77 ;;
|
||||
*-solaris*|*-sunos*)
|
||||
--- libtool-2.4.6/tests/testsuite.orig 2015-02-15 11:15:25.000000000 -0500
|
||||
+++ libtool-2.4.6/tests/testsuite 2015-02-16 10:50:58.736483216 -0500
|
||||
@@ -8741,7 +8741,7 @@
|
||||
|
||||
{ set +x
|
||||
$as_echo "$at_srcdir/demo.at:535: case \$host in
|
||||
-hppa*|x86_64*|s390*)
|
||||
+hppa*|x86_64*|s390*|arm*|mips*)
|
||||
# These hosts cannot use non-PIC shared libs
|
||||
exit 77 ;;
|
||||
*-solaris*|*-sunos*)
|
||||
@@ -8766,7 +8766,7 @@
|
||||
"
|
||||
at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:535"
|
||||
( $at_check_trace; case $host in
|
||||
-hppa*|x86_64*|s390*)
|
||||
+hppa*|x86_64*|s390*|arm*|mips*)
|
||||
# These hosts cannot use non-PIC shared libs
|
||||
exit 77 ;;
|
||||
*-solaris*|*-sunos*)
|
||||
@@ -9298,7 +9298,7 @@
|
||||
#AT_START_34
|
||||
at_fn_group_banner 34 'demo.at:548' \
|
||||
"hardcoding library path" " " 4
|
||||
-at_xfail=no
|
||||
+at_xfail=yes
|
||||
test no = "$ACLOCAL" && at_xfail=yes
|
||||
test no = "$AUTOHEADER" && at_xfail=yes
|
||||
test no = "$AUTOMAKE" && at_xfail=yes
|
||||
@@ -27243,7 +27243,7 @@
|
||||
#AT_START_98
|
||||
at_fn_group_banner 98 'destdir.at:75' \
|
||||
"DESTDIR with in-package deplibs" " " 8
|
||||
-at_xfail=no
|
||||
+at_xfail=yes
|
||||
eval `$LIBTOOL --config | $GREP '^fast_install='`
|
||||
case $fast_install in no) :;; *) false;; esac && at_xfail=yes
|
||||
(
|
|
@ -1,15 +0,0 @@
|
|||
From resolution of upstream python issue #20901: http://bugs.python.org/issue20901
|
||||
|
||||
diff --git a/Lib/sqlite3/test/hooks.py b/Lib/sqlite3/test/hooks.py
|
||||
--- Lib/sqlite3/test/hooks.py
|
||||
+++ Lib/sqlite3/test/hooks.py
|
||||
@@ -162,7 +162,7 @@ class ProgressTests(unittest.TestCase):
|
||||
create table bar (a, b)
|
||||
""")
|
||||
second_count = len(progress_calls)
|
||||
- self.assertGreater(first_count, second_count)
|
||||
+ self.assertGreaterEqual(first_count, second_count)
|
||||
|
||||
def CheckCancelOperation(self):
|
||||
"""
|
||||
|
|
@ -1,17 +0,0 @@
|
|||
Without this patch, 'ld' as invoked by 'g-ir-scanner' fails to find -lgudev-1.0
|
||||
This is because libtool puts it in $(top_builddir)/.libs.
|
||||
|
||||
This patch forces 'g-ir-scanner' to use libtool, which enables it to find
|
||||
libgudev-1.0.la.
|
||||
|
||||
--- udev-182/Makefile.in 2014-06-22 14:55:07.000000000 +0200
|
||||
+++ udev-182/Makefile.in 2014-06-22 14:55:15.000000000 +0200
|
||||
@@ -3622,7 +3622,7 @@ test-sys-distclean:
|
||||
@ENABLE_GUDEV_TRUE@@ENABLE_INTROSPECTION_TRUE@ --namespace GUdev \
|
||||
@ENABLE_GUDEV_TRUE@@ENABLE_INTROSPECTION_TRUE@ --nsversion=1.0 \
|
||||
@ENABLE_GUDEV_TRUE@@ENABLE_INTROSPECTION_TRUE@ --include=GObject-2.0 \
|
||||
-@ENABLE_GUDEV_TRUE@@ENABLE_INTROSPECTION_TRUE@ --library=gudev-1.0 \
|
||||
+@ENABLE_GUDEV_TRUE@@ENABLE_INTROSPECTION_TRUE@ --library=gudev-1.0 --libtool=$(top_builddir)/libtool \
|
||||
@ENABLE_GUDEV_TRUE@@ENABLE_INTROSPECTION_TRUE@ --library-path=$(top_builddir)/src \
|
||||
@ENABLE_GUDEV_TRUE@@ENABLE_INTROSPECTION_TRUE@ --library-path=$(top_builddir)/src/gudev \
|
||||
@ENABLE_GUDEV_TRUE@@ENABLE_INTROSPECTION_TRUE@ --output $@ \
|
Reference in New Issue