gnu: torsocks: Update to 2.2.0.
* gnu/packages/patches/torsocks-dns-test.patch: Delete file. * gnu/local.mk: Remove it. * gnu/packages/tor.scm (torsocks): Update to 2.2.0. [source]: Remove patch. Change method from 'git-fetch' to 'url-fetch'. Remove 'file-name'. [arguments]: Remove 'bootstrap' phase. [native-inputs]: Remove autoconf, automake and libtool. Also remove obsoleted perl-test-harness. [home-page]: Use https URL. (define-module): Don't import perl. Signed-off-by: Marius Bakke <mbakke@fastmail.com>master
parent
15ca49b220
commit
91988aee12
|
@ -845,7 +845,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ttf2eot-cstddef.patch \
|
||||
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
|
||||
%D%/packages/patches/tophat-build-with-later-seqan.patch \
|
||||
%D%/packages/patches/torsocks-dns-test.patch \
|
||||
%D%/packages/patches/totem-debug-format-fix.patch \
|
||||
%D%/packages/patches/tuxpaint-stamps-path.patch \
|
||||
%D%/packages/patches/unzip-CVE-2014-8139.patch \
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
Skip DNS tests that rely on the ability to look up arbitary
|
||||
host names.
|
||||
|
||||
--- torsocks/tests/test_dns.c 2015-11-10 18:30:53.955941984 +0100
|
||||
+++ torsocks/tests/test_dns.c 2015-11-10 18:31:02.199941892 +0100
|
||||
@@ -134,11 +134,8 @@ static void test_getaddrinfo(const struc
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
/* Libtap call for the number of tests planned. */
|
||||
- plan_tests(NUM_TESTS);
|
||||
+ plan_tests(1);
|
||||
|
||||
- test_getaddrinfo(&tor_check);
|
||||
- test_gethostbyname(&tor_dir_auth1);
|
||||
- test_gethostbyaddr(&tor_dir_auth2);
|
||||
test_getaddrinfo(&tor_localhost);
|
||||
|
||||
return 0;
|
|
@ -30,7 +30,6 @@
|
|||
#:use-module (gnu packages libevent)
|
||||
#:use-module (gnu packages compression)
|
||||
#:use-module (gnu packages pcre)
|
||||
#:use-module (gnu packages perl)
|
||||
#:use-module (gnu packages python)
|
||||
#:use-module (gnu packages qt)
|
||||
#:use-module (gnu packages autotools)
|
||||
|
@ -73,28 +72,16 @@ applications based on the TCP protocol.")
|
|||
(define-public torsocks
|
||||
(package
|
||||
(name "torsocks")
|
||||
(version "2.0.0")
|
||||
(version "2.2.0")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://git.torproject.org/torsocks.git")
|
||||
(commit (string-append "v" version))))
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://people.torproject.org/~dgoulet/"
|
||||
name "/" name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0an2q5ail9z414riyjbkjkm29504hy778j914baz2gn5hlv2cfak"))
|
||||
(file-name (string-append name "-" version "-checkout"))
|
||||
(patches (search-patches "torsocks-dns-test.patch"))))
|
||||
"0byr9ga9w79qz4vp0m11sbmspad7fsal9wm67r4znzb7zb7cis19"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:phases (modify-phases %standard-phases
|
||||
(add-before 'configure 'bootstrap
|
||||
(lambda _
|
||||
(system* "autoreconf" "-vfi"))))))
|
||||
(native-inputs `(("autoconf" ,(autoconf-wrapper))
|
||||
("automake" ,automake)
|
||||
("libtool" ,libtool)
|
||||
("perl-test-harness" ,perl-test-harness)))
|
||||
(home-page "http://www.torproject.org/")
|
||||
(home-page "https://www.torproject.org/")
|
||||
(synopsis "Use socks-friendly applications with Tor")
|
||||
(description
|
||||
"Torsocks allows you to use most socks-friendly applications in a safe
|
||||
|
|
Reference in New Issue