gnu: blktrace: Update to db4f634.
* gnu/packages/linux.scm (blktrace): Update to db4f634. [revision]: Increment variable. [patches]: Remove variable. * gnu/packages/patches/blktrace-use-rmtree.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>master
parent
2eb39cd26c
commit
93a267b7a4
|
@ -768,7 +768,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
|
||||
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
|
||||
%D%/packages/patches/blktrace-use-rmtree.patch \
|
||||
%D%/packages/patches/bluez-CVE-2020-0556.patch \
|
||||
%D%/packages/patches/byobu-writable-status.patch \
|
||||
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
||||
|
|
|
@ -4014,8 +4014,8 @@ applications.")
|
|||
|
||||
(define-public blktrace
|
||||
;; Take a newer commit to get the fix for CVE-2018-10689.
|
||||
(let ((commit "f4f8ef7cdea138cfaa2f3ca0ee31fa23d3bcf1cc")
|
||||
(revision "0"))
|
||||
(let ((commit "db4f6340e04716285ea56fe26d76381c3adabe58")
|
||||
(revision "1"))
|
||||
(package
|
||||
(name "blktrace")
|
||||
(version (git-version "1.2.0" revision commit))
|
||||
|
@ -4027,9 +4027,8 @@ applications.")
|
|||
(url home-page)
|
||||
(commit commit)))
|
||||
(sha256
|
||||
(base32 "1ihdfimg7mfcgdm6l09xfqx5kdyv42x743dxp3z3w65q5vd7xy89"))
|
||||
(file-name (git-file-name name version))
|
||||
(patches (search-patches "blktrace-use-rmtree.patch"))))
|
||||
(base32 "0ah7xn4qnx09k6bm39p69av7d0c8cl6863drv6a1nf914sq1kpgp"))
|
||||
(file-name (git-file-name name version))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:make-flags
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
From 6d1ce4a3a1a561644695a50c00cbd28494728061 Mon Sep 17 00:00:00 2001
|
||||
From: Vincent Legoll <vincent.legoll@gmail.com>
|
||||
Date: Mon, 16 Mar 2020 11:43:19 +0100
|
||||
Subject: [PATCH 02/10] bno_plot.py: Use shutil.rmtree() instead of
|
||||
os.system('/bin/rm')
|
||||
|
||||
---
|
||||
btt/bno_plot.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/btt/bno_plot.py b/btt/bno_plot.py
|
||||
index f05cfdc..36fc524 100644
|
||||
--- a/btt/bno_plot.py
|
||||
+++ b/btt/bno_plot.py
|
||||
@@ -40,7 +40,7 @@ To exit the plotter, enter 'quit' or ^D at the 'gnuplot> ' prompt.
|
||||
|
||||
from __future__ import absolute_import
|
||||
from __future__ import print_function
|
||||
-import getopt, glob, os, sys, tempfile
|
||||
+import getopt, glob, os, sys, tempfile, shutil
|
||||
|
||||
verbose = 0
|
||||
cmds = """
|
||||
@@ -125,4 +125,4 @@ if __name__ == '__main__':
|
||||
sys.exit(1)
|
||||
|
||||
os.waitpid(pid, 0)
|
||||
- os.system('/bin/rm -rf ' + tmpdir)
|
||||
+ shutil.rmtree(tmpdir)
|
||||
--
|
||||
2.20.1
|
||||
|
Reference in New Issue