gnu: pigx-bsseq: Update to 0.1.7.
* gnu/packages/bioinformatics.scm (pigx-bsseq): Update to 0.1.7. [source]: Remove patch. [arguments]: Remove 'autoreconf phase. [native-inputs]: Remove automake and autoconf. * gnu/packages/patches/pigx-bsseq-no-citeproc.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove patch.
parent
6e54ce9ca9
commit
93c97bfffb
|
@ -1628,7 +1628,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/picard-fix-id3-rename-test.patch \
|
%D%/packages/patches/picard-fix-id3-rename-test.patch \
|
||||||
%D%/packages/patches/picprog-non-intel-support.patch \
|
%D%/packages/patches/picprog-non-intel-support.patch \
|
||||||
%D%/packages/patches/pidgin-add-search-path.patch \
|
%D%/packages/patches/pidgin-add-search-path.patch \
|
||||||
%D%/packages/patches/pigx-bsseq-no-citeproc.patch \
|
|
||||||
%D%/packages/patches/pinball-system-ltdl.patch \
|
%D%/packages/patches/pinball-system-ltdl.patch \
|
||||||
%D%/packages/patches/pingus-boost-headers.patch \
|
%D%/packages/patches/pingus-boost-headers.patch \
|
||||||
%D%/packages/patches/pingus-sdl-libs-config.patch \
|
%D%/packages/patches/pingus-sdl-libs-config.patch \
|
||||||
|
|
|
@ -10608,7 +10608,7 @@ in an easily configurable manner.")
|
||||||
(define-public pigx-bsseq
|
(define-public pigx-bsseq
|
||||||
(package
|
(package
|
||||||
(name "pigx-bsseq")
|
(name "pigx-bsseq")
|
||||||
(version "0.1.6")
|
(version "0.1.7")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://github.com/BIMSBbioinfo/pigx_bsseq/"
|
(uri (string-append "https://github.com/BIMSBbioinfo/pigx_bsseq/"
|
||||||
|
@ -10616,8 +10616,7 @@ in an easily configurable manner.")
|
||||||
"/pigx_bsseq-" version ".tar.gz"))
|
"/pigx_bsseq-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1dipikph0xdr8fp0h1flpafcrg60y4aabljg8fl1v92j3gxdggmw"))
|
"1hfiignq3410dbl6f67vc6zr69abknpcgxixx475dspky2jb5lyn"))))
|
||||||
(patches (search-patches "pigx-bsseq-no-citeproc.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(;; TODO: tests currently require 12+GB of RAM. See
|
`(;; TODO: tests currently require 12+GB of RAM. See
|
||||||
|
@ -10625,18 +10624,6 @@ in an easily configurable manner.")
|
||||||
#:tests? #f
|
#:tests? #f
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
(add-before 'bootstrap 'autoreconf
|
|
||||||
(lambda _
|
|
||||||
;; This was fixed in commit
|
|
||||||
;; d56ac732524da659afbbb0972f7a87fa178ae58e, but there is no
|
|
||||||
;; release with this fix.
|
|
||||||
(call-with-output-file "VERSION"
|
|
||||||
(lambda (port) (display ,version port)))
|
|
||||||
;; https://github.com/BIMSBbioinfo/pigx_bsseq/issues/181
|
|
||||||
(substitute* "m4/ax_r_package.m4"
|
|
||||||
(("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
|
|
||||||
"if(system.file(package=\"PKG\") == \"\")"))
|
|
||||||
(invoke "autoreconf" "-vif")))
|
|
||||||
(add-before 'configure 'set-PYTHONPATH
|
(add-before 'configure 'set-PYTHONPATH
|
||||||
(lambda _
|
(lambda _
|
||||||
(setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH"))))
|
(setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH"))))
|
||||||
|
@ -10648,7 +10635,7 @@ in an easily configurable manner.")
|
||||||
(search-input-directory inputs
|
(search-input-directory inputs
|
||||||
"share/zoneinfo")))))))
|
"share/zoneinfo")))))))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list tzdata automake autoconf))
|
(list tzdata))
|
||||||
(inputs
|
(inputs
|
||||||
(list coreutils
|
(list coreutils
|
||||||
sed
|
sed
|
||||||
|
|
|
@ -1,33 +0,0 @@
|
||||||
diff -Naur pigx_bsseq-0.1.5/configure.ac pigx_bsseq-0.1.5.patched/configure.ac
|
|
||||||
--- pigx_bsseq-0.1.5/configure.ac 2021-06-08 15:28:08.000000000 +0200
|
|
||||||
+++ pigx_bsseq-0.1.5.patched/configure.ac 2021-10-05 14:43:56.806529137 +0200
|
|
||||||
@@ -38,7 +38,6 @@
|
|
||||||
find_or_override_prog([GNUBASH], [bash])
|
|
||||||
find_or_override_prog([SNAKEMAKE], [snakemake])
|
|
||||||
find_or_override_prog([PANDOC], [pandoc])
|
|
||||||
-find_or_override_prog([PANDOC_CITEPROC], [pandoc-citeproc])
|
|
||||||
find_or_override_prog([FASTQC], [fastqc])
|
|
||||||
find_or_override_prog([MULTIQC], [multiqc])
|
|
||||||
find_or_override_prog([TRIMGALORE], [trim_galore])
|
|
||||||
diff -Naur pigx_bsseq-0.1.5/Makefile.in pigx_bsseq-0.1.5.patched/Makefile.in
|
|
||||||
--- pigx_bsseq-0.1.5/Makefile.in 2021-06-08 16:17:03.000000000 +0200
|
|
||||||
+++ pigx_bsseq-0.1.5.patched/Makefile.in 2021-10-05 14:43:34.635876855 +0200
|
|
||||||
@@ -408,7 +408,6 @@
|
|
||||||
PACKAGE_URL = @PACKAGE_URL@
|
|
||||||
PACKAGE_VERSION = @PACKAGE_VERSION@
|
|
||||||
PANDOC = @PANDOC@
|
|
||||||
-PANDOC_CITEPROC = @PANDOC_CITEPROC@
|
|
||||||
PATH_SEPARATOR = @PATH_SEPARATOR@
|
|
||||||
PYTHON = @PYTHON@
|
|
||||||
PYTHONPATH = @PYTHONPATH@
|
|
||||||
diff -Naur pigx_bsseq-0.1.5/pigx-common/common/pigx-runner.in pigx_bsseq-0.1.5.patched/pigx-common/common/pigx-runner.in
|
|
||||||
--- pigx_bsseq-0.1.5/pigx-common/common/pigx-runner.in 2021-06-08 10:14:29.000000000 +0200
|
|
||||||
+++ pigx_bsseq-0.1.5.patched/pigx-common/common/pigx-runner.in 2021-10-05 14:43:44.296161069 +0200
|
|
||||||
@@ -375,7 +375,6 @@
|
|
||||||
if path.exists(bin): shutil.rmtree(bin)
|
|
||||||
os.makedirs(bin, exist_ok=True)
|
|
||||||
os.symlink('@PANDOC@', path.join(bin, "pandoc"))
|
|
||||||
- os.symlink('@PANDOC_CITEPROC@', path.join(bin, "pandoc-citeproc"))
|
|
||||||
os.symlink('@RSCRIPT@', path.join(bin, "Rscript"))
|
|
||||||
os.environ['PATH'] = path.abspath(bin) + ":" + os.environ['PATH']
|
|
||||||
os.environ['PIGX_PATH'] = path.abspath(bin) + ":" + os.environ['PATH']
|
|
Reference in New Issue