From 941ef1a1e54893ca917ebbaa4b8cc14b5ce9b75c Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Tue, 23 Jul 2019 19:06:23 +0200
Subject: [PATCH] gnu: boost: Do not install CMake files.

Fixes <https://bugs.gnu.org/36721>.

* gnu/packages/boost.scm (boost)[arguments]: Add "--no-cmake-config" to
<#:configure-flags>.
---
 gnu/packages/boost.scm | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 6b8eebcecb..a2253a9efc 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -69,6 +69,11 @@
        #:make-flags
        (list "threading=multi" "link=shared"
 
+             ;; XXX: Disable installation of Boosts modular CMake config scripts
+             ;; which conflicts in 1.70.0 with the ones provided by CMake.
+             ;; See <https://bugs.gnu.org/36721>.
+             "--no-cmake-config"
+
              ;; Set the RUNPATH to $libdir so that the libs find each other.
              (string-append "linkflags=-Wl,-rpath="
                             (assoc-ref %outputs "out") "/lib"))