From 9479e941b8961cb7e2d80adcab8f3207b8cc9b3c Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:44:23 +0200
Subject: [PATCH] gnu: Add texlive-beamersubframe.

* gnu/packages/tex.scm (texlive-beamersubframe): New variable.
---
 gnu/packages/tex.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e3dc01b62a..dd8d153e73 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -73759,6 +73759,35 @@ provided by the Beamer class (for example, with rounded corners and shadows).
 Good looking posters may be created very rapidly.")
     (license (list license:lppl license:gpl3+))))
 
+(define-public texlive-beamersubframe
+  (package
+    (name "texlive-beamersubframe")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/beamersubframe/"
+                   "source/latex/beamersubframe/"
+                   "tex/latex/beamersubframe/")
+             (base32
+              "1z1bgrbpfcxr66ldnp2ymr4l6qmmc06v5k91q2av4kfjvanb9bi3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'no-example-file
+            (lambda _
+              (substitute* "source/latex/beamersubframe/beamersubframe.ins"
+                (("\\\\generateexampletrue") "\\generateexamplefalse")))))))
+    (home-page "https://ctan.org/pkg/beamersubframe")
+    (synopsis "Reorder frames in the PDF file")
+    (description
+     "The package provides a method to reorder frames in the PDF file without
+reordering the source.  Its principal use is to embed or append frames with
+details on some subject.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar