gnu: racket: Update to 7.3.
* gnu/packages/scheme.scm (racket): Update to 7.3. * gnu/packages/patches/racket-store-checksum-override.patch: Update for Racket 7.3.master
parent
944cb87a33
commit
948ecc27dd
|
@ -7,12 +7,8 @@ because the store is immutable. This patch makes Racket ignore
|
||||||
checksums for files in the store.
|
checksums for files in the store.
|
||||||
|
|
||||||
See <https://debbugs.gnu.org/30680> for details.
|
See <https://debbugs.gnu.org/30680> for details.
|
||||||
---
|
|
||||||
collects/compiler/private/cm-minimal.rkt | 8 +++++++-
|
|
||||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/collects/compiler/private/cm-minimal.rkt b/collects/compiler/private/cm-minimal.rkt
|
---
|
||||||
index a5a5407..15af6b8 100644
|
|
||||||
--- a/collects/compiler/private/cm-minimal.rkt
|
--- a/collects/compiler/private/cm-minimal.rkt
|
||||||
+++ b/collects/compiler/private/cm-minimal.rkt
|
+++ b/collects/compiler/private/cm-minimal.rkt
|
||||||
@@ -7,6 +7,7 @@
|
@@ -7,6 +7,7 @@
|
||||||
|
@ -20,10 +16,10 @@ index a5a5407..15af6b8 100644
|
||||||
racket/path
|
racket/path
|
||||||
racket/promise
|
racket/promise
|
||||||
+ racket/string
|
+ racket/string
|
||||||
openssl/sha1
|
file/sha1
|
||||||
setup/collects
|
setup/collects
|
||||||
compiler/compilation-path
|
setup/cross-system
|
||||||
@@ -543,6 +544,10 @@
|
@@ -940,6 +941,10 @@
|
||||||
#f
|
#f
|
||||||
(list src-hash recorded-hash)))
|
(list src-hash recorded-hash)))
|
||||||
|
|
||||||
|
@ -34,16 +30,13 @@ index a5a5407..15af6b8 100644
|
||||||
(define (rkt->ss p)
|
(define (rkt->ss p)
|
||||||
(if (path-has-extension? p #".rkt")
|
(if (path-has-extension? p #".rkt")
|
||||||
(path-replace-extension p #".ss")
|
(path-replace-extension p #".ss")
|
||||||
@@ -595,7 +600,8 @@
|
@@ -1015,6 +1020,7 @@
|
||||||
(trace-printf "newer src... ~a > ~a" path-time path-zo-time)
|
(trace-printf "newer src... ~a > ~a" path-time path-zo-time)
|
||||||
;; If `sha1-only?', then `maybe-compile-zo' returns a #f or thunk:
|
(maybe-compile-zo deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen
|
||||||
(maybe-compile-zo sha1-only? deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen)]
|
#:trying-sha1? sha1-only?)]
|
||||||
- [(different-source-sha1-and-dep-recorded path deps)
|
- [(different-source-sha1-and-dep-recorded path deps)
|
||||||
+ [(and (not (store-reference? path))
|
+ [(and (not (store-reference? path))
|
||||||
+ (different-source-sha1-and-dep-recorded path deps))
|
+ (different-source-sha1-and-dep-recorded path deps))
|
||||||
=> (lambda (difference)
|
=> (lambda (difference)
|
||||||
(trace-printf "different src hash... ~a" difference)
|
(trace-printf "different src hash ~a for ~a..." difference path)
|
||||||
;; If `sha1-only?', then `maybe-compile-zo' returns a #f or thunk:
|
(maybe-compile-zo deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen
|
||||||
--
|
|
||||||
2.18.0
|
|
||||||
|
|
|
@ -437,7 +437,7 @@ implementation techniques and as an expository tool.")
|
||||||
(define-public racket
|
(define-public racket
|
||||||
(package
|
(package
|
||||||
(name "racket")
|
(name "racket")
|
||||||
(version "7.0")
|
(version "7.3")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (list (string-append "http://mirror.racket-lang.org/installers/"
|
(uri (list (string-append "http://mirror.racket-lang.org/installers/"
|
||||||
|
@ -447,7 +447,7 @@ implementation techniques and as an expository tool.")
|
||||||
version "/racket-" version "-src.tgz")))
|
version "/racket-" version "-src.tgz")))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1glv5amsp9xp480d4yr63hhm9kkyav06yl3a6p489nkr4cln0j9a"))
|
"0h6072njhb87rkz4arijvahxgjzn8r14s4wns0ijvxm89bg136yl"))
|
||||||
(patches (search-patches
|
(patches (search-patches
|
||||||
"racket-store-checksum-override.patch"))))
|
"racket-store-checksum-override.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
|
Reference in New Issue