gnu: hdf5@1.10: Update to 1.10.5.
* gnu/packages/maths.scm (hdf5-1.10): Update to 1.10.5. Remove "hdf5-mpi-deprecations.patch". * gnu/packages/patches/hdf5-mpi-deprecations.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it.master
parent
6212146f88
commit
94fea21b21
|
@ -969,7 +969,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/hdf4-shared-fortran.patch \
|
%D%/packages/patches/hdf4-shared-fortran.patch \
|
||||||
%D%/packages/patches/hdf4-tirpc.patch \
|
%D%/packages/patches/hdf4-tirpc.patch \
|
||||||
%D%/packages/patches/hdf5-config-date.patch \
|
%D%/packages/patches/hdf5-config-date.patch \
|
||||||
%D%/packages/patches/hdf5-mpi-deprecations.patch \
|
|
||||||
%D%/packages/patches/hdf5-1.8-mpi-deprecations.patch \
|
%D%/packages/patches/hdf5-1.8-mpi-deprecations.patch \
|
||||||
%D%/packages/patches/hdf-eos2-build-shared.patch \
|
%D%/packages/patches/hdf-eos2-build-shared.patch \
|
||||||
%D%/packages/patches/hdf-eos2-remove-gctp.patch \
|
%D%/packages/patches/hdf-eos2-remove-gctp.patch \
|
||||||
|
|
|
@ -925,7 +925,7 @@ extremely large and complex data collections.")
|
||||||
|
|
||||||
(define-public hdf5-1.10
|
(define-public hdf5-1.10
|
||||||
(package (inherit hdf5)
|
(package (inherit hdf5)
|
||||||
(version "1.10.4")
|
(version "1.10.5")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -939,9 +939,8 @@ extremely large and complex data collections.")
|
||||||
(take (string-split version #\.) 2))
|
(take (string-split version #\.) 2))
|
||||||
"/src/hdf5-" version ".tar.bz2")))
|
"/src/hdf5-" version ".tar.bz2")))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1pr85fa1sh2ky6ai2hs3f21lp252grl2cq3wbyi4rh7dm83gyrqj"))
|
(base32 "0i3g6v521vigzbx8wpd32ibsiiw92r65ca3qdbn0d8fj8f4fmmk8"))
|
||||||
(patches (search-patches "hdf5-config-date.patch"
|
(patches (search-patches "hdf5-config-date.patch"))))))
|
||||||
"hdf5-mpi-deprecations.patch"))))))
|
|
||||||
|
|
||||||
(define-public hdf-java
|
(define-public hdf-java
|
||||||
(package
|
(package
|
||||||
|
|
|
@ -1,61 +0,0 @@
|
||||||
--- a/src/H5.c
|
|
||||||
+++ b/src/H5.c
|
|
||||||
@@ -138,7 +138,7 @@
|
|
||||||
if (mpi_initialized && !mpi_finalized) {
|
|
||||||
int key_val;
|
|
||||||
|
|
||||||
- if(MPI_SUCCESS != (mpi_code = MPI_Comm_create_keyval(MPI_NULL_COPY_FN,
|
|
||||||
+ if(MPI_SUCCESS != (mpi_code = MPI_Comm_create_keyval(MPI_COMM_NULL_COPY_FN,
|
|
||||||
(MPI_Comm_delete_attr_function *)H5_mpi_delete_cb,
|
|
||||||
&key_val, NULL)))
|
|
||||||
HMPI_GOTO_ERROR(FAIL, "MPI_Comm_create_keyval failed", mpi_code)
|
|
||||||
--- hdf5-1.10.4/testpar/t_cache.c
|
|
||||||
+++ hdf5-1.10.4/testpar/t_cache.c
|
|
||||||
@@ -1217,20 +1217,20 @@
|
|
||||||
struct mssg_t sample; /* used to compute displacements */
|
|
||||||
|
|
||||||
/* setup the displacements array */
|
|
||||||
- if ( ( MPI_SUCCESS != MPI_Address(&sample.req, &displs[0]) ) ||
|
|
||||||
- ( MPI_SUCCESS != MPI_Address(&sample.src, &displs[1]) ) ||
|
|
||||||
- ( MPI_SUCCESS != MPI_Address(&sample.dest, &displs[2]) ) ||
|
|
||||||
- ( MPI_SUCCESS != MPI_Address(&sample.mssg_num, &displs[3]) ) ||
|
|
||||||
- ( MPI_SUCCESS != MPI_Address(&sample.base_addr, &displs[4]) ) ||
|
|
||||||
- ( MPI_SUCCESS != MPI_Address(&sample.len, &displs[5]) ) ||
|
|
||||||
- ( MPI_SUCCESS != MPI_Address(&sample.ver, &displs[6]) ) ||
|
|
||||||
- ( MPI_SUCCESS != MPI_Address(&sample.count, &displs[7]) ) ||
|
|
||||||
- ( MPI_SUCCESS != MPI_Address(&sample.magic, &displs[8]) ) ) {
|
|
||||||
+ if ( ( MPI_SUCCESS != MPI_Get_address(&sample.req, &displs[0]) ) ||
|
|
||||||
+ ( MPI_SUCCESS != MPI_Get_address(&sample.src, &displs[1]) ) ||
|
|
||||||
+ ( MPI_SUCCESS != MPI_Get_address(&sample.dest, &displs[2]) ) ||
|
|
||||||
+ ( MPI_SUCCESS != MPI_Get_address(&sample.mssg_num, &displs[3]) ) ||
|
|
||||||
+ ( MPI_SUCCESS != MPI_Get_address(&sample.base_addr, &displs[4]) ) ||
|
|
||||||
+ ( MPI_SUCCESS != MPI_Get_address(&sample.len, &displs[5]) ) ||
|
|
||||||
+ ( MPI_SUCCESS != MPI_Get_address(&sample.ver, &displs[6]) ) ||
|
|
||||||
+ ( MPI_SUCCESS != MPI_Get_address(&sample.count, &displs[7]) ) ||
|
|
||||||
+ ( MPI_SUCCESS != MPI_Get_address(&sample.magic, &displs[8]) ) ) {
|
|
||||||
|
|
||||||
nerrors++;
|
|
||||||
success = FALSE;
|
|
||||||
if ( verbose ) {
|
|
||||||
- HDfprintf(stdout, "%d:%s: MPI_Address() call failed.\n",
|
|
||||||
+ HDfprintf(stdout, "%d:%s: MPI_Get_address() call failed.\n",
|
|
||||||
world_mpi_rank, FUNC);
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -1245,14 +1245,14 @@
|
|
||||||
|
|
||||||
if ( success ) {
|
|
||||||
|
|
||||||
- result = MPI_Type_struct(9, block_len, displs, mpi_types, &mpi_mssg_t);
|
|
||||||
+ result = MPI_Type_create_struct(9, block_len, displs, mpi_types, &mpi_mssg_t);
|
|
||||||
|
|
||||||
if ( result != MPI_SUCCESS ) {
|
|
||||||
|
|
||||||
nerrors++;
|
|
||||||
success = FALSE;
|
|
||||||
if ( verbose ) {
|
|
||||||
- HDfprintf(stdout, "%d:%s: MPI_Type_struct() call failed.\n",
|
|
||||||
+ HDfprintf(stdout, "%d:%s: MPI_Type_create_struct() call failed.\n",
|
|
||||||
world_mpi_rank, FUNC);
|
|
||||||
}
|
|
||||||
}
|
|
Reference in New Issue