me
/
guix
Archived
1
0
Fork 0

gnu: gdbm: Update to 1.19.

* gnu/packages/patches/gdbm-gcc-compat.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/dbm.scm (gdbm)[source]: Remove 'patches'.
master
Ludovic Courtès 2020-12-27 18:44:57 +01:00
parent bbd2864272
commit 951610567f
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 3 additions and 21 deletions

View File

@ -1044,7 +1044,6 @@ dist_patch_DATA = \
%D%/packages/patches/gdb-hurd.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gd-brect-bounds.patch \
%D%/packages/patches/gdbm-gcc-compat.patch \
%D%/packages/patches/gdm-default-session.patch \
%D%/packages/patches/genimage-signedness.patch \
%D%/packages/patches/geoclue-config.patch \

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012, 2013, 2014, 2016, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
@ -134,15 +134,14 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(define-public gdbm
(package
(name "gdbm")
(version "1.18.1")
(version "1.19")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gdbm/gdbm-"
version ".tar.gz"))
(patches (search-patches "gdbm-gcc-compat.patch"))
(sha256
(base32
"1p4ibds6z3ccy65lkmd6lm7js0kwifvl53r0fd759fjxgr917rl6"))))
"1g342f0xhh8xbc8p9vrr34clhxz57589k50dibhp5f9284hi5v9p"))))
(arguments `(#:configure-flags '("--enable-libgdbm-compat"
"--disable-static")))
(build-system gnu-build-system)

View File

@ -1,16 +0,0 @@
Fix build failure with GCC 10 due to duplicate definitions. It can be
reproduced on older compilers with -fno-common.
Fix taken from Gentoo: https://bugs.gentoo.org/705898
--- a/src/parseopt.c
+++ b/src/parseopt.c
@@ -255,8 +255,6 @@ print_option_descr (const char *descr, size_t lmargin, size_t rmargin)
}
char *parseopt_program_name;
-char *parseopt_program_doc;
-char *parseopt_program_args;
const char *program_bug_address = "<" PACKAGE_BUGREPORT ">";
void (*parseopt_help_hook) (FILE *stream);