gnu: gvfs: Fix build with libplist 2.2.0.
* gnu/packages/gnome.scm (gvfs)[source]: Add patch. * gnu/packages/patches/gvfs-add-support-for-libplist-2.2.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.master
parent
d82a5e70c8
commit
95b90decd3
|
@ -1101,6 +1101,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch \
|
||||
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
%D%/packages/patches/gtksourceview-2-add-default-directory.patch \
|
||||
%D%/packages/patches/gvfs-add-support-for-libplist-2.2.patch \
|
||||
%D%/packages/patches/gzdoom-search-in-installed-share.patch \
|
||||
%D%/packages/patches/gzdoom-find-system-libgme.patch \
|
||||
%D%/packages/patches/hdf4-architectures.patch \
|
||||
|
|
|
@ -5343,7 +5343,10 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
|
|||
"gvfs-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1cfnzamr4mvgpf6yhm28lh9cafy9z6842s8jpbqnfizfxybg8ylj"))))
|
||||
"1cfnzamr4mvgpf6yhm28lh9cafy9z6842s8jpbqnfizfxybg8ylj"))
|
||||
;; This patch may be removed when upgrading to version 1.46.x.
|
||||
(patches
|
||||
(search-patches "gvfs-add-support-for-libplist-2.2.patch"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
'(#:glib-or-gtk? #t
|
||||
|
|
|
@ -0,0 +1,34 @@
|
|||
Source: https://gitlab.gnome.org/GNOME/gvfs/-/commit/13551f3f40d41f1357126ac5a26d0fa012cd8123
|
||||
|
||||
Note: This change should be incorporated into stable version 1.46.x of gvfs.
|
||||
|
||||
From 13551f3f40d41f1357126ac5a26d0fa012cd8123 Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Tue, 16 Jun 2020 13:28:35 +0200
|
||||
Subject: [PATCH] afc: Add support for libplist-2.2
|
||||
|
||||
Which changed name from libplist to libplist-2.0 to embed its API
|
||||
version number in the library name.
|
||||
---
|
||||
meson.build | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 1750f65ca..187bfd55f 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -357,7 +357,10 @@ config_h.set('HAVE_LOGIND', enable_logind)
|
||||
enable_afc = get_option('afc')
|
||||
if enable_afc
|
||||
libimobiledevice_dep = dependency('libimobiledevice-1.0', version: '>= 1.2')
|
||||
- libplist_dep = dependency('libplist', version: '>= 0.15')
|
||||
+ libplist_dep = dependency('libplist-2.0', required: false)
|
||||
+ if not libplist_dep.found()
|
||||
+ libplist_dep = dependency('libplist', version: '>= 0.15')
|
||||
+ endif
|
||||
endif
|
||||
|
||||
# *** Check if we should build with GOA volume monitor ***
|
||||
--
|
||||
GitLab
|
||||
|
Reference in New Issue